summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-01-20 01:36:05 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-01-20 01:36:05 +0000
commit847ea787d4a4b739575c4531b3e38e1b95eca7a5 (patch)
tree437163c58a1bb0dc55668c32b05ce4817e7ed20e /games-fps/doom3
parentVersion bump using eapi 2 (diff)
downloadgentoo-2-847ea787d4a4b739575c4531b3e38e1b95eca7a5.tar.gz
gentoo-2-847ea787d4a4b739575c4531b3e38e1b95eca7a5.tar.bz2
gentoo-2-847ea787d4a4b739575c4531b3e38e1b95eca7a5.zip
version bump (ebuild submitted by Paul Bredbury and YLD via bug #167173)
(Portage version: 2.1.6.4/cvs/Linux 2.6.27.8 i686)
Diffstat (limited to 'games-fps/doom3')
-rw-r--r--games-fps/doom3/ChangeLog10
-rw-r--r--games-fps/doom3/doom3-1.3.1304.ebuild103
2 files changed, 111 insertions, 2 deletions
diff --git a/games-fps/doom3/ChangeLog b/games-fps/doom3/ChangeLog
index e9c1254a8076..c444847265c2 100644
--- a/games-fps/doom3/ChangeLog
+++ b/games-fps/doom3/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/doom3
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/ChangeLog,v 1.34 2008/09/26 17:53:56 zmedico Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/ChangeLog,v 1.35 2009/01/20 01:36:05 mr_bones_ Exp $
+
+*doom3-1.3.1304 (20 Jan 2009)
+
+ 20 Jan 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +doom3-1.3.1304.ebuild:
+ version bump (ebuild submitted by Paul Bredbury and YLD via bug #167173)
26 Sep 2008; Zac Medico <zmedico@gentoo.org> doom3-1.3.1302-r2.ebuild:
Set PROPERTIES=interactive since GAMES_CHECK_LICENSE=yes is set.
diff --git a/games-fps/doom3/doom3-1.3.1304.ebuild b/games-fps/doom3/doom3-1.3.1304.ebuild
new file mode 100644
index 000000000000..91569c4cff11
--- /dev/null
+++ b/games-fps/doom3/doom3-1.3.1304.ebuild
@@ -0,0 +1,103 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/doom3/doom3-1.3.1304.ebuild,v 1.1 2009/01/20 01:36:05 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_PV="1.3.1.1304"
+
+DESCRIPTION="3rd installment of the classic iD 3D first-person shooter"
+HOMEPAGE="http://www.doom3.com/"
+SRC_URI="mirror://idsoftware/doom3/linux/doom3-linux-${MY_PV}.x86.run
+ http://zerowing.idsoftware.com/linux/${PN}.png"
+
+LICENSE="DOOM3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa cdinstall dedicated opengl roe"
+RESTRICT="strip"
+
+DEPEND="app-arch/bzip2
+ app-arch/tar"
+RDEPEND="sys-libs/glibc
+ opengl? ( virtual/opengl )
+ alsa? ( >=media-libs/alsa-lib-1.0.6 )
+ cdinstall? (
+ >=games-fps/doom3-data-1.1.1282-r1
+ roe? ( games-fps/doom3-roe ) )
+ amd64? (
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-soundlibs
+ || (
+ >=app-emulation/emul-linux-x86-xlibs-7.0
+ x11-drivers/nvidia-drivers
+ >=x11-drivers/ati-drivers-8.8.25-r1 ) )"
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+GAMES_CHECK_LICENSE="yes"
+
+QA_TEXTRELS="${dir:1}/pb/pbcl.so
+ ${dir:1}/pb/pbcls.so
+ ${dir:1}/pb/pbag.so
+ ${dir:1}/pb/pbsv.so
+ ${dir:1}/pb/pbags.so"
+
+QA_EXECSTACK="${dir:1}/libgcc_s.so.1
+ ${dir:1}/libstdc++.so.6
+ ${dir:1}/doom.x86
+ ${dir:1}/doomded.x86"
+
+src_unpack() {
+ unpack_makeself ${PN}-linux-${MY_PV}.x86.run
+}
+
+src_install() {
+ insinto "${dir}"
+ doins License.txt CHANGES README version.info ${PN}.png || die
+
+ exeinto "${dir}"
+ doexe *.so.? || die "doexe libs"
+ doexe openurl.sh || die "openurl.sh"
+
+ if use amd64 ; then
+ doexe bin/Linux/amd64/doom{,ded}.x86 || die "doexe amd64"
+ else
+ doexe bin/Linux/x86/doom{,ded}.x86 || die "doexe x86"
+ fi
+
+ doins -r base d3xp pb || die "doins base d3xp pb"
+
+ games_make_wrapper ${PN} ./doom.x86 "${dir}" "${dir}"
+ if use dedicated ; then
+ games_make_wrapper ${PN}-ded ./doomded.x86 "${dir}" "${dir}"
+ fi
+
+ doicon "${DISTDIR}"/${PN}.png || die "doicon"
+ make_desktop_entry ${PN} "Doom III"
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ if ! use cdinstall; then
+ elog "You need to copy pak000.pk4, pak001.pk4, pak002.pk4, pak003.pk4, and"
+ elog "pak004.pk4 from either your installation media or your hard drive to"
+ elog "${dir}/base before running the game,"
+ elog "or 'emerge games-fps/doom3-data' to install from CD."
+ echo
+ if ! use roe ; then
+ elog "To use the Resurrection of Evil expansion pack, you also need to copy"
+ elog "pak000.pk4 to ${dir}/d3xp from the RoE CD before running the game,"
+ elog "or 'emerge doom3-roe' to install from CD."
+ fi
+ fi
+
+ echo
+ elog "To play the game, run:"
+ elog " doom3"
+ echo
+}