summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-04-11 14:16:54 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-04-11 14:16:54 +0000
commitd1a167886b3910050cb800a585db804f2262034b (patch)
treefc5634a795a1831305a15774c7bcd888f89f8db2 /games-fps/eduke32
parentadding new rdep as identified in bug #455832 (diff)
downloadgentoo-2-d1a167886b3910050cb800a585db804f2262034b.tar.gz
gentoo-2-d1a167886b3910050cb800a585db804f2262034b.tar.bz2
gentoo-2-d1a167886b3910050cb800a585db804f2262034b.zip
fix build with libpng-1.6
(Portage version: 2.2.0_alpha171/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'games-fps/eduke32')
-rw-r--r--games-fps/eduke32/ChangeLog7
-rw-r--r--games-fps/eduke32/eduke32-20130317.3572-r1.ebuild7
-rw-r--r--games-fps/eduke32/files/eduke32-20130317.3572-libpng-1.6.patch40
3 files changed, 50 insertions, 4 deletions
diff --git a/games-fps/eduke32/ChangeLog b/games-fps/eduke32/ChangeLog
index 0a4d9f38c479..c3fd726a8070 100644
--- a/games-fps/eduke32/ChangeLog
+++ b/games-fps/eduke32/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/eduke32
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/eduke32/ChangeLog,v 1.6 2013/04/11 00:23:55 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/eduke32/ChangeLog,v 1.7 2013/04/11 14:16:54 hasufell Exp $
+
+ 11 Apr 2013; Julian Ospald <hasufell@gentoo.org>
+ eduke32-20130317.3572-r1.ebuild,
+ +files/eduke32-20130317.3572-libpng-1.6.patch:
+ fix build with libpng-1.6
11 Apr 2013; Julian Ospald <hasufell@gentoo.org>
eduke32-20130317.3572-r1.ebuild:
diff --git a/games-fps/eduke32/eduke32-20130317.3572-r1.ebuild b/games-fps/eduke32/eduke32-20130317.3572-r1.ebuild
index a3bb0288b1c9..97858cb44aca 100644
--- a/games-fps/eduke32/eduke32-20130317.3572-r1.ebuild
+++ b/games-fps/eduke32/eduke32-20130317.3572-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/eduke32/eduke32-20130317.3572-r1.ebuild,v 1.2 2013/04/11 00:23:55 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/eduke32/eduke32-20130317.3572-r1.ebuild,v 1.3 2013/04/11 14:16:54 hasufell Exp $
# TODO/FIXME:
# lunatic broken
@@ -49,7 +49,7 @@ RDEPEND="media-libs/flac
gtk? ( x11-libs/gtk+:2 )
opengl? ( virtual/glu
virtual/opengl )
- png? ( media-libs/libpng:0
+ png? ( media-libs/libpng:0=
sys-libs/zlib )
vpx? ( media-libs/libvpx )"
DEPEND="${RDEPEND}
@@ -82,7 +82,8 @@ src_unpack() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-QA.patch
+ epatch "${FILESDIR}"/${P}-QA.patch \
+ "${FILESDIR}"/${P}-libpng-1.6.patch
# Point eduke32 to data files in shared duke3d folder.
# Multiple search paths can be defined, so that with the default configuration as of
diff --git a/games-fps/eduke32/files/eduke32-20130317.3572-libpng-1.6.patch b/games-fps/eduke32/files/eduke32-20130317.3572-libpng-1.6.patch
new file mode 100644
index 000000000000..c9eb6448fa38
--- /dev/null
+++ b/games-fps/eduke32/files/eduke32-20130317.3572-libpng-1.6.patch
@@ -0,0 +1,40 @@
+From: Julian Ospald <hasufell@gentoo.org>
+Date: Thu Apr 11 13:31:20 UTC 2013
+Subject: fix compatibility with libpng-1.6
+
+--- eduke32_20130317-3572/build/src/engine.c
++++ eduke32_20130317-3572/build/src/engine.c
+@@ -8,6 +8,9 @@
+
+ #define ENGINE
+
++#if (PNG_LIBPNG_VER > 10599)
++# include <string.h>
++#endif
+ #include "compat.h"
+ #include "build.h"
+ #include "pragmas.h"
+@@ -16112,7 +16115,11 @@ static int32_t screencapture_png(const c
+ png_set_filter(png_ptr, PNG_FILTER_TYPE_BASE, PNG_FILTER_VALUE_NONE);
+
+ if (!HICOLOR)
++ #if (PNG_LIBPNG_VER > 10599)
++ palette = (png_colorp)png_malloc(png_ptr, 256*sizeof(png_color));
++ #else
+ palette = (png_colorp)png_malloc(png_ptr, 256*png_sizeof(png_color));
++ #endif
+
+ if (palette)
+ {
+@@ -16129,7 +16136,11 @@ static int32_t screencapture_png(const c
+ // png_set_gAMA(png_ptr, info_ptr, vid_gamma); // 1.0/vid_gamma ?
+ // png_set_sRGB(png_ptr, info_ptr, PNG_sRGB_INTENT_SATURATION); // hm...
+
++ #if (PNG_LIBPNG_VER > 10599)
++ text = (png_textp)png_malloc(png_ptr, 2*sizeof(png_text));
++ #else
+ text = (png_textp)png_malloc(png_ptr, 2*png_sizeof(png_text));
++ #endif
+ text[0].compression = PNG_TEXT_COMPRESSION_NONE;
+ text[0].key = "Title";
+ text[0].text = (png_charp)(editstatus ? "Mapster32 screenshot" : "EDuke32 screenshot");