summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-10-30 06:00:00 +0000
committerMike Frysinger <vapier@gentoo.org>2005-10-30 06:00:00 +0000
commit43cca1dc9d4ee6c8264e4d97c61471d55f340c14 (patch)
tree9ab8a99250099aaa0d8f03c522e03cc717e93523 /games-fps/quakeforge/quakeforge-0.5.5.ebuild
parentquake1-data import (diff)
downloadgentoo-2-43cca1dc9d4ee6c8264e4d97c61471d55f340c14.tar.gz
gentoo-2-43cca1dc9d4ee6c8264e4d97c61471d55f340c14.tar.bz2
gentoo-2-43cca1dc9d4ee6c8264e4d97c61471d55f340c14.zip
add support for USE=cdinstall
(Portage version: 2.0.53_rc6)
Diffstat (limited to 'games-fps/quakeforge/quakeforge-0.5.5.ebuild')
-rw-r--r--games-fps/quakeforge/quakeforge-0.5.5.ebuild37
1 files changed, 19 insertions, 18 deletions
diff --git a/games-fps/quakeforge/quakeforge-0.5.5.ebuild b/games-fps/quakeforge/quakeforge-0.5.5.ebuild
index a427d3d33b0a..724d4a30d8bb 100644
--- a/games-fps/quakeforge/quakeforge-0.5.5.ebuild
+++ b/games-fps/quakeforge/quakeforge-0.5.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.5.5.ebuild,v 1.7 2005/09/06 12:57:29 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quakeforge/quakeforge-0.5.5.ebuild,v 1.8 2005/10/30 06:00:00 vapier Exp $
inherit eutils games
@@ -11,7 +11,7 @@ SRC_URI="mirror://sourceforge/quake/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="ppc x86"
-IUSE="debug 3dfx fbcon opengl sdl svga X ncurses vorbis zlib ipv6 xv dga xmms alsa oss"
+IUSE="cdinstall debug 3dfx fbcon opengl sdl svga X ncurses vorbis zlib ipv6 xv dga xmms alsa oss"
RESTRICT="nouserpriv"
RDEPEND="3dfx? ( media-libs/glide-v3 )
@@ -27,6 +27,7 @@ RDEPEND="3dfx? ( media-libs/glide-v3 )
xmms? ( media-sound/xmms )
alsa? ( media-libs/alsa-lib )"
DEPEND="${RDEPEND}
+ cdinstall? ( games-fps/quake1-data )
sys-devel/bison
sys-devel/flex"
@@ -72,24 +73,24 @@ src_compile() {
addpredict ${GAMES_LIBDIR}
egamesconf \
- `use_enable ncurses curses` \
- `use_enable vorbis` \
- `use_enable zlib` \
- `use_with ipv6` \
- `use_with fbcon fbdev` \
+ $(use_enable ncurses curses) \
+ $(use_enable vorbis) \
+ $(use_enable zlib) \
+ $(use_with ipv6) \
+ $(use_with fbcon fbdev) \
${svgaconf} \
- `use_with X x` \
- `use_enable xv vidmode` \
- `use_enable dga` \
- `use_enable sdl` \
- `use_enable xmms` \
- `use_enable alsa` \
- `use_enable oss` \
+ $(use_with X x) \
+ $(use_enable xv vidmode) \
+ $(use_enable dga) \
+ $(use_enable sdl) \
+ $(use_enable xmms) \
+ $(use_enable alsa) \
+ $(use_enable oss) \
--enable-sound \
--disable-optimize \
${debugopts} \
--with-global-cfg=${GAMES_SYSCONFDIR}/quakeforge.conf \
- --with-sharepath=${GAMES_DATADIR}/quake-data \
+ --with-sharepath=${GAMES_DATADIR}/quake1 \
--with-clients=${clients} \
--with-servers=${servers} \
--with-tools=${tools} \
@@ -111,12 +112,12 @@ pkg_postinst() {
einfo "QuakeForge can find your Quake .pak files"
echo
einfo "You have 2 choices to do this"
- einfo "1 Copy pak*.pak files to ${GAMES_DATADIR}/quake-data/id1"
- einfo "2 Symlink pak*.pak files in ${GAMES_DATADIR}/quake-data/id1"
+ einfo "1 Copy pak*.pak files to ${GAMES_DATADIR}/quake1/id1"
+ einfo "2 Symlink pak*.pak files in ${GAMES_DATADIR}/quake1/id1"
echo
einfo "Example:"
einfo "my pak*.pak files are in /mnt/secondary/Games/Quake/Id1/"
- einfo "ln -s /mnt/secondary/Games/Quake/Id1/pak0.pak ${GAMES_DATADIR}/quake-data/id1/pak0.pak"
+ einfo "ln -s /mnt/secondary/Games/Quake/Id1/pak0.pak ${GAMES_DATADIR}/quake1/id1/pak0.pak"
echo
einfo "You only need pak0.pak to play the demo version,"
einfo "the others are needed for registered version"