summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-08-06 08:26:54 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-08-06 08:26:54 +0000
commitbd8659852f40d02ea2e58eb5d7abfe681a307d82 (patch)
tree12f7b2d14c157f71faa25ab580a8dfb58e4bf9a6 /games-fps/turtlearena
parentInstall Xawtv app-defaults to correct directory at /usr/share/X11. Fix buildi... (diff)
downloadgentoo-2-bd8659852f40d02ea2e58eb5d7abfe681a307d82.tar.gz
gentoo-2-bd8659852f40d02ea2e58eb5d7abfe681a307d82.tar.bz2
gentoo-2-bd8659852f40d02ea2e58eb5d7abfe681a307d82.zip
Fix building with libjpeg-turbo extended libjpeg.so.62 API with jpeg_mem_src() and jpeg_mem_dest() wrt #479822 by Julian Ospald. Fix freetype2 related build error wrt #479822#c3.
(Portage version: 2.2.0_alpha191/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'games-fps/turtlearena')
-rw-r--r--games-fps/turtlearena/ChangeLog8
-rw-r--r--games-fps/turtlearena/files/turtlearena-0.6.1-freetype.patch17
-rw-r--r--games-fps/turtlearena/turtlearena-0.6.1.ebuild12
3 files changed, 33 insertions, 4 deletions
diff --git a/games-fps/turtlearena/ChangeLog b/games-fps/turtlearena/ChangeLog
index 742f691a2b62..ab6b484bb0de 100644
--- a/games-fps/turtlearena/ChangeLog
+++ b/games-fps/turtlearena/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-fps/turtlearena
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/turtlearena/ChangeLog,v 1.4 2013/06/25 12:55:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/turtlearena/ChangeLog,v 1.5 2013/08/06 08:26:53 ssuominen Exp $
+
+ 06 Aug 2013; Samuli Suominen <ssuominen@gentoo.org> turtlearena-0.6.1.ebuild,
+ +files/turtlearena-0.6.1-freetype.patch:
+ Fix building with libjpeg-turbo extended libjpeg.so.62 API with
+ jpeg_mem_src() and jpeg_mem_dest() wrt #479822 by Julian Ospald. Fix
+ freetype2 related build error wrt #479822#c3.
25 Jun 2013; Agostino Sarubbo <ago@gentoo.org> turtlearena-0.6.1.ebuild:
Stable for amd64, wrt bug #474382
diff --git a/games-fps/turtlearena/files/turtlearena-0.6.1-freetype.patch b/games-fps/turtlearena/files/turtlearena-0.6.1-freetype.patch
new file mode 100644
index 000000000000..563a9d0d7042
--- /dev/null
+++ b/games-fps/turtlearena/files/turtlearena-0.6.1-freetype.patch
@@ -0,0 +1,17 @@
+http://bugs.gentoo.org/show_bug.cgi?id=479822#c3
+http://github.com/ioquake/ioq3/commit/ab4c602374caa0f520b3a0801d384a73e29e0bc7
+
+--- engine/code/renderer/tr_font.c
++++ engine/code/renderer/tr_font.c
+@@ -47,10 +47,10 @@
+ #include "../qcommon/qcommon.h"
+
+ #include <ft2build.h>
++#include FT_FREETYPE_H
+ #include FT_ERRORS_H
+ #include FT_SYSTEM_H
+ #include FT_IMAGE_H
+-#include FT_FREETYPE_H
+ #include FT_OUTLINE_H
+
+ #define _FLOOR(x) ((x) & -64)
diff --git a/games-fps/turtlearena/turtlearena-0.6.1.ebuild b/games-fps/turtlearena/turtlearena-0.6.1.ebuild
index f2e64ec033f8..eb1030ba226a 100644
--- a/games-fps/turtlearena/turtlearena-0.6.1.ebuild
+++ b/games-fps/turtlearena/turtlearena-0.6.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/turtlearena/turtlearena-0.6.1.ebuild,v 1.4 2013/06/25 12:55:35 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/turtlearena/turtlearena-0.6.1.ebuild,v 1.5 2013/08/06 08:26:53 ssuominen Exp $
EAPI=5
@@ -23,7 +23,7 @@ RDEPEND="
!dedicated? (
media-libs/freetype:2
media-libs/libsdl[X,audio,joystick,opengl,video]
- virtual/jpeg
+ virtual/jpeg:0
virtual/opengl
curl? ( net-misc/curl )
openal? ( media-libs/openal )
@@ -41,7 +41,13 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}-0-src
src_prepare() {
- epatch "${FILESDIR}"/${P}-build.patch
+ epatch \
+ "${FILESDIR}"/${P}-build.patch \
+ "${FILESDIR}"/${P}-freetype.patch
+
+ sed -i \
+ -e 's:JPEG_LIB_VERSION < 80:JPEG_LIB_VERSION < 62:' \
+ engine/code/renderer/tr_image_jpg.c || die #479822
rm -r engine/code/{AL,libcurl,libogg,libspeex,libtheora,libvorbis,SDL12,zlib} \
engine/code/freetype* engine/code/jpeg-* \