summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-08 18:16:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-08 18:16:12 +0000
commitaa02f7e3c57aae4933358ee2c19c93ff68bc1042 (patch)
treea6c9caa9d6126390b59a1a579cee323f07587d6b /games-fps/worldofpadman
parentVersion bump (diff)
downloadgentoo-2-aa02f7e3c57aae4933358ee2c19c93ff68bc1042.tar.gz
gentoo-2-aa02f7e3c57aae4933358ee2c19c93ff68bc1042.tar.bz2
gentoo-2-aa02f7e3c57aae4933358ee2c19c93ff68bc1042.zip
Add libsdl usd deps - might fix bug #459360; use usex
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps/worldofpadman')
-rw-r--r--games-fps/worldofpadman/ChangeLog7
-rw-r--r--games-fps/worldofpadman/worldofpadman-1.6.ebuild15
2 files changed, 12 insertions, 10 deletions
diff --git a/games-fps/worldofpadman/ChangeLog b/games-fps/worldofpadman/ChangeLog
index 96868e922c5b..2db12c9fd66f 100644
--- a/games-fps/worldofpadman/ChangeLog
+++ b/games-fps/worldofpadman/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-fps/worldofpadman
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/worldofpadman/ChangeLog,v 1.15 2014/06/24 23:34:13 mr_bones_ Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/worldofpadman/ChangeLog,v 1.16 2015/02/08 18:16:12 mr_bones_ Exp $
+
+ 08 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org> worldofpadman-1.6.ebuild:
+ Add libsdl usd deps - might fix bug #459360; use usex
24 Jun 2014; Michael Sterrett <mr_bones_@gentoo.org> worldofpadman-1.6.ebuild:
add missing glu dep (bug #514854)
diff --git a/games-fps/worldofpadman/worldofpadman-1.6.ebuild b/games-fps/worldofpadman/worldofpadman-1.6.ebuild
index e230edfec9e2..82ca44426890 100644
--- a/games-fps/worldofpadman/worldofpadman-1.6.ebuild
+++ b/games-fps/worldofpadman/worldofpadman-1.6.ebuild
@@ -1,9 +1,8 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/worldofpadman/worldofpadman-1.6.ebuild,v 1.6 2014/06/24 23:34:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/worldofpadman/worldofpadman-1.6.ebuild,v 1.7 2015/02/08 18:16:12 mr_bones_ Exp $
EAPI=5
-
inherit eutils games
DESCRIPTION="A cartoon style multiplayer first-person shooter"
@@ -20,7 +19,7 @@ RDEPEND="sys-libs/zlib
!dedicated? (
media-libs/speex
virtual/jpeg:0
- media-libs/libsdl
+ media-libs/libsdl[opengl,video]
virtual/opengl
virtual/glu
openal? ( media-libs/openal )
@@ -63,12 +62,12 @@ src_compile() {
BUILD_CLIENT=$(use dedicated && echo 0) \
DEFAULT_BASEDIR="${GAMES_DATADIR}"/${PN} \
OPTIMIZE= \
- USE_CURL=$(use curl && echo 1 || echo 0) \
+ USE_CURL=$(usex curl 1 0) \
USE_CURL_DLOPEN=0 \
- USE_OPENAL=$(use openal && echo 1 || echo 0) \
+ USE_OPENAL=$(usex openal 1 0) \
USE_OPENAL_DLOPEN=0 \
- USE_CODEC_VORBIS=$(use vorbis && echo 1 || echo 0) \
- USE_CIN_THEORA=$(use theora && echo 1 || echo 0) \
+ USE_CODEC_VORBIS=$(usex vorbis 1 0) \
+ USE_CIN_THEORA=$(usex theora 1 0) \
USE_RENDERER_DLOPEN=0 \
USE_INTERNAL_ZLIB=0 \
USE_INTERNAL_JPEG=0 \