summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2013-06-14 15:16:08 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2013-06-14 15:16:08 +0000
commite8b09228eeb61e47007d0acee7a9dccb036c1465 (patch)
tree590be5436da668e667dd0d71326829bbea62a0ec /games-fps/xonotic
parentLost a digit in the bug number. (diff)
downloadgentoo-2-e8b09228eeb61e47007d0acee7a9dccb036c1465.tar.gz
gentoo-2-e8b09228eeb61e47007d0acee7a9dccb036c1465.tar.bz2
gentoo-2-e8b09228eeb61e47007d0acee7a9dccb036c1465.zip
version bump (bug #472760)
(Portage version: 2.1.12.2/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-fps/xonotic')
-rw-r--r--games-fps/xonotic/ChangeLog7
-rw-r--r--games-fps/xonotic/xonotic-0.7.0.ebuild111
2 files changed, 117 insertions, 1 deletions
diff --git a/games-fps/xonotic/ChangeLog b/games-fps/xonotic/ChangeLog
index 328ffde949f6..73b2879ea730 100644
--- a/games-fps/xonotic/ChangeLog
+++ b/games-fps/xonotic/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-fps/xonotic
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.9 2013/01/24 00:19:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/ChangeLog,v 1.10 2013/06/14 15:16:08 mr_bones_ Exp $
+
+*xonotic-0.7.0 (14 Jun 2013)
+
+ 14 Jun 2013; Michael Sterrett <mr_bones_@gentoo.org> +xonotic-0.7.0.ebuild:
+ version bump (bug #472760)
24 Jan 2013; Michael Sterrett <mr_bones_@gentoo.org> -xonotic-0.5.0.ebuild:
old
diff --git a/games-fps/xonotic/xonotic-0.7.0.ebuild b/games-fps/xonotic/xonotic-0.7.0.ebuild
new file mode 100644
index 000000000000..449f8089440d
--- /dev/null
+++ b/games-fps/xonotic/xonotic-0.7.0.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/xonotic/xonotic-0.7.0.ebuild,v 1.1 2013/06/14 15:16:07 mr_bones_ Exp $
+
+EAPI=5
+inherit eutils check-reqs games
+
+MY_PN="${PN^}"
+DESCRIPTION="Fork of Nexuiz, Deathmatch FPS based on DarkPlaces, an advanced Quake 1 engine"
+HOMEPAGE="http://www.xonotic.org/"
+SRC_URI="http://dl.xonotic.org/${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="alsa debug dedicated doc sdl"
+
+UIRDEPEND="
+ media-libs/libogg
+ media-libs/libtheora
+ media-libs/libvorbis
+ media-libs/libmodplug
+ x11-libs/libX11
+ x11-libs/libXau
+ x11-libs/libXpm
+ x11-libs/libXext
+ x11-libs/libXdmcp
+ x11-libs/libXxf86dga
+ x11-libs/libXxf86vm
+ virtual/opengl
+ media-libs/freetype:2
+ alsa? ( media-libs/alsa-lib )
+ sdl? ( media-libs/libsdl[X,audio,joystick,opengl,video,alsa?] )"
+UIDEPEND="
+ x11-proto/xextproto
+ x11-proto/xf86dgaproto
+ x11-proto/xf86vidmodeproto
+ x11-proto/xproto"
+RDEPEND="
+ sys-libs/zlib
+ virtual/jpeg
+ media-libs/libpng
+ net-misc/curl
+ ~dev-libs/d0_blind_id-0.5
+ !dedicated? ( ${UIRDEPEND} )"
+DEPEND="${RDEPEND}
+ !dedicated? ( ${UIDEPEND} )"
+
+CHECKREQS_DISK_BUILD="1200M"
+CHECKREQS_DISK_USR="950M"
+
+S=${WORKDIR}/${MY_PN}
+
+pkg_pretend() {
+ check-reqs_pkg_pretend
+}
+
+pkg_setup() {
+ check-reqs_pkg_setup
+ games_pkg_setup
+}
+
+src_prepare() {
+ sed -i \
+ -e "/^EXE_/s:darkplaces:${PN}:" \
+ -e "s:-O3:${CFLAGS}:" \
+ -e "/-lm/s:$: ${LDFLAGS}:" \
+ -e '/^STRIP/s/strip/true/' \
+ source/darkplaces/makefile.inc || die
+
+ if ! use alsa; then
+ sed -i \
+ -e "/DEFAULT_SNDAPI/s:ALSA:OSS:" \
+ source/darkplaces/makefile || die
+ fi
+}
+
+src_compile() {
+ local t="$(use debug && echo debug || echo release)"
+
+ emake \
+ -C source/darkplaces \
+ DP_LINK_TO_LIBJPEG=1 \
+ DP_FS_BASEDIR="${GAMES_DATADIR}/${PN}" \
+ sv-${t} \
+ $(use !dedicated && echo "cl-${t} $(use sdl && echo sdl-${t})")
+}
+
+src_install() {
+ if ! use dedicated; then
+ dogamesbin source/darkplaces/${PN}-glx
+ newicon misc/logos/${PN}_icon.svg ${PN}.svg
+ make_desktop_entry ${PN}-glx "${MY_PN} (GLX)"
+
+ if use sdl; then
+ dogamesbin source/darkplaces/${PN}-sdl
+ make_desktop_entry ${PN}-sdl "${MY_PN} (SDL)"
+ fi
+ fi
+ dogamesbin source/darkplaces/${PN}-dedicated
+
+ dodoc Docs/*.txt
+ use doc && dohtml -r Docs
+
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r key_0.d0pk server data
+ prepgamesdirs
+
+ elog "If you are using opensource drivers you should condider installing: "
+ elog " media-libs/libtxc_dxtn"
+}