summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-01-15 03:08:09 +0000
committerMike Frysinger <vapier@gentoo.org>2004-01-15 03:08:09 +0000
commit2b5d40a82f5eb72ff9aef98d5f740ebe1391e52b (patch)
tree4779621f83e91d64a6e24b1ba4c99f62f2f3582c /games-fps
parentoh god i just unmasked it (diff)
downloadgentoo-2-2b5d40a82f5eb72ff9aef98d5f740ebe1391e52b.tar.gz
gentoo-2-2b5d40a82f5eb72ff9aef98d5f740ebe1391e52b.tar.bz2
gentoo-2-2b5d40a82f5eb72ff9aef98d5f740ebe1391e52b.zip
change to new cdrom stuff
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/unreal-tournament/unreal-tournament-436.ebuild17
-rw-r--r--games-fps/unreal-tournament/unreal-tournament-451.ebuild17
2 files changed, 16 insertions, 18 deletions
diff --git a/games-fps/unreal-tournament/unreal-tournament-436.ebuild b/games-fps/unreal-tournament/unreal-tournament-436.ebuild
index a5d6deb78612..038906d8684e 100644
--- a/games-fps/unreal-tournament/unreal-tournament-436.ebuild
+++ b/games-fps/unreal-tournament/unreal-tournament-436.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/unreal-tournament-436.ebuild,v 1.3 2003/10/05 02:42:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/unreal-tournament-436.ebuild,v 1.4 2004/01/15 03:08:08 vapier Exp $
inherit games eutils
@@ -22,8 +22,7 @@ S=${WORKDIR}
pkg_setup() {
check_license
- games_get_cd System/
- games_verify_cd ${PN}
+ cdrom_get_cds System/
games_pkg_setup
}
@@ -37,13 +36,13 @@ src_install() {
dodir ${dir}
# Help, Logs, Music, Textures, Web
- cp -rf ${UT_CD}/{Help,Logs,Music,Textures,Web} ${D}/${dir}/ || die "copy Help, Logs, Music, Textures, Web"
+ cp -rf ${CDROM_ROOT}/{Help,Logs,Music,Textures,Web} ${D}/${dir}/ || die "copy Help, Logs, Music, Textures, Web"
tar -zxf Credits.tar.gz -C ${D}/${dir} || die "extract credits texture"
# NetGamesUSA.com
tar -zxf NetGamesUSA.com.tar.gz -C ${D}/${dir}/ || die "extract NetGamesUSA.com"
# Sounds
dodir ${dir}/Sounds
- cp -rf ${UT_CD}/Sounds/*.uax ${D}/${dir}/Sounds/ || die "copy Sounds"
+ cp -rf ${CDROM_ROOT}/Sounds/*.uax ${D}/${dir}/Sounds/ || die "copy Sounds"
# System
if [ `use 3dfx` ] ; then
@@ -52,7 +51,7 @@ src_install() {
tar -zxf OpenGL.ini.tar.gz -C ${D}/${dir} || die "install OpenGL ini"
fi
tar -zxf data.tar.gz -C ${D}/${dir} || die "extract System data"
- cp ${UT_CD}/System/*.u ${D}/${dir}/System/ || die "copy System data"
+ cp ${CDROM_ROOT}/System/*.u ${D}/${dir}/System/ || die "copy System data"
# the most important things, ucc & ut :)
exeinto ${dir}
@@ -78,11 +77,11 @@ src_install() {
cd ${D}/${dir}
export HOME=${T}
export UT_DATA_PATH=${D}/${dir}/System
- for f in `find ${UT_CD}/Maps/ -name '*.uz' -printf '%f '` ; do
- ./ucc decompress ${UT_CD}/Maps/${f} -nohomedir || die "uncompressing map ${f}"
+ for f in `find ${CDROM_ROOT}/Maps/ -name '*.uz' -printf '%f '` ; do
+ ./ucc decompress ${CDROM_ROOT}/Maps/${f} -nohomedir || die "uncompressing map ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map ${f}"
done
- cp -rf ${UT_CD}/Maps/*.unr ${D}/${dir}/Maps/ # some cd's have uncompressed maps ??
+ cp -rf ${CDROM_ROOT}/Maps/*.unr ${D}/${dir}/Maps/ # some cd's have uncompressed maps ??
# export some symlinks so ppl can run
dodir ${GAMES_BINDIR}
diff --git a/games-fps/unreal-tournament/unreal-tournament-451.ebuild b/games-fps/unreal-tournament/unreal-tournament-451.ebuild
index 8ed2c9974010..68993328bb04 100644
--- a/games-fps/unreal-tournament/unreal-tournament-451.ebuild
+++ b/games-fps/unreal-tournament/unreal-tournament-451.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/unreal-tournament-451.ebuild,v 1.3 2003/10/05 02:42:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/unreal-tournament/unreal-tournament-451.ebuild,v 1.4 2004/01/15 03:08:09 vapier Exp $
inherit games eutils
@@ -23,8 +23,7 @@ S=${WORKDIR}
pkg_setup() {
check_license
- games_get_cd System/
- games_verify_cd ${PN}
+ cdrom_get_cds System/
games_pkg_setup
}
@@ -41,13 +40,13 @@ src_install() {
dodir ${dir}
# Help, Logs, Music, Textures, Web
- cp -rf ${GAMES_CD}/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web"
+ cp -rf ${CDROM_ROOT}/{Help,Logs,Music,Textures,Web} ${Ddir}/ || die "copy Help, Logs, Music, Textures, Web"
tar -zxf Credits.tar.gz -C ${Ddir} || die "extract credits texture"
# NetGamesUSA.com
tar -zxf NetGamesUSA.com.tar.gz -C ${Ddir}/ || die "extract NetGamesUSA.com"
# Sounds
dodir ${dir}/Sounds
- cp -rf ${GAMES_CD}/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds"
+ cp -rf ${CDROM_ROOT}/Sounds/*.uax ${Ddir}/Sounds/ || die "copy Sounds"
# System
if [ `use 3dfx` ] ; then
@@ -56,7 +55,7 @@ src_install() {
tar -zxf OpenGL.ini.tar.gz -C ${Ddir} || die "install OpenGL ini"
fi
tar -zxf data.tar.gz -C ${Ddir} || die "extract System data"
- cp ${GAMES_CD}/System/*.u ${Ddir}/System/ || die "copy System data"
+ cp ${CDROM_ROOT}/System/*.u ${Ddir}/System/ || die "copy System data"
# the most important things, ucc & ut :)
exeinto ${dir}
@@ -88,11 +87,11 @@ src_install() {
cd ${Ddir}
export HOME=${T}
export UT_DATA_PATH=${Ddir}/System
- for f in `find ${GAMES_CD}/Maps/ -name '*.uz' -printf '%f '` ; do
- ./ucc decompress ${GAMES_CD}/Maps/${f} -nohomedir || die "uncompressing map ${f}"
+ for f in `find ${CDROM_ROOT}/Maps/ -name '*.uz' -printf '%f '` ; do
+ ./ucc decompress ${CDROM_ROOT}/Maps/${f} -nohomedir || die "uncompressing map ${f}"
mv System/${f:0:${#f}-3} Maps/ || die "copy map ${f}"
done
- cp -rf ${GAMES_CD}/Maps/*.unr ${Ddir}/Maps/ # some cd's have uncompressed maps ??
+ cp -rf ${CDROM_ROOT}/Maps/*.unr ${Ddir}/Maps/ # some cd's have uncompressed maps ??
# now, since these files are coming off a cd, the times/sizes/md5sums wont
# be different ... that means portage will try to unmerge some files (!)