summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-10-27 16:06:54 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-10-27 16:06:54 +0000
commit36de1783dd567a3d464b2d40264646709bee27e8 (patch)
tree3021a609d28e5ef15674e153447e3d2f7f24f19d /games-fps
parentUnmask games-fps/quake3-osp since I managed to find a super-slow download loc... (diff)
downloadgentoo-2-36de1783dd567a3d464b2d40264646709bee27e8.tar.gz
gentoo-2-36de1783dd567a3d464b2d40264646709bee27e8.tar.bz2
gentoo-2-36de1783dd567a3d464b2d40264646709bee27e8.zip
Added new revision for testing which uses the brand-spankin-new games-mods.eclass to reduce ebuild code.
(Portage version: 2.1.2_pre3-r8)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/quake3-osp/ChangeLog11
-rw-r--r--games-fps/quake3-osp/files/digest-quake3-osp-1.03a2
-rw-r--r--games-fps/quake3-osp/files/digest-quake3-osp-1.03a-r13
-rw-r--r--games-fps/quake3-osp/quake3-osp-1.03a-r1.ebuild28
4 files changed, 42 insertions, 2 deletions
diff --git a/games-fps/quake3-osp/ChangeLog b/games-fps/quake3-osp/ChangeLog
index 96d9771d2089..7c76fbacfd9c 100644
--- a/games-fps/quake3-osp/ChangeLog
+++ b/games-fps/quake3-osp/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-fps/quake3-osp
-# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-osp/ChangeLog,v 1.6 2004/12/29 00:05:26 ciaranm Exp $
+# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-osp/ChangeLog,v 1.7 2006/10/27 16:06:54 wolf31o2 Exp $
+
+*quake3-osp-1.03a-r1 (27 Oct 2006)
+
+ 27 Oct 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ +quake3-osp-1.03a-r1.ebuild:
+ Added new revision for testing which uses the brand-spankin-new
+ games-mods.eclass to reduce ebuild code.
29 Dec 2004; Ciaran McCreesh <ciaranm@gentoo.org> :
Change encoding to UTF-8 for GLEP 31 compliance
diff --git a/games-fps/quake3-osp/files/digest-quake3-osp-1.03a b/games-fps/quake3-osp/files/digest-quake3-osp-1.03a
index 989e0f1a252a..b0283c623080 100644
--- a/games-fps/quake3-osp/files/digest-quake3-osp-1.03a
+++ b/games-fps/quake3-osp/files/digest-quake3-osp-1.03a
@@ -1 +1,3 @@
MD5 8b2b4925cce1895067bc617b86c62ea5 osp-Quake3-1.03a_full.zip 55882759
+RMD160 05c0e37baac5b93c0dd914e8b42123515cbcaf92 osp-Quake3-1.03a_full.zip 55882759
+SHA256 af9a184134733fc24c308b4f8790932d30dc70b6c8a36e050223ba16ba2ac2b3 osp-Quake3-1.03a_full.zip 55882759
diff --git a/games-fps/quake3-osp/files/digest-quake3-osp-1.03a-r1 b/games-fps/quake3-osp/files/digest-quake3-osp-1.03a-r1
new file mode 100644
index 000000000000..b0283c623080
--- /dev/null
+++ b/games-fps/quake3-osp/files/digest-quake3-osp-1.03a-r1
@@ -0,0 +1,3 @@
+MD5 8b2b4925cce1895067bc617b86c62ea5 osp-Quake3-1.03a_full.zip 55882759
+RMD160 05c0e37baac5b93c0dd914e8b42123515cbcaf92 osp-Quake3-1.03a_full.zip 55882759
+SHA256 af9a184134733fc24c308b4f8790932d30dc70b6c8a36e050223ba16ba2ac2b3 osp-Quake3-1.03a_full.zip 55882759
diff --git a/games-fps/quake3-osp/quake3-osp-1.03a-r1.ebuild b/games-fps/quake3-osp/quake3-osp-1.03a-r1.ebuild
new file mode 100644
index 000000000000..04641c816d96
--- /dev/null
+++ b/games-fps/quake3-osp/quake3-osp-1.03a-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/quake3-osp/quake3-osp-1.03a-r1.ebuild,v 1.1 2006/10/27 16:06:54 wolf31o2 Exp $
+
+MOD_DESC="a touirnament-based mod"
+MOD_NAME="OSP"
+MOD_DIR="osp"
+
+inherit games games-mods
+
+SRC_URI="http://www.flatlands.ch/filebase/mods/left/osp-Quake3-${PV}_full.zip
+ http://games13.xs4all.nl/quake3/osp-Quake3-${PV}_full.zip"
+HOMEPAGE="http://www.orangesmoothie.org/"
+
+LICENSE="GPL-2"
+
+KEYWORDS="-* ~amd64 ~ppc ~x86"
+
+RDEPEND="ppc? ( games-fps/${GAME} )
+ !ppc? (
+ || (
+ games-fps/${GAME}
+ games-fps/${GAME}-bin ) )"
+
+pkg_nofetch() {
+ einfo "Go to http://www.fileshack.com/file.x?fid=1515 and download"
+ einfo "${A} and put it in ${DISTDIR}"
+}