summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-02-15 09:23:38 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-02-15 09:23:38 +0000
commitc27837c62fcd97609db9472100da468bd159aba9 (patch)
tree13994f5b31b57bb61eec19ed683536be35379606 /games-fps
parentstable x86; security bug 166901 (diff)
downloadgentoo-2-c27837c62fcd97609db9472100da468bd159aba9.tar.gz
gentoo-2-c27837c62fcd97609db9472100da468bd159aba9.tar.bz2
gentoo-2-c27837c62fcd97609db9472100da468bd159aba9.zip
rm old versions
(Portage version: 2.1.2-r9)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone/alephone-20060506-r1.ebuild79
-rw-r--r--games-fps/alephone/alephone-20060701.ebuild79
-rw-r--r--games-fps/alephone/files/digest-alephone-20060506-r13
-rw-r--r--games-fps/alephone/files/digest-alephone-200607013
4 files changed, 0 insertions, 164 deletions
diff --git a/games-fps/alephone/alephone-20060506-r1.ebuild b/games-fps/alephone/alephone-20060506-r1.ebuild
deleted file mode 100644
index b860c3021f55..000000000000
--- a/games-fps/alephone/alephone-20060506-r1.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20060506-r1.ebuild,v 1.2 2006/09/19 14:10:23 wolf31o2 Exp $
-
-inherit eutils games
-
-DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
-HOMEPAGE="http://source.bungie.org/"
-SRC_URI="mirror://sourceforge/marathon/AlephOne-${PV}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 x86"
-IUSE="lua opengl speex"
-
-DEPEND="lua? ( dev-lang/lua )
- opengl? ( virtual/opengl )
- speex? ( media-libs/speex )
- dev-libs/boost
- >=media-libs/libsdl-1.2
- media-libs/sdl-image
- media-libs/sdl-net"
-
-S=${WORKDIR}/AlephOne-${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- cp ${FILESDIR}/alephone.png ./
- cp ${FILESDIR}/alephone.sh ./
- sed -i -e "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
- alephone.sh || die
-}
-
-src_compile() {
- egamesconf \
- --disable-dependency-tracking \
- $(use_enable opengl) || die
- if ! use lua ; then
- # stupid configure script doesnt have an option
- dosed -i \
- -e '/HAVE_LUA/d' config.h \
- || die "sed HAVE_LUA"
- dosed -i \
- -e '/^LIBS/s:-llua -llualib::' $(find -name Makefile) \
- || die "sed -llua"
- fi
- if ! use speex ; then
- # stupid configure script doesnt have an option
- dosed -i \
- -e '/SPEEX/d:' config.h \
- || die "sed SPEEX"
- dosed -i \
- -e '/^LIBS/s:-lspeex::' $(find -name Makefile) \
- || die "sed -lspeex"
- fi
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dogamesbin alephone.sh || die "failed to install wrapper"
- dodoc AUTHORS README docs/Cheat_Codes
- dohtml docs/MML.html
- doicon alephone.png
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- einfo "Read the docs and install the data files accordingly to play."
- echo
- einfo "If you only want to install one scenario, read"
- einfo "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Single_scenario_3"
- einfo "If you want to install multiple scenarios, read"
- einfo "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Multiple_scenarios_3"
- echo
-}
diff --git a/games-fps/alephone/alephone-20060701.ebuild b/games-fps/alephone/alephone-20060701.ebuild
deleted file mode 100644
index 954cafbe255a..000000000000
--- a/games-fps/alephone/alephone-20060701.ebuild
+++ /dev/null
@@ -1,79 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20060701.ebuild,v 1.1 2006/10/08 21:29:47 tupone Exp $
-
-inherit eutils games
-
-DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
-HOMEPAGE="http://source.bungie.org/"
-SRC_URI="mirror://sourceforge/marathon/AlephOne-${PV}-nolibs.tar.bz2"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="lua opengl speex"
-
-DEPEND="lua? ( dev-lang/lua )
- opengl? ( virtual/opengl )
- speex? ( media-libs/speex )
- dev-libs/boost
- >=media-libs/libsdl-1.2
- media-libs/sdl-image
- media-libs/sdl-net"
-
-S=${WORKDIR}/AlephOne-${PV}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- cp ${FILESDIR}/alephone.png ./
- cp ${FILESDIR}/alephone.sh ./
- sed -i -e "s:GAMES_DATADIR:${GAMES_DATADIR}:g" \
- alephone.sh || die
-}
-
-src_compile() {
- egamesconf \
- --disable-dependency-tracking \
- $(use_enable opengl) || die
- if ! use lua ; then
- # stupid configure script doesnt have an option
- dosed -i \
- -e '/HAVE_LUA/d' config.h \
- || die "sed HAVE_LUA"
- dosed -i \
- -e '/^LIBS/s:-llua -llualib::' $(find -name Makefile) \
- || die "sed -llua"
- fi
- if ! use speex ; then
- # stupid configure script doesnt have an option
- dosed -i \
- -e '/SPEEX/d:' config.h \
- || die "sed SPEEX"
- dosed -i \
- -e '/^LIBS/s:-lspeex::' $(find -name Makefile) \
- || die "sed -lspeex"
- fi
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- dogamesbin alephone.sh || die "failed to install wrapper"
- dodoc AUTHORS README docs/Cheat_Codes
- dohtml docs/MML.html
- doicon alephone.png
- prepgamesdirs
-}
-
-pkg_postinst() {
- games_pkg_postinst
- echo
- einfo "Read the docs and install the data files accordingly to play."
- echo
- einfo "If you only want to install one scenario, read"
- einfo "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Single_scenario_3"
- einfo "If you want to install multiple scenarios, read"
- einfo "http://traxus.jjaro.net/traxus/AlephOne:Install_Guide#Multiple_scenarios_3"
- echo
-}
diff --git a/games-fps/alephone/files/digest-alephone-20060506-r1 b/games-fps/alephone/files/digest-alephone-20060506-r1
deleted file mode 100644
index 01aa3fa7e522..000000000000
--- a/games-fps/alephone/files/digest-alephone-20060506-r1
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 7daead26056dfe33732cc8d5169ba489 AlephOne-20060506.tar.gz 6272060
-RMD160 857f0534dd1387fcac4dd9a10628a6250666a970 AlephOne-20060506.tar.gz 6272060
-SHA256 4ab9630ae8e0bb76429d82793c70035c9d1d2a2eeea6abcbccd82e0b7940e402 AlephOne-20060506.tar.gz 6272060
diff --git a/games-fps/alephone/files/digest-alephone-20060701 b/games-fps/alephone/files/digest-alephone-20060701
deleted file mode 100644
index b4112afbab1b..000000000000
--- a/games-fps/alephone/files/digest-alephone-20060701
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 55adc626db175f9312613055a53276f2 AlephOne-20060701-nolibs.tar.bz2 1259392
-RMD160 e8b47276162e56e57a79822fee2d970dbe729d50 AlephOne-20060701-nolibs.tar.bz2 1259392
-SHA256 d68635020c91cfed4a703879c84aefdfbd97064798bf91a3dec954ff5fc593cd AlephOne-20060701-nolibs.tar.bz2 1259392