summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-01-20 23:34:46 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-01-20 23:34:46 +0000
commitdfa854c71f53816d2db32081cb5d894d305743d0 (patch)
tree494bfa6756e20339657873167453fb5de892ad0a /games-fps
parentcleanup old packages (diff)
downloadgentoo-2-dfa854c71f53816d2db32081cb5d894d305743d0.tar.gz
gentoo-2-dfa854c71f53816d2db32081cb5d894d305743d0.tar.bz2
gentoo-2-dfa854c71f53816d2db32081cb5d894d305743d0.zip
Fix build with boost-1.45. Bug #352123
(Portage version: 2.1.9.34/cvs/Linux i686)
Diffstat (limited to 'games-fps')
-rw-r--r--games-fps/alephone/ChangeLog8
-rw-r--r--games-fps/alephone/alephone-20100424.ebuild8
-rw-r--r--games-fps/alephone/files/alephone-20100424-boost_145.patch10
3 files changed, 21 insertions, 5 deletions
diff --git a/games-fps/alephone/ChangeLog b/games-fps/alephone/ChangeLog
index 158775163530..27c2ada37144 100644
--- a/games-fps/alephone/ChangeLog
+++ b/games-fps/alephone/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-fps/alephone
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.37 2010/08/19 03:35:39 phajdan.jr Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/ChangeLog,v 1.38 2011/01/20 23:34:46 tupone Exp $
+
+ 20 Jan 2011; Tupone Alfredo <tupone@gentoo.org> alephone-20100424.ebuild,
+ +files/alephone-20100424-boost_145.patch:
+ Fix build with boost-1.45. Bug #352123 by flameeyes@gentoo.org
19 Aug 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org>
alephone-20100424.ebuild:
diff --git a/games-fps/alephone/alephone-20100424.ebuild b/games-fps/alephone/alephone-20100424.ebuild
index f375ab6c29f8..86642ffb87c3 100644
--- a/games-fps/alephone/alephone-20100424.ebuild
+++ b/games-fps/alephone/alephone-20100424.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20100424.ebuild,v 1.3 2010/08/19 03:35:39 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-fps/alephone/alephone-20100424.ebuild,v 1.4 2011/01/20 23:34:46 tupone Exp $
EAPI=2
-inherit autotools games
+inherit autotools eutils games
MY_P=AlephOne-${PV}
DESCRIPTION="An enhanced version of the game engine from the classic Mac game, Marathon"
@@ -52,6 +52,8 @@ src_prepare() {
|| die "sed failed"
rm -rf Source_Files/Expat
+ epatch "${FILESDIR}"/${P}-boost_145.patch
+
eautoreconf
}
diff --git a/games-fps/alephone/files/alephone-20100424-boost_145.patch b/games-fps/alephone/files/alephone-20100424-boost_145.patch
new file mode 100644
index 000000000000..30d8b78594df
--- /dev/null
+++ b/games-fps/alephone/files/alephone-20100424-boost_145.patch
@@ -0,0 +1,10 @@
+--- Source_Files/Network/Metaserver/network_metaserver.h.old 2011-01-20 23:29:21.000000000 +0100
++++ Source_Files/Network/Metaserver/network_metaserver.h 2011-01-20 23:30:07.000000000 +0100
+@@ -32,6 +32,7 @@
+ #include <map>
+ #include <memory> // auto_ptr
+ #include <set>
++#include <stdexcept>
+
+ #include "Logging.h"
+