summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 17:15:51 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-04-12 17:15:51 +0000
commit4c3c056bb99ccc4fce6667d0765ca57682b694b5 (patch)
treeb72251dc258386d76574d466bfe439af269c9a09 /games-kids/pytraffic
parentDrop obsolete description (diff)
downloadgentoo-2-4c3c056bb99ccc4fce6667d0765ca57682b694b5.tar.gz
gentoo-2-4c3c056bb99ccc4fce6667d0765ca57682b694b5.tar.bz2
gentoo-2-4c3c056bb99ccc4fce6667d0765ca57682b694b5.zip
Use python_mod_optimize() and python_mod_cleanup() directly.
(Portage version: 2.2.0_alpha29_p17/cvs/Linux x86_64)
Diffstat (limited to 'games-kids/pytraffic')
-rw-r--r--games-kids/pytraffic/pytraffic-2.5.4.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/games-kids/pytraffic/pytraffic-2.5.4.ebuild b/games-kids/pytraffic/pytraffic-2.5.4.ebuild
index 3c2f37962ada..7d48ba0e36e6 100644
--- a/games-kids/pytraffic/pytraffic-2.5.4.ebuild
+++ b/games-kids/pytraffic/pytraffic-2.5.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/pytraffic/pytraffic-2.5.4.ebuild,v 1.7 2011/04/06 20:04:12 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/pytraffic/pytraffic-2.5.4.ebuild,v 1.8 2011/04/12 17:15:51 arfrever Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -53,6 +53,10 @@ pkg_setup() {
}
pkg_postinst() {
- distutils_pkg_postinst
+ python_mod_optimize "$(games_get_libdir)/${PN}"
games_pkg_postinst
}
+
+pkg_postrm() {
+ python_mod_cleanup "$(games_get_libdir)/${PN}"
+}