summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-11-07 01:21:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-11-07 01:21:17 +0000
commit0027e3e551ef750c2d128dcbb283524c59c65c07 (patch)
treedd2d5cbbdbee3a405636ff9f2a614b8e0baed34f /games-kids
parentStable on amd64 and x86. It's just firmware files. They haven't changed from ... (diff)
downloadgentoo-2-0027e3e551ef750c2d128dcbb283524c59c65c07.tar.gz
gentoo-2-0027e3e551ef750c2d128dcbb283524c59c65c07.tar.bz2
gentoo-2-0027e3e551ef750c2d128dcbb283524c59c65c07.zip
version bump
(Portage version: 2.1.1-r1)
Diffstat (limited to 'games-kids')
-rw-r--r--games-kids/gcompris/ChangeLog7
-rw-r--r--games-kids/gcompris/files/digest-gcompris-8.23
-rw-r--r--games-kids/gcompris/gcompris-8.2.ebuild69
3 files changed, 78 insertions, 1 deletions
diff --git a/games-kids/gcompris/ChangeLog b/games-kids/gcompris/ChangeLog
index 70b133aca58f..ec7f4c9bc79b 100644
--- a/games-kids/gcompris/ChangeLog
+++ b/games-kids/gcompris/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-kids/gcompris
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.29 2006/10/30 22:32:41 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/ChangeLog,v 1.30 2006/11/07 01:21:17 mr_bones_ Exp $
+
+*gcompris-8.2 (07 Nov 2006)
+
+ 07 Nov 2006; Michael Sterrett <mr_bones_@gentoo.org> +gcompris-8.2.ebuild:
+ version bump
30 Oct 2006; <tupone@gentoo.org> gcompris-8.1.ebuild:
Fix gcompris failure in configure. Bug #146843 by Ulrich Mueller
diff --git a/games-kids/gcompris/files/digest-gcompris-8.2 b/games-kids/gcompris/files/digest-gcompris-8.2
new file mode 100644
index 000000000000..0c1535bc6489
--- /dev/null
+++ b/games-kids/gcompris/files/digest-gcompris-8.2
@@ -0,0 +1,3 @@
+MD5 56849e2b09bea6a47eb6f177cc85258f gcompris-8.2.tar.gz 79157620
+RMD160 20be5f509f203bbf3cb781a472b65e6d4b433cda gcompris-8.2.tar.gz 79157620
+SHA256 fa38b319c34708701f6b5cc53630348bbf27d2150873353541bd781c58dbb997 gcompris-8.2.tar.gz 79157620
diff --git a/games-kids/gcompris/gcompris-8.2.ebuild b/games-kids/gcompris/gcompris-8.2.ebuild
new file mode 100644
index 000000000000..be33f55b7d0d
--- /dev/null
+++ b/games-kids/gcompris/gcompris-8.2.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-kids/gcompris/gcompris-8.2.ebuild,v 1.1 2006/11/07 01:21:17 mr_bones_ Exp $
+
+inherit autotools python games
+
+DESCRIPTION="full featured educational application for children from 2 to 10"
+HOMEPAGE="http://gcompris.net"
+SRC_URI="mirror://sourceforge/gcompris/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="python"
+
+RDEPEND="x11-libs/libXrandr
+ >=dev-libs/glib-2.0
+ =x11-libs/gtk+-2*
+ >=gnome-base/libgnomecanvas-2.0.2
+ media-libs/sdl-mixer
+ media-libs/libsdl
+ dev-libs/libxml2
+ python? (
+ dev-python/gnome-python
+ dev-python/pygtk
+ dev-python/pyxml
+ >=dev-python/pysqlite-2
+ )
+ >=dev-libs/popt-1.5
+ games-board/gnuchess"
+DEPEND="${RDEPEND}
+ sys-apps/texinfo
+ app-text/texi2html
+ x11-libs/libXt"
+RDEPEND="${RDEPEND}
+ media-gfx/tuxpaint
+ sci-electronics/gnucap"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's/-Werror//' \
+ -e '/AM_CHECK_PYMOD(gnome.canvas/d' \
+ configure.in \
+ || die "sed configure failed"
+ sed -i \
+ -e 's:libgcomprisinclude_HEADERS:noinst_HEADERS:' \
+ src/gcompris/Makefile.am \
+ || die "sed failed"
+ eautoreconf
+}
+
+src_compile() {
+ python_version
+ export GNUCHESS="${GAMES_BINDIR}/gnuchess"
+ econf \
+ --disable-dependency-tracking \
+ $(use_with python python /usr/bin/python${PYVER}) \
+ $(use_enable python sqlite) \
+ || die
+ emake -j1 || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README THANKS TODO
+ prepgamesdirs
+}