summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-04-19 07:25:01 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-04-19 07:25:01 +0000
commit52f886175926ad407f413fee666fe201e7b5d8f9 (patch)
tree1e13b5ac10ce83da6ca57333f9e98420920f416c /games-misc
parentadd missing test to IUSE (diff)
downloadgentoo-2-52f886175926ad407f413fee666fe201e7b5d8f9.tar.gz
gentoo-2-52f886175926ad407f413fee666fe201e7b5d8f9.tar.bz2
gentoo-2-52f886175926ad407f413fee666fe201e7b5d8f9.zip
Drop the gimp idea completely as the regenerated pngs do not differ anyway. Fixes all the sandbox violation issues gimp was causing. Wrt bug#412595.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'games-misc')
-rw-r--r--games-misc/opengfx/ChangeLog6
-rw-r--r--games-misc/opengfx/opengfx-0.4.4.ebuild14
2 files changed, 13 insertions, 7 deletions
diff --git a/games-misc/opengfx/ChangeLog b/games-misc/opengfx/ChangeLog
index 9a9b0ce0fac9..340022fd8694 100644
--- a/games-misc/opengfx/ChangeLog
+++ b/games-misc/opengfx/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-misc/opengfx
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.18 2012/04/18 20:34:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/ChangeLog,v 1.19 2012/04/19 07:25:01 scarabeus Exp $
+
+ 19 Apr 2012; Tomáš Chvátal <scarabeus@gentoo.org> opengfx-0.4.4.ebuild:
+ Drop the gimp idea completely as the regenerated pngs do not differ anyway.
+ Fixes all the sandbox violation issues gimp was causing. Wrt bug#412595.
18 Apr 2012; Michael Sterrett <mr_bones_@gentoo.org> opengfx-0.4.4.ebuild:
tidy
diff --git a/games-misc/opengfx/opengfx-0.4.4.ebuild b/games-misc/opengfx/opengfx-0.4.4.ebuild
index ef834daaa142..480cdac0c8dd 100644
--- a/games-misc/opengfx/opengfx-0.4.4.ebuild
+++ b/games-misc/opengfx/opengfx-0.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.4.4.ebuild,v 1.4 2012/04/18 20:34:23 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-misc/opengfx/opengfx-0.4.4.ebuild,v 1.5 2012/04/19 07:25:01 scarabeus Exp $
EAPI=3
inherit games
@@ -14,20 +14,22 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc ~x86"
IUSE=""
-DEPEND=">=games-util/nml-0.2.3
- media-gfx/gimp"
+DEPEND=">=games-util/nml-0.2.3"
RDEPEND=""
S=${WORKDIR}/${P}-source
src_prepare() {
sed -i -e 's/\[a-z\]/[[:alpha:]]/' ./scripts/Makefile.in || die
+
+ # ensure that we will not use gimp to regenerate the pngs
+ # causes sandbox violations and not worth the effort anyway
+ sed -i \
+ -e 's:echo "gimp":echo "":g' \
+ scripts/Makefile.def || die
}
src_compile() {
- GIMP2_DIRECTORY="${T}" \
- GEGL_PATH="${T}" \
- GEGL_SWAP="${T}" \
emake bundle || die
}