summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2008-05-01 10:30:08 +0000
committerTristan Heaven <nyhm@gentoo.org>2008-05-01 10:30:08 +0000
commit779df789d3d0bd898865996e08b0b87b95cca69c (patch)
treef53bb89f6dbd66ebf2ad399db9500e33ac348849 /games-mud
parentalpha/ia64/sparc/x86 stable (diff)
downloadgentoo-2-779df789d3d0bd898865996e08b0b87b95cca69c.tar.gz
gentoo-2-779df789d3d0bd898865996e08b0b87b95cca69c.tar.bz2
gentoo-2-779df789d3d0bd898865996e08b0b87b95cca69c.zip
Fix building with gcc-4.3
(Portage version: 2.1.5_rc6)
Diffstat (limited to 'games-mud')
-rw-r--r--games-mud/crystal/ChangeLog9
-rw-r--r--games-mud/crystal/crystal-0.2.2.ebuild18
-rw-r--r--games-mud/crystal/files/crystal-0.2.2-64bit.patch11
-rw-r--r--games-mud/crystal/files/crystal-0.2.2-gcc43.patch11
4 files changed, 42 insertions, 7 deletions
diff --git a/games-mud/crystal/ChangeLog b/games-mud/crystal/ChangeLog
index f194a1dcade8..e82fa874ad46 100644
--- a/games-mud/crystal/ChangeLog
+++ b/games-mud/crystal/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-mud/crystal
-# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/crystal/ChangeLog,v 1.5 2005/07/10 04:51:41 mr_bones_ Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-mud/crystal/ChangeLog,v 1.6 2008/05/01 10:30:07 nyhm Exp $
+
+ 01 May 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/crystal-0.2.2-64bit.patch, +files/crystal-0.2.2-gcc43.patch,
+ crystal-0.2.2.ebuild:
+ Fix building with gcc-4.3
*crystal-0.2.2 (10 Jul 2005)
diff --git a/games-mud/crystal/crystal-0.2.2.ebuild b/games-mud/crystal/crystal-0.2.2.ebuild
index 3efad49fb084..41a253dcd827 100644
--- a/games-mud/crystal/crystal-0.2.2.ebuild
+++ b/games-mud/crystal/crystal-0.2.2.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-mud/crystal/crystal-0.2.2.ebuild,v 1.1 2005/07/10 04:51:41 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-mud/crystal/crystal-0.2.2.ebuild,v 1.2 2008/05/01 10:30:07 nyhm Exp $
-inherit games
+inherit eutils games
DESCRIPTION="The crystal MUD client"
HOMEPAGE="http://www.evilmagic.org/crystal/"
@@ -10,13 +10,21 @@ SRC_URI="http://www.evilmagic.org/dist/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~ppc x86"
+KEYWORDS="~amd64 ~ppc x86"
IUSE=""
DEPEND="sys-libs/zlib
sys-libs/ncurses
dev-libs/openssl"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch \
+ "${FILESDIR}"/${P}-64bit.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
+}
+
src_compile() {
egamesconf \
--disable-scripting || die
@@ -24,7 +32,7 @@ src_compile() {
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS NEWS README TODO
prepgamesdirs
}
diff --git a/games-mud/crystal/files/crystal-0.2.2-64bit.patch b/games-mud/crystal/files/crystal-0.2.2-64bit.patch
new file mode 100644
index 000000000000..0d82356b7c24
--- /dev/null
+++ b/games-mud/crystal/files/crystal-0.2.2-64bit.patch
@@ -0,0 +1,11 @@
+--- Socket.cc
++++ Socket.cc
+@@ -212,7 +212,7 @@
+ int Socket::read(char *data, int size) {
+ if (pending) {
+ int opt = 0;
+- size_t osz = sizeof(int);
++ socklen_t osz = sizeof(int);
+ getsockopt(fd, SOL_SOCKET, SO_ERROR, &opt, &osz);
+ pending = 0;
+ if (opt != 0)
diff --git a/games-mud/crystal/files/crystal-0.2.2-gcc43.patch b/games-mud/crystal/files/crystal-0.2.2-gcc43.patch
new file mode 100644
index 000000000000..40623c5c22b3
--- /dev/null
+++ b/games-mud/crystal/files/crystal-0.2.2-gcc43.patch
@@ -0,0 +1,11 @@
+--- common.h
++++ common.h
+@@ -3,6 +3,8 @@
+
+ #include <string>
+ #include <stdio.h>
++#include <cstring>
++#include <cstdlib>
+ #include <curses.h>
+ #include <termios.h>
+ #include <sys/ioctl.h>