summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2010-01-09 18:59:59 +0000
committerAlfredo Tupone <tupone@gentoo.org>2010-01-09 18:59:59 +0000
commit0ad28d945bd599c5d585fb518779229a2ac4f684 (patch)
tree3a068972671eed4e80f905ce5bc56ebee4e17ec8 /games-puzzle/amoebax
parentTransfer Prefix keywords (diff)
downloadgentoo-2-0ad28d945bd599c5d585fb518779229a2ac4f684.tar.gz
gentoo-2-0ad28d945bd599c5d585fb518779229a2ac4f684.tar.bz2
gentoo-2-0ad28d945bd599c5d585fb518779229a2ac4f684.zip
Fix build with autoconf-2.65. Bug #297949
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/amoebax')
-rw-r--r--games-puzzle/amoebax/ChangeLog8
-rw-r--r--games-puzzle/amoebax/amoebax-0.2.0.ebuild10
-rw-r--r--games-puzzle/amoebax/files/amoebax-0.2.0-aclocal.patch41
3 files changed, 53 insertions, 6 deletions
diff --git a/games-puzzle/amoebax/ChangeLog b/games-puzzle/amoebax/ChangeLog
index d2781d24a58d..ee50e98611d2 100644
--- a/games-puzzle/amoebax/ChangeLog
+++ b/games-puzzle/amoebax/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/amoebax
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/ChangeLog,v 1.6 2009/06/13 18:13:11 nyhm Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/ChangeLog,v 1.7 2010/01/09 18:59:58 tupone Exp $
+
+ 09 Jan 2010; Tupone Alfredo <tupone@gentoo.org> amoebax-0.2.0.ebuild,
+ +files/amoebax-0.2.0-aclocal.patch:
+ Fix build with autoconf-2.65. Bug #297949 by flameeyes@gentoo.org
13 Jun 2009; Tristan Heaven <nyhm@gentoo.org> amoebax-0.2.0.ebuild,
+files/amoebax-0.2.0-glibc2.10.patch:
diff --git a/games-puzzle/amoebax/amoebax-0.2.0.ebuild b/games-puzzle/amoebax/amoebax-0.2.0.ebuild
index da22ddbd53d6..53f196342b8f 100644
--- a/games-puzzle/amoebax/amoebax-0.2.0.ebuild
+++ b/games-puzzle/amoebax/amoebax-0.2.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/amoebax-0.2.0.ebuild,v 1.6 2009/06/13 18:13:11 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/amoebax/amoebax-0.2.0.ebuild,v 1.7 2010/01/09 18:59:58 tupone Exp $
EAPI=2
inherit autotools eutils games
@@ -14,14 +14,16 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE=""
-DEPEND="media-libs/libsdl
+RDEPEND="media-libs/libsdl
media-libs/sdl-image
media-libs/sdl-mixer"
+DEPEND="${RDEPEND}"
src_prepare() {
epatch \
"${FILESDIR}"/${P}-gcc43.patch \
- "${FILESDIR}"/${P}-glibc2.10.patch
+ "${FILESDIR}"/${P}-glibc2.10.patch \
+ "${FILESDIR}"/${P}-aclocal.patch
sed -i \
-e "/^SUBDIRS/s:doc ::" \
Makefile.am \
diff --git a/games-puzzle/amoebax/files/amoebax-0.2.0-aclocal.patch b/games-puzzle/amoebax/files/amoebax-0.2.0-aclocal.patch
new file mode 100644
index 000000000000..312585900309
--- /dev/null
+++ b/games-puzzle/amoebax/files/amoebax-0.2.0-aclocal.patch
@@ -0,0 +1,41 @@
+--- m4/objc.m4.old 2010-01-09 19:41:58.000000000 +0100
++++ m4/objc.m4 2010-01-09 19:43:35.000000000 +0100
+@@ -448,32 +448,32 @@
+
+ # AC_LANG_SOURCE(Objective C)(BODY)
+ # ---------------------------------
+-m4_copy([AC_LANG_SOURCE(C)], [AC_LANG_SOURCE(Objective C)])
++m4_copy_force([AC_LANG_SOURCE(C)], [AC_LANG_SOURCE(Objective C)])
+
+
+ # AC_LANG_PROGRAM(Objective C)([PROLOGUE], [BODY])
+ # ------------------------------------------------
+-m4_copy([AC_LANG_PROGRAM(C)], [AC_LANG_PROGRAM(Objective C)])
++m4_copy_force([AC_LANG_PROGRAM(C)], [AC_LANG_PROGRAM(Objective C)])
+
+
+ # AC_LANG_CALL(Objective C)(PROLOGUE, FUNCTION)
+ # ---------------------------------------------
+-m4_copy([AC_LANG_CALL(C)], [AC_LANG_CALL(Objective C)])
++m4_copy_force([AC_LANG_CALL(C)], [AC_LANG_CALL(Objective C)])
+
+
+ # AC_LANG_FUNC_LINK_TRY(Objective C)(FUNCTION)
+ # --------------------------------------------
+-m4_copy([AC_LANG_FUNC_LINK_TRY(C)], [AC_LANG_FUNC_LINK_TRY(Objective C)])
++m4_copy_force([AC_LANG_FUNC_LINK_TRY(C)], [AC_LANG_FUNC_LINK_TRY(Objective C)])
+
+
+ # AC_LANG_BOOL_COMPILE_TRY(Objective C)(PROLOGUE, EXPRESSION)
+ # -----------------------------------------------------------
+-m4_copy([AC_LANG_BOOL_COMPILE_TRY(C)], [AC_LANG_BOOL_COMPILE_TRY(Objective C)])
++m4_copy_force([AC_LANG_BOOL_COMPILE_TRY(C)], [AC_LANG_BOOL_COMPILE_TRY(Objective C)])
+
+
+ # AC_LANG_INT_SAVE(Objective C)(PROLOGUE, EXPRESSION)
+ # ---------------------------------------------------
+-m4_copy([AC_LANG_INT_SAVE(C)], [AC_LANG_INT_SAVE(Objective C)])
++m4_copy_force([AC_LANG_INT_SAVE(C)], [AC_LANG_INT_SAVE(Objective C)])
+
+
+