summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2004-10-16 01:31:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2004-10-16 01:31:06 +0000
commit8a80d2c94c09a36889b2744d7a62fd6327f1c4b2 (patch)
treeaac0148a4dd51b3fe07786116949d7f302fbaba8 /games-puzzle/enigma
parentMarked stable x86 and fixed bug# 67673 Thanks Vaclav Slavik <vaclav.slavik@ma... (diff)
downloadgentoo-2-8a80d2c94c09a36889b2744d7a62fd6327f1c4b2.tar.gz
gentoo-2-8a80d2c94c09a36889b2744d7a62fd6327f1c4b2.tar.bz2
gentoo-2-8a80d2c94c09a36889b2744d7a62fd6327f1c4b2.zip
Add gcc34 patch from Mandrakesoft (bug #66904)
Diffstat (limited to 'games-puzzle/enigma')
-rw-r--r--games-puzzle/enigma/ChangeLog6
-rw-r--r--games-puzzle/enigma/Manifest3
-rw-r--r--games-puzzle/enigma/enigma-0.81.ebuild11
-rw-r--r--games-puzzle/enigma/files/enigma-0.81-gcc34.patch201
4 files changed, 214 insertions, 7 deletions
diff --git a/games-puzzle/enigma/ChangeLog b/games-puzzle/enigma/ChangeLog
index 886405beb38d..67b7cc5fa415 100644
--- a/games-puzzle/enigma/ChangeLog
+++ b/games-puzzle/enigma/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/enigma
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.14 2004/09/24 23:51:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.15 2004/10/16 01:31:06 mr_bones_ Exp $
+
+ 15 Oct 2004; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/enigma-0.81-gcc34.patch, enigma-0.81.ebuild:
+ Add gcc34 patch from Mandrakesoft (bug #66904)
24 Sep 2004; Michael Sterrett <mr_bones_@gentoo.org> enigma-0.81.ebuild:
update HOMEPAGE (bug #65260)
diff --git a/games-puzzle/enigma/Manifest b/games-puzzle/enigma/Manifest
index c9c4e3d5bf24..21a1edd3b971 100644
--- a/games-puzzle/enigma/Manifest
+++ b/games-puzzle/enigma/Manifest
@@ -1,6 +1,7 @@
MD5 a57ac2a4f754198fc4a6d88e4ebae0dc ChangeLog 3033
-MD5 eaf48873b20964840942f9f21dfc7909 enigma-0.81.ebuild 1284
+MD5 be6294ea21a08f19c4e750ccc17633c3 enigma-0.81.ebuild 1338
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
MD5 43e970bb89bb24c634b411cf29b5cb7f files/0.70-gcc3.patch 258
MD5 bebed419a4c41cffce2a7428f989b809 files/enigma-0.80-beta.patch 403
MD5 a6926b0172a634b74980c6df03de48e4 files/digest-enigma-0.81 64
+MD5 9a83f99d9e12ec1d19a7a3a8c9964da6 files/enigma-0.81-gcc34.patch 7377
diff --git a/games-puzzle/enigma/enigma-0.81.ebuild b/games-puzzle/enigma/enigma-0.81.ebuild
index 5fcce5e87aa8..b0e96b751f40 100644
--- a/games-puzzle/enigma/enigma-0.81.ebuild
+++ b/games-puzzle/enigma/enigma-0.81.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-0.81.ebuild,v 1.13 2004/09/24 23:51:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-0.81.ebuild,v 1.14 2004/10/16 01:31:06 mr_bones_ Exp $
-inherit games
+inherit eutils games
DESCRIPTION="puzzle game similar to Oxyd"
HOMEPAGE="http://www.nongnu.org/enigma/"
@@ -25,7 +25,8 @@ DEPEND="${RDEOEND}
src_unpack() {
unpack ${A}
- cd ${S}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-gcc34.patch"
sed -i \
-e 's:$(pkgdatadir):$(DESTDIR)$(pkgdatadir):' \
data/levels/Makefile.am \
@@ -43,8 +44,8 @@ src_compile() {
src_install() {
make DESTDIR="${D}" install || die "make install failed"
- mv ${D}/${GAMES_PREFIX}/share/* ${D}/usr/share/
- rm -r ${D}/${GAMES_PREFIX}/share
+ mv "${D}/${GAMES_PREFIX}/share/"* "${D}/usr/share/"
+ rm -r "${D}/${GAMES_PREFIX}/share"
dodoc NEWS README AUTHORS INSTALL ChangeLog
prepgamesdirs
}
diff --git a/games-puzzle/enigma/files/enigma-0.81-gcc34.patch b/games-puzzle/enigma/files/enigma-0.81-gcc34.patch
new file mode 100644
index 000000000000..b9fc280c7443
--- /dev/null
+++ b/games-puzzle/enigma/files/enigma-0.81-gcc34.patch
@@ -0,0 +1,201 @@
+Index: src/object_mixins.hh
+===================================================================
+--- src/object_mixins.hh
++++ src/object_mixins.hh 2004-07-02 16:46:30.787586969 +0200
+@@ -80,14 +80,14 @@
+ template <class T>
+ class OnOffBase : public T {
+ protected:
+- OnOffBase(const char *kind) : T(kind) { set_attrib("on", 0.0); }
++ OnOffBase(const char *kind) : T(kind) { this->set_attrib("on", 0.0); }
+
+- bool is_on() const { return int_attrib("on") == 1; }
++ bool is_on() const { return this->int_attrib("on") == 1; }
+
+ void set_on(bool newon) {
+ if (newon != is_on()) {
+- set_attrib("on", Value(newon));
+- init_model();
++ this->set_attrib("on", Value(newon));
++ this->init_model();
+ notify_onoff(newon);
+ }
+ }
+Index: src/px/alist.hh
+===================================================================
+--- src/px/alist.hh
++++ src/px/alist.hh 2004-07-02 16:43:07.785292225 +0200
+@@ -43,7 +43,7 @@
+ // Lookup of keys
+ //
+ iterator find (const key_type &key) {
+- iterator i=begin(), e=end();
++ iterator i=this->begin(), e=this->end();
+ for (; i!=e; ++i)
+ if (i->first == key)
+ break;
+@@ -51,7 +51,7 @@
+ }
+
+ const_iterator find (const key_type &key) const {
+- const_iterator i=begin(), e=end();
++ const_iterator i=this->begin(), e=this->end();
+ for (; i!=e; ++i)
+ if (i->first == key)
+ break;
+@@ -60,8 +60,8 @@
+
+ VAL &operator[] (const key_type &key) {
+ iterator i=find(key);
+- if (i==end())
+- i=insert(end(), make_pair(key, VAL()));
++ if (i==this->end())
++ i=insert(this->end(), make_pair(key, VAL()));
+ return i->second;
+ }
+ };
+Index: src/px/array2.hh
+===================================================================
+--- src/px/array2.hh
++++ src/px/array2.hh 2004-07-02 16:42:05.426430416 +0200
+@@ -70,14 +70,14 @@
+ // Destructor
+ ~Array2() { destroy_elements(); }
+
+- iterator begin() { return first; }
+- iterator end() { return last; }
+- const_iterator begin() const { return first; }
+- const_iterator end() const { return last; }
+- iterator row_begin(size_type y) { return first + y*w; }
+- iterator row_end(size_type y) { return first + y*w + w; }
+- const_iterator row_begin(size_type y) const { return first + y*w; }
+- const_iterator row_end(size_type y) const { return first + y*w + w; }
++ iterator begin() { return this->first; }
++ iterator end() { return this->last; }
++ const_iterator begin() const { return this->first; }
++ const_iterator end() const { return this->last; }
++ iterator row_begin(size_type y) { return this->first + y*w; }
++ iterator row_end(size_type y) { return this->first + y*w + w; }
++ const_iterator row_begin(size_type y) const { return this->first + y*w; }
++ const_iterator row_end(size_type y) const { return this->first + y*w + w; }
+
+
+ void swap(Array2<T,A> &a2);
+@@ -86,13 +86,13 @@
+ size_type height()const { return h; }
+
+
+- T& get(size_type x, size_type y) { return first[y*w+x]; }
+- const T& get(size_type x, size_type y) const { return first[y*w+x]; }
++ T& get(size_type x, size_type y) { return this->first[y*w+x]; }
++ const T& get(size_type x, size_type y) const { return this->first[y*w+x]; }
+ T& operator()(size_type x, size_type y) { return get(x,y); }
+ const T& operator()(size_type x, size_type y) const { return get(x,y); }
+
+ void set(size_type x, size_type y, const T& val) {
+- first[y*w+x] = val;
++ this->first[y*w+x] = val;
+ }
+
+ /*! Fill the array with some value or the default value. */
+@@ -112,19 +112,19 @@
+ Array2<T,A>::Array2(int ww, int hh, const T& val, const A& a)
+ : Array2Base<T,A>(a, ww*hh), w(ww), h(hh)
+ {
+- std::uninitialized_fill(first, last, val);
++ std::uninitialized_fill(this->first, this->last, val);
+ }
+
+ template <class T, class A>
+ Array2<T,A>::Array2(const Array2<T,A> &a)
+ : Array2Base<T,A>(a.alloc, a.last-a.first)
+ {
+- std::uninitialized_copy(a.begin(), a.end(), first);
++ std::uninitialized_copy(a.begin(), a.end(), this->first);
+ }
+
+ template <class T, class A>
+ void Array2<T,A>::destroy_elements() {
+- for (T* p=first; p!=last; ++p)
++ for (T* p=this->first; p!=this->last; ++p)
+ p->~T();
+ }
+
+@@ -132,7 +132,7 @@
+ void Array2<T,A>::fill (const T& val)
+ {
+ destroy_elements();
+- std::uninitialized_fill(first, last, val);
++ std::uninitialized_fill(this->first, this->last, val);
+ }
+
+ /*! Resize the array in place, but discard any old array
+@@ -142,7 +142,7 @@
+ {
+ destroy_elements();
+ Array2Base<T,A>::resize(w_*h_);
+- std::uninitialized_fill(first, last, val);
++ std::uninitialized_fill(this->first, this->last, val);
+ w = w_;
+ h = h_;
+ }
+@@ -150,8 +150,8 @@
+ template <class T, class A>
+ void Array2<T,A>::swap(Array2<T,A> &a2)
+ {
+- std::swap(first, a2.first);
+- std::swap(last, a2.last);
++ std::swap(this->first, a2.first);
++ std::swap(this->last, a2.last);
+ std::swap(w, a2.w);
+ std::swap(h, a2.h);
+ }
+Index: src/px/dict.hh
+===================================================================
+--- src/px/dict.hh
++++ src/px/dict.hh 2004-07-02 16:32:18.620140973 +0200
+@@ -101,8 +101,8 @@
+ public:
+ typedef Iter<value_type> iterator;
+ typedef Iter<const value_type> const_iterator;
+- friend class iterator;
+- friend class const_iterator;
++ //friend class iterator;
++ //friend class const_iterator;
+
+ Dict(size_type table_size = 257);
+ ~Dict();
+@@ -126,7 +126,7 @@
+
+ const T& lookup(const std::string &key) const {
+ Entry *e = find_entry(key);
+- if (!e) throw XInvalidKey();
++ if (!e) throw this->XInvalidKey();
+ return e->pair.second;
+ }
+
+Index: src/px/video.cc
+===================================================================
+--- src/px/video.cc
++++ src/px/video.cc 2004-07-02 16:38:16.957600495 +0200
+@@ -207,16 +207,16 @@
+ void set_pixels(int n, const int* xlist, const int* ylist, Uint32 color)
+ {
+ const int *xp = xlist, *yp = ylist;
+- if (NOCLIP(gs)) {
++ if (NOCLIP(this->gs)) {
+ for (int i=n; i > 0; --i) {
+ int x = *xp++, y = *yp++;
+- *pixel_pointer(x,y) = gs.pcolor;
++ *pixel_pointer(x,y) = this->gs.pcolor;
+ }
+ } else {
+ for (int i=n; i > 0; --i) {
+ int x = *xp++, y = *yp++;
+- if (clip_pixel (gs, x, y))
+- *pixel_pointer(x,y) = gs.pcolor;
++ if (clip_pixel (this->gs, x, y))
++ *pixel_pointer(x,y) = this->gs.pcolor;
+ }
+ }
+ }