summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-07-07 17:28:12 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-07-07 17:28:12 +0000
commit992133d78329390eafab568e417cc67fdfcc2469 (patch)
treeb1f7d70d7329cad8a44feb74f1deaa3be42b1fb1 /games-puzzle/kiki
parentReplaced einfo occurences with elog. (diff)
downloadgentoo-2-992133d78329390eafab568e417cc67fdfcc2469.tar.gz
gentoo-2-992133d78329390eafab568e417cc67fdfcc2469.tar.bz2
gentoo-2-992133d78329390eafab568e417cc67fdfcc2469.zip
clean out cruft; add freeglut patch from Tristan Heaven for bug #139445
(Portage version: 2.1.1_pre2-r2)
Diffstat (limited to 'games-puzzle/kiki')
-rw-r--r--games-puzzle/kiki/ChangeLog9
-rw-r--r--games-puzzle/kiki/files/digest-kiki-1.0.2-r13
-rw-r--r--games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch19
-rw-r--r--games-puzzle/kiki/kiki-1.0.2-r1.ebuild70
4 files changed, 100 insertions, 1 deletions
diff --git a/games-puzzle/kiki/ChangeLog b/games-puzzle/kiki/ChangeLog
index 2a2b98e402dd..ac221f9513b6 100644
--- a/games-puzzle/kiki/ChangeLog
+++ b/games-puzzle/kiki/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-puzzle/kiki
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.10 2006/05/29 22:22:39 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/ChangeLog,v 1.11 2006/07/07 17:28:12 mr_bones_ Exp $
+
+*kiki-1.0.2-r1 (07 Jul 2006)
+
+ 07 Jul 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/kiki-1.0.2-freeglut.patch, -kiki-0.9.0-r1.ebuild,
+ -kiki-1.0.2.ebuild, +kiki-1.0.2-r1.ebuild:
+ clean out cruft; add freeglut patch from Tristan Heaven for bug #139445
29 May 2006; <Tupone@gentoo.org> Manifest:
Fixing Manifest
diff --git a/games-puzzle/kiki/files/digest-kiki-1.0.2-r1 b/games-puzzle/kiki/files/digest-kiki-1.0.2-r1
new file mode 100644
index 000000000000..1162d1e6a149
--- /dev/null
+++ b/games-puzzle/kiki/files/digest-kiki-1.0.2-r1
@@ -0,0 +1,3 @@
+MD5 eb4966eae85d3a073aab521bf1ba33e2 kiki-1.0.2-src.tgz 3366523
+RMD160 78e71cae75f7d6957d06fb8c7323d607bc232499 kiki-1.0.2-src.tgz 3366523
+SHA256 7651f57543ce61c22bcc01daf6a68e0ab31ba353f9b2fbc067e323bbba6e1246 kiki-1.0.2-src.tgz 3366523
diff --git a/games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch b/games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch
new file mode 100644
index 000000000000..aab70ba69b72
--- /dev/null
+++ b/games-puzzle/kiki/files/kiki-1.0.2-freeglut.patch
@@ -0,0 +1,19 @@
+--- src/main/main.cpp.orig 2003-04-11 14:42:29.000000000 +0100
++++ src/main/main.cpp 2006-07-06 19:37:55.000000000 +0100
+@@ -9,6 +9,7 @@
+ #include <math.h>
+
+ #include <SDL.h>
++#include <GL/glut.h>
+ #include "KikiController.h"
+
+ // __________________________________________________________________________________________________
+@@ -19,6 +20,8 @@
+ int width, height;
+ SDL_Surface * screen;
+
++ glutInit(&argc, argv);
++
+ // initialize SDL
+ if ( SDL_Init(SDL_INIT_VIDEO | SDL_INIT_VIDEO) < 0 ) // SDL_INIT_TIMER
+ {
diff --git a/games-puzzle/kiki/kiki-1.0.2-r1.ebuild b/games-puzzle/kiki/kiki-1.0.2-r1.ebuild
new file mode 100644
index 000000000000..4a2ccac18725
--- /dev/null
+++ b/games-puzzle/kiki/kiki-1.0.2-r1.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/kiki/kiki-1.0.2-r1.ebuild,v 1.1 2006/07/07 17:28:12 mr_bones_ Exp $
+
+inherit eutils python games
+
+DESCRIPTION="Fun 3D puzzle game using SDL/OpenGL"
+HOMEPAGE="http://kiki.sourceforge.net/"
+SRC_URI="mirror://sourceforge/kiki/${P}-src.tgz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="ppc x86"
+IUSE=""
+
+DEPEND=">=media-libs/libsdl-1.2
+ >=media-libs/sdl-image-1.2.2
+ >=media-libs/sdl-mixer-1.2.5
+ >=dev-lang/python-2.2
+ virtual/glut"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}"-gcc41.patch \
+ "${FILESDIR}/${P}"-freeglut.patch
+ # There are CVS directories in the tgz file
+ rm -rf $(find -name CVS -type d)
+ rm -rf $(find -name .cvsignore)
+ rm *.dll Readme.rtf uDevGame\ Readme.txt
+ edos2unix Readme.txt Thanks.txt Thanks.txt
+ chmod a-x sound/*.*
+
+ # Change the hard-coded data dir for sounds, etc...
+ sed -i \
+ -e "s:kiki_home += \"/\";:kiki_home = \"${GAMES_DATADIR}/${PN}/\";:g" \
+ -e "s:KConsole\:\:printf(\"WARNING \:\: environment variable KIKI_HOME not set ...\");::g" \
+ -e "s:KConsole\:\:printf(\" ... assuming resources in current directory\");::g" \
+ src/main/KikiController.cpp \
+ || die "sed KikiController.cpp failed"
+ python_version
+ sed -i \
+ -e "/^PYTHON_VERSION/s/2.3/${PYVER}/" \
+ -e '/lib-dynload/d' \
+ -e '/^PYTHONLIBS/s:\\:-lpython$(PYTHON_VERSION):' \
+ linux/Makefile \
+ || die "sed kiki_src/kiki/linux/Makefile failed"
+}
+
+
+src_compile() {
+ cd kodilib/linux
+ emake || die "emake in kodilib/linux failed"
+ cd ../../linux
+ emake || die "emake in linux failed"
+}
+
+src_install() {
+ dogamesbin linux/kiki || die "dogamesbin failed"
+
+ dodir "${GAMES_DATADIR}/${PN}"/{py,sound}
+ cp -R py sound "${D}${GAMES_DATADIR}/${PN}" \
+ || die "cp failed"
+
+ dodoc Readme.txt Thanks.txt
+ prepgamesdirs
+}