summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
committerMike Frysinger <vapier@gentoo.org>2003-09-10 06:36:01 +0000
commit2f7b073c1bc54c873666c4522cd6cd49ac1d59df (patch)
tree072f3e7b49f6b078b595b1483277009b1f03d0f6 /games-puzzle/xblockout
parentgames-puzzle (diff)
downloadgentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.tar.gz
gentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.tar.bz2
gentoo-2-2f7b073c1bc54c873666c4522cd6cd49ac1d59df.zip
games-puzzle !@
Diffstat (limited to 'games-puzzle/xblockout')
-rw-r--r--games-puzzle/xblockout/ChangeLog16
-rw-r--r--games-puzzle/xblockout/Manifest5
-rw-r--r--games-puzzle/xblockout/files/digest-xblockout-1.0k1
-rw-r--r--games-puzzle/xblockout/files/digest-xblockout-1.1.11
-rw-r--r--games-puzzle/xblockout/xblockout-1.0k.ebuild48
-rw-r--r--games-puzzle/xblockout/xblockout-1.1.1.ebuild48
6 files changed, 119 insertions, 0 deletions
diff --git a/games-puzzle/xblockout/ChangeLog b/games-puzzle/xblockout/ChangeLog
new file mode 100644
index 000000000000..bac57595591c
--- /dev/null
+++ b/games-puzzle/xblockout/ChangeLog
@@ -0,0 +1,16 @@
+# ChangeLog for app-games/xblockout
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/ChangeLog,v 1.1 2003/09/10 06:36:00 vapier Exp $
+
+*xblockout-1.1.1 (17 Aug 2003)
+
+ 17 Aug 2003; Michael Sterrett <msterret@gentoo.org> xblockout-1.1.1.ebuild:
+ version bump
+
+ 28 Jun 2003; <msterret@gentoo.org> xblockout-1.0k.ebuild:
+ use sed -i
+
+*xblockout-1.0k (27 Jun 2003)
+
+ 27 Jun 2003; Mike Frysinger <vapier@gentoo.org> :
+ Initial import. Ebuild submitted by Henrik Johansson <henrik_johansson@home.se> #19429.
diff --git a/games-puzzle/xblockout/Manifest b/games-puzzle/xblockout/Manifest
new file mode 100644
index 000000000000..794f8093a350
--- /dev/null
+++ b/games-puzzle/xblockout/Manifest
@@ -0,0 +1,5 @@
+MD5 72226f924864ec486e1237f7ea2e8fd1 ChangeLog 596
+MD5 b89b1d1a4a57d660f858021df6b53281 xblockout-1.0k.ebuild 1056
+MD5 bbc65c2389d40c345e983bfed1f4c621 xblockout-1.1.1.ebuild 1073
+MD5 b5621a2229a4333ebe6f8d7a1de6bca8 files/digest-xblockout-1.0k 60
+MD5 178132632e2994de633d36969c9a1f48 files/digest-xblockout-1.1.1 61
diff --git a/games-puzzle/xblockout/files/digest-xblockout-1.0k b/games-puzzle/xblockout/files/digest-xblockout-1.0k
new file mode 100644
index 000000000000..4fd3d39e19c5
--- /dev/null
+++ b/games-puzzle/xblockout/files/digest-xblockout-1.0k
@@ -0,0 +1 @@
+MD5 22e7822a449ae5b68695158fd59ea49c xbl-1.0k.tar.gz 135080
diff --git a/games-puzzle/xblockout/files/digest-xblockout-1.1.1 b/games-puzzle/xblockout/files/digest-xblockout-1.1.1
new file mode 100644
index 000000000000..1f69f6dac017
--- /dev/null
+++ b/games-puzzle/xblockout/files/digest-xblockout-1.1.1
@@ -0,0 +1 @@
+MD5 5c066ddd754995905cce5a15c2218b11 xbl-1.1.1.tar.gz 135716
diff --git a/games-puzzle/xblockout/xblockout-1.0k.ebuild b/games-puzzle/xblockout/xblockout-1.0k.ebuild
new file mode 100644
index 000000000000..0ea3b0eef1ef
--- /dev/null
+++ b/games-puzzle/xblockout/xblockout-1.0k.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/xblockout-1.0k.ebuild,v 1.1 2003/09/10 06:36:00 vapier Exp $
+
+inherit games
+
+DESCRIPTION="XBlockOut: X Window block dropping game in 3 Dimension"
+HOMEPAGE="http://www710.univ-lyon1.fr/ftp/xbl/xbl.html"
+SRC_URI="ftp://ftp710.univ-lyon1.fr/pub/xbl/xbl-${PV}.tar.gz"
+
+LICENSE="GPL-1"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/xbl-${PV}
+
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e "s:-g$:${CFLAGS}:" ${S}/Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_compile() {
+ egamesconf || die
+ emake \
+ SCOREDIR=${GAMES_STATEDIR}/${PN} \
+ GROUP_GID=`id -g ${GAMES_GROUP}` \
+ RESOURCEDIR=${GAMES_DATADIR}/${PN} \
+ || die
+}
+
+src_install() {
+ newgamesbin bl xbl
+ insinto ${GAMES_DATADIR}/${PN}
+ newins Xbl.ad Xbl
+ insinto ${GAMES_STATEDIR}/${PN}
+ newins Xbl.ad Xbl
+
+ newman xbl.man xbl.6
+ dodoc README xbl-README
+ dohtml *.html *.gif
+
+ prepgamesdirs
+}
diff --git a/games-puzzle/xblockout/xblockout-1.1.1.ebuild b/games-puzzle/xblockout/xblockout-1.1.1.ebuild
new file mode 100644
index 000000000000..3ecfb54cc796
--- /dev/null
+++ b/games-puzzle/xblockout/xblockout-1.1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xblockout/xblockout-1.1.1.ebuild,v 1.1 2003/09/10 06:36:00 vapier Exp $
+
+inherit games
+
+DESCRIPTION="XBlockOut: X Window block dropping game in 3 Dimension"
+HOMEPAGE="http://www710.univ-lyon1.fr/ftp/xbl/xbl.html"
+SRC_URI="ftp://ftp710.univ-lyon1.fr/pub/xbl/xbl-${PV}.tar.gz"
+
+LICENSE="GPL-1"
+KEYWORDS="x86"
+SLOT="0"
+
+DEPEND="virtual/x11
+ >=sys-apps/sed-4"
+
+S=${WORKDIR}/xbl-${PV}
+
+src_unpack() {
+ unpack ${A}
+ sed -i \
+ -e "s:-g$:${CFLAGS}:" ${S}/Makefile.in || \
+ die "sed Makefile.in failed"
+}
+
+src_compile() {
+ egamesconf || die
+ emake \
+ SCOREDIR=${GAMES_STATEDIR}/${PN} \
+ GROUP_GID=`id -g ${GAMES_GROUP}` \
+ RESOURCEDIR=${GAMES_DATADIR}/${PN} || \
+ die "emake failed"
+}
+
+src_install() {
+ newgamesbin bl xbl
+ insinto ${GAMES_DATADIR}/${PN}
+ newins Xbl.ad Xbl
+ insinto ${GAMES_STATEDIR}/${PN}
+ newins Xbl.ad Xbl
+
+ newman xbl.man xbl.6
+ dodoc README xbl-README
+ dohtml *.html *.gif
+
+ prepgamesdirs
+}