summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2003-11-12 09:21:47 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2003-11-12 09:21:47 +0000
commite46655677281473fd7b0b68f627dfbac71a89e09 (patch)
tree7c9a916be79685edc7da22da5a107275be10adad /games-puzzle/xpired/xpired-1.22.ebuild
parentinitial commit; ebuild supplied by Eric Harney via bug 33254 (diff)
downloadgentoo-2-e46655677281473fd7b0b68f627dfbac71a89e09.tar.gz
gentoo-2-e46655677281473fd7b0b68f627dfbac71a89e09.tar.bz2
gentoo-2-e46655677281473fd7b0b68f627dfbac71a89e09.zip
initial commit; ebuild supplied by Eric Harney via bug 33254
Diffstat (limited to 'games-puzzle/xpired/xpired-1.22.ebuild')
-rw-r--r--games-puzzle/xpired/xpired-1.22.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/games-puzzle/xpired/xpired-1.22.ebuild b/games-puzzle/xpired/xpired-1.22.ebuild
new file mode 100644
index 000000000000..bf5cffa848de
--- /dev/null
+++ b/games-puzzle/xpired/xpired-1.22.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/xpired/xpired-1.22.ebuild,v 1.1 2003/11/12 09:21:45 mr_bones_ Exp $
+
+inherit games
+
+S="${WORKDIR}/src"
+DESCRIPTION="A Sokoban-styled puzzle game with lots more action."
+HOMEPAGE="http://xpired.sourceforge.net"
+SRC_URI="mirror://sourceforge/xpired/${P}-linux_source.tar.gz"
+
+KEYWORDS="x86"
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+DEPEND="virtual/glibc
+ media-libs/sdl-gfx
+ media-libs/sdl-image
+ media-libs/sdl-mixer"
+
+src_compile() {
+ emake PREFIX=/usr/games SHARE_PREFIX=/usr/share/games/xpired || \
+ die "emake failed"
+}
+src_install() {
+ make \
+ PREFIX="${D}/usr/games" \
+ SHARE_PREFIX="${D}/usr/share/games/${PN}" \
+ install || die "make install failed"
+ prepgamesdirs
+}