summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2010-09-04 07:50:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2010-09-04 07:50:50 +0000
commit4a0eb24cb4018127611229760d185f97aa6f8bae (patch)
tree59f40450046695914e01660fa57e2707f5656ba0 /games-puzzle/zaz/zaz-1.0.0.ebuild
parentVersion bump (diff)
downloadgentoo-2-4a0eb24cb4018127611229760d185f97aa6f8bae.tar.gz
gentoo-2-4a0eb24cb4018127611229760d185f97aa6f8bae.tar.bz2
gentoo-2-4a0eb24cb4018127611229760d185f97aa6f8bae.zip
version bump
(Portage version: 2.1.8.3/cvs/Linux i686)
Diffstat (limited to 'games-puzzle/zaz/zaz-1.0.0.ebuild')
-rw-r--r--games-puzzle/zaz/zaz-1.0.0.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/games-puzzle/zaz/zaz-1.0.0.ebuild b/games-puzzle/zaz/zaz-1.0.0.ebuild
new file mode 100644
index 000000000000..cc8a5e995e67
--- /dev/null
+++ b/games-puzzle/zaz/zaz-1.0.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/zaz/zaz-1.0.0.ebuild,v 1.1 2010/09/04 07:50:50 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="A puzzle game where the player has to arrange balls in triplets"
+HOMEPAGE="http://sourceforge.net/projects/zaz/"
+SRC_URI="mirror://sourceforge/zaz/${P}.tar.bz2"
+
+LICENSE="GPL-3 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ media-libs/libsdl[X,audio,video]
+ media-libs/sdl-image[jpeg,png]
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/ftgl
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-build.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --with-applicationdir=/usr/share/applications \
+ --with-icondir=/usr/share/pixmaps \
+ --localedir=/usr/share/locale \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake failed"
+ dodoc AUTHORS ChangeLog
+ prepgamesdirs
+}