summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2015-02-05 03:50:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2015-02-05 03:50:07 +0000
commit506183e709bdfd1bdf6e36522386b1f78db240c4 (patch)
treedc42f373873e536c718b5be3497d86a41b66cd12 /games-puzzle
parentold (diff)
downloadgentoo-2-506183e709bdfd1bdf6e36522386b1f78db240c4.tar.gz
gentoo-2-506183e709bdfd1bdf6e36522386b1f78db240c4.tar.bz2
gentoo-2-506183e709bdfd1bdf6e36522386b1f78db240c4.zip
old
(Portage version: 2.2.14/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/icebreaker/ChangeLog7
-rw-r--r--games-puzzle/icebreaker/files/icebreaker-1.9.5-gentoo.patch251
-rw-r--r--games-puzzle/icebreaker/files/icebreaker-1.9.5-ldflags.patch28
-rw-r--r--games-puzzle/icebreaker/files/icebreaker-1.9.5-parallell-install.patch34
-rw-r--r--games-puzzle/icebreaker/icebreaker-1.9.5.ebuild44
5 files changed, 6 insertions, 358 deletions
diff --git a/games-puzzle/icebreaker/ChangeLog b/games-puzzle/icebreaker/ChangeLog
index 596e4a6a8ba8..d51d71719ce5 100644
--- a/games-puzzle/icebreaker/ChangeLog
+++ b/games-puzzle/icebreaker/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-puzzle/icebreaker
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/ChangeLog,v 1.22 2015/01/28 10:24:38 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/ChangeLog,v 1.23 2015/02/05 03:50:07 mr_bones_ Exp $
+
+ 05 Feb 2015; Michael Sterrett <mr_bones_@gentoo.org>
+ -files/icebreaker-1.9.5-gentoo.patch, -files/icebreaker-1.9.5-ldflags.patch,
+ -files/icebreaker-1.9.5-parallell-install.patch, -icebreaker-1.9.5.ebuild:
+ old
28 Jan 2015; Agostino Sarubbo <ago@gentoo.org> icebreaker-1.9.6.ebuild:
Stable for ppc, wrt bug #535810
diff --git a/games-puzzle/icebreaker/files/icebreaker-1.9.5-gentoo.patch b/games-puzzle/icebreaker/files/icebreaker-1.9.5-gentoo.patch
deleted file mode 100644
index 97be35498e68..000000000000
--- a/games-puzzle/icebreaker/files/icebreaker-1.9.5-gentoo.patch
+++ /dev/null
@@ -1,251 +0,0 @@
-diff -ru icebreaker-1.9.5.orig/dialog.c icebreaker-1.9.5/dialog.c
---- icebreaker-1.9.5.orig/dialog.c 2002-05-26 16:13:00.000000000 -0400
-+++ icebreaker-1.9.5/dialog.c 2010-10-11 13:23:24.829480644 -0400
-@@ -384,12 +384,12 @@
-
- if (strlen(commandline.theme)>0)
- {
-- snprintf(originaltheme,MAXTHEMENAMELENGTH+1,"%s",commandline.theme);
-+ snprintf(originaltheme,sizeof(originaltheme),"%s",commandline.theme);
- originalthemecl=true;
- }
- else
- {
-- snprintf(originaltheme,MAXTHEMENAMELENGTH+1,"%s",options.theme);
-+ snprintf(originaltheme,sizeof(originaltheme),"%s",options.theme);
- originalthemecl=false;
- }
-
-@@ -662,7 +662,7 @@
- { // "random", at the end of the list
-
- strncpy(val,"random",MAXMENUVALUELENGTH);
-- snprintf(options.theme,MAXMENUVALUELENGTH,"random");
-+ strcpy(options.theme,"random");
-
- settheme("linux"); // just for pretty
-
-@@ -676,7 +676,7 @@
- else
- {
- strncpy(val,themelist[(t+1)%themecount],MAXMENUVALUELENGTH);
-- snprintf(options.theme,MAXMENUVALUELENGTH,themelist[(t+1)%themecount]);
-+ snprintf(options.theme,sizeof(options.theme),"%s",themelist[(t+1)%themecount]);
-
- settheme(options.theme);
-
-@@ -729,10 +729,10 @@
-
- for (i=0;i<HISCORENUM;i++)
- {
-- snprintf(buf,4,"%d.",i+1);
-+ snprintf(buf,sizeof(buf),"%d.",i+1);
- puttext(scorelistrect.x+BLOCKWIDTH,scorelistrect.y+45+i*(CHARHEIGHT*2+5),2,color.normaltext,buf);
- puttext(scorelistrect.x+BLOCKWIDTH*4,scorelistrect.y+45+i*(CHARHEIGHT*2+5),2,color.normaltext,hiscorename[i]);
-- snprintf(buf,30,"%ld",hiscoreval[i]);
-+ snprintf(buf,sizeof(buf),"%ld",hiscoreval[i]);
- puttext(scorelistrect.x+scorelistrect.w-(BLOCKWIDTH*5),scorelistrect.y+45+i*(CHARHEIGHT*2+5),2,color.normaltext,buf);
- }
-
-@@ -814,7 +814,7 @@
- {
- puttext(helprect.x+BLOCKWIDTH/2,helprect.y+BLOCKHEIGHT/2+i*(CHARHEIGHT*2+4),2,color.normaltext,helptext[i]);
- }
-- snprintf(buf,80,"v%d.%d.%d %s",VERMAJOR,VERMINOR,VERSUB,"Copyright (c) 2000-2002 Matthew Miller. Released under the GPL.");
-+ snprintf(buf,sizeof(buf),"v%d.%d.%d %s",VERMAJOR,VERMINOR,VERSUB,"Copyright (c) 2000-2002 Matthew Miller. Released under the GPL.");
- puttext(helprect.x+BLOCKWIDTH/2,helprect.y+helprect.h-CHARHEIGHT*3,1,color.copyrighttext,buf);
- puttext(helprect.x+BLOCKWIDTH/2,helprect.y+helprect.h-CHARHEIGHT*1-3,1,color.copyrighttext,"Thanks to my wonderful wife Karen for inspiration (and for patience)!");
-
-diff -ru icebreaker-1.9.5.orig/hiscore.c icebreaker-1.9.5/hiscore.c
---- icebreaker-1.9.5.orig/hiscore.c 2002-05-26 16:13:00.000000000 -0400
-+++ icebreaker-1.9.5/hiscore.c 2010-10-11 13:27:19.007140342 -0400
-@@ -72,7 +72,7 @@
- // make sure all entries are zeroed out to start.
- for (i=0;i<HISCORENUM;i++)
- {
-- snprintf(temphiscorename[i],7,"Nobody");
-+ strcpy(temphiscorename[i],"Nobody");
- temphiscoreval[i]=100; //100 is better than 0. :)
- }
-
-@@ -103,7 +103,7 @@
- // ok, so now, we can copy things over in the proper sorted order
- for (i=0;i<HISCORENUM;i++)
- {
-- snprintf(hiscorename[i],50,temphiscorename[arrayindex[i]]);
-+ snprintf(hiscorename[i],50,"%s",temphiscorename[arrayindex[i]]);
- hiscoreval[i]=temphiscoreval[arrayindex[i]];
- }
-
-@@ -201,13 +201,13 @@
- // make sure the temp array contains the right data
- for (i=0;i<HISCORENUM;i++)
- {
-- snprintf(temphiscorename[i],50,hiname[i]);
-+ snprintf(temphiscorename[i],50,"%s",hiname[i]);
- temphiscoreval[i]=hival[i];
- }
-
- // and toss in the new data
- //(this is why these arrays are size HISCORENUM+1)
-- snprintf(temphiscorename[HISCORENUM],50,username);
-+ snprintf(temphiscorename[HISCORENUM],50,"%s",username);
- temphiscoreval[HISCORENUM]=score;
-
- // fill the "helper" array.
-@@ -221,7 +221,7 @@
- // and take the top ones back.
- for (i=0;i<HISCORENUM;i++)
- {
-- snprintf(hiname[i],50,temphiscorename[arrayindex[i]]);
-+ snprintf(hiname[i],50,"%s",temphiscorename[arrayindex[i]]);
- hival[i]=temphiscoreval[arrayindex[i]];
- }
- }
-diff -ru icebreaker-1.9.5.orig/line.c icebreaker-1.9.5/line.c
---- icebreaker-1.9.5.orig/line.c 2002-05-25 14:15:22.000000000 -0400
-+++ icebreaker-1.9.5/line.c 2010-10-11 13:25:03.833197122 -0400
-@@ -30,8 +30,9 @@
-
- Line createline(int linenum)
- {
-- Line l;
-+ static Line l;
-
-+ memset(&l, 0, sizeof(l));
- switch (linenum)
- {
- case 1:
-diff -ru icebreaker-1.9.5.orig/options.c icebreaker-1.9.5/options.c
---- icebreaker-1.9.5.orig/options.c 2002-05-23 00:52:35.000000000 -0400
-+++ icebreaker-1.9.5/options.c 2010-10-11 13:21:51.247600060 -0400
-@@ -66,7 +66,7 @@
- options.autopause=AUTOPAUSEOFF;
- options.difficulty=NORMAL;
- options.fullscreen=FULLSCREENOFF;
-- snprintf(options.theme,MAXTHEMENAMELENGTH+1,"linux");
-+ strcpy(options.theme,"linux");
- }
-
- int readoptions(void)
-@@ -81,7 +81,7 @@
-
- setdefaultoptions();
-
-- snprintf(filename,255,"%s/%s",homedir,OPTIONFILE);
-+ snprintf(filename,sizeof(filename),"%s/%s",homedir,OPTIONFILE);
-
- optionfile=fopen(filename,"r");
- if (optionfile==NULL)
-@@ -135,7 +135,7 @@
- }
- else if (!strcmp(optbuf,"theme"))
- {
-- snprintf(options.theme,MAXTHEMENAMELENGTH+1,"%s",valbuf);
-+ snprintf(options.theme,sizeof(options.theme),"%s",valbuf);
- }
- // FIX: add username
- }
-@@ -150,7 +150,7 @@
- {
- FILE * optionfile;
- char filename[255];
-- snprintf(filename,255,"%s/%s",homedir,OPTIONFILE);
-+ snprintf(filename,sizeof(filename),"%s/%s",homedir,OPTIONFILE);
-
- optionfile=fopen(filename,"w");
- if (optionfile==NULL)
-@@ -292,7 +292,7 @@
- else
- {
- // fix -- we should probably search for malicious characters here.
-- snprintf(commandline.theme,MAXTHEMENAMELENGTH+1,"%s",argv[i]+strlen(FLAGTHEME));
-+ snprintf(commandline.theme,sizeof(commandline.theme),"%s",argv[i]+strlen(FLAGTHEME));
- }
- }
- else if (strncmp(argv[i],FLAGTHEMELONG "=" ,strlen(FLAGTHEMELONG "=")) == 0)
-@@ -312,7 +312,7 @@
- else
- {
- // fix -- we should probably search for malicious characters here.
-- snprintf(commandline.theme,MAXTHEMENAMELENGTH+1,"%s",argv[i]+strlen(FLAGTHEMELONG "="));
-+ snprintf(commandline.theme,sizeof(commandline.theme),"%s",argv[i]+strlen(FLAGTHEMELONG "="));
- }
- }
- else if (strncmp(argv[i],FLAGTHEMELONG,strlen(FLAGTHEMELONG)) == 0)
-diff -ru icebreaker-1.9.5.orig/penguin.c icebreaker-1.9.5/penguin.c
---- icebreaker-1.9.5.orig/penguin.c 2002-05-26 16:13:00.000000000 -0400
-+++ icebreaker-1.9.5/penguin.c 2010-10-11 13:26:03.789308697 -0400
-@@ -40,8 +40,9 @@
-
- Penguin createpenguinxy(int x, int y)
- {
-- Penguin p;
-+ static Penguin p;
-
-+ memset(&p, 0, sizeof(p));
- switch (random() % 4)
- {
- case 0:
-diff -ru icebreaker-1.9.5.orig/themes.c icebreaker-1.9.5/themes.c
---- icebreaker-1.9.5.orig/themes.c 2002-05-26 16:13:00.000000000 -0400
-+++ icebreaker-1.9.5/themes.c 2010-10-11 13:17:41.360331223 -0400
-@@ -183,7 +183,7 @@
-
- foundcolor.spritetransparent = 0;
-
-- snprintf(themefilename, 256,"%s/%s%s",DATAPREFIX,themename,THEMEFILEEXTENSION);
-+ snprintf(themefilename, sizeof(themefilename),"%s/%s%s",DATAPREFIX,themename,THEMEFILEEXTENSION);
-
- themefile=fopen(themefilename,"r");
- if (themefile==NULL)
-@@ -329,7 +329,7 @@
- "We'll try to load it anyway, but don't be surpised if there's a problem.\n"
- "(Filename is %s)\n",themename,valbuf);
- }
-- snprintf(loadfilebuf, 256,"%s/%s",DATAPREFIX,valbuf);
-+ snprintf(loadfilebuf, sizeof(loadfilebuf),"%s/%s",DATAPREFIX,valbuf);
- spriteimage=loadsprite(themename,loadfilebuf);
- }
- else if (!strcmp(optbuf,"spritemirrorbitmap"))
-@@ -340,7 +340,7 @@
- "We'll try to load it anyway, but don't be surpised if there's a problem.\n"
- "(Filename is %s)\n",themename,valbuf);
- }
-- snprintf(loadfilebuf, 256,"%s/%s",DATAPREFIX,valbuf);
-+ snprintf(loadfilebuf, sizeof(loadfilebuf),"%s/%s",DATAPREFIX,valbuf);
- spritemirrorimage=loadsprite(themename,loadfilebuf);
- }
- else if (!strcmp(optbuf,"soundouch"))
-@@ -351,7 +351,7 @@
- "We'll try to load it anyway, but don't be surpised if there's a problem.\n"
- "(Filename is %s)\n",themename,valbuf);
- }
-- snprintf(loadfilebuf, 256,"%s/%s",DATAPREFIX,valbuf);
-+ snprintf(loadfilebuf, sizeof(loadfilebuf),"%s/%s",DATAPREFIX,valbuf);
- loadsounds(themename,loadfilebuf,NULL);
- }
- else if (!strcmp(optbuf,"soundcrash"))
-@@ -362,7 +362,7 @@
- "We'll try to load it anyway, but don't be surpised if there's a problem.\n"
- "(Filename is %s)\n",themename,valbuf);
- }
-- snprintf(loadfilebuf, 256,"%s/%s",DATAPREFIX,valbuf);
-+ snprintf(loadfilebuf, sizeof(loadfilebuf),"%s/%s",DATAPREFIX,valbuf);
- loadsounds(themename,NULL,loadfilebuf);
- }
- }
-@@ -474,11 +474,11 @@
- {
- fprintf(stderr,"Hey! You can't have a theme named random! Please remove the random.ibt\n"
- "file from your themes directory.\n");
-- snprintf(themename,MAXTHEMENAMELENGTH+1,"linux");
-+ strcpy(themename,"linux");
- }
- else
- {
-- snprintf(themename,MAXTHEMENAMELENGTH+1,themelist[random() %themecount]);
-+ snprintf(themename,sizeof(themename),"%s",themelist[random() %themecount]);
- }
- freethemenames(&themelist,themecount);
- return settheme(themename);
diff --git a/games-puzzle/icebreaker/files/icebreaker-1.9.5-ldflags.patch b/games-puzzle/icebreaker/files/icebreaker-1.9.5-ldflags.patch
deleted file mode 100644
index 44ef9bdf8631..000000000000
--- a/games-puzzle/icebreaker/files/icebreaker-1.9.5-ldflags.patch
+++ /dev/null
@@ -1,28 +0,0 @@
---- Makefile.orig 2010-10-11 12:20:01.274684641 -0400
-+++ Makefile 2010-10-11 12:22:02.256897083 -0400
-@@ -1,5 +1,3 @@
--CC=gcc
--
- SDLCONFIG=sdl-config
-
- ifndef prefix
-@@ -177,7 +175,7 @@
- [ -d win32.build ] && rm -rf win32.build || true
-
- icebreaker: $(SRC:.c=.o)
-- $(CC) $(CFLAGS) $^ -o icebreaker $(SDL_LIB)
-+ $(CC) $(LDFLAGS) $(CFLAGS) $^ -o icebreaker $(SDL_LIB)
-
- man: icebreaker.6
-
-@@ -202,8 +200,8 @@
- install -m 644 *.wav *.bmp $(datadir)/icebreaker
-
- install-bin: icebreaker
-- install -s -g games -m 2755 icebreaker $(bindir) || \
-- install -s -m 755 icebreaker $(bindir)
-+ install -g games -m 2755 icebreaker $(bindir) || \
-+ install -m 755 icebreaker $(bindir)
- @test -g $(bindir)/icebreaker || \
- echo -e '*** Note: icebreaker binary not installed set-group-ID "games" -- shared\n*** highscores may be impossible. (Try installing as root.)'
-
diff --git a/games-puzzle/icebreaker/files/icebreaker-1.9.5-parallell-install.patch b/games-puzzle/icebreaker/files/icebreaker-1.9.5-parallell-install.patch
deleted file mode 100644
index de388d9b5758..000000000000
--- a/games-puzzle/icebreaker/files/icebreaker-1.9.5-parallell-install.patch
+++ /dev/null
@@ -1,34 +0,0 @@
---- Makefile.old 2010-10-19 10:26:18.000000000 +0200
-+++ Makefile 2010-10-19 10:38:28.000000000 +0200
-@@ -196,26 +196,30 @@
- themes-install: install-themes
-
- install-themes:
-+ mkdir -p $(datadir)/icebreaker
- install -m 644 *.ibt $(datadir)/icebreaker
- install -m 644 *.wav *.bmp $(datadir)/icebreaker
-
- install-bin: icebreaker
-+ mkdir -p $(bindir)
- install -g games -m 2755 icebreaker $(bindir) || \
- install -m 755 icebreaker $(bindir)
- @test -g $(bindir)/icebreaker || \
- echo -e '*** Note: icebreaker binary not installed set-group-ID "games" -- shared\n*** highscores may be impossible. (Try installing as root.)'
-
- install-man: icebreaker.6
-+ mkdir -p $(mandir)/man6
- install -m 644 icebreaker.6 $(mandir)/man6
-
- install-scorefile:
-+ mkdir -p $(highscoredir)
- touch $(highscoredir)/icebreaker.scores
- chown -f games:games $(highscoredir)/icebreaker.scores && \
- chmod 664 $(highscoredir)/icebreaker.scores || \
- chmod 644 $(highscoredir)/icebreaker.scores
-
-
--install: all install-mkdirs install-themes install-bin install-man install-scorefile
-+install: install-themes install-bin install-man install-scorefile
-
- %.d: %.c
- set -e; $(CC) -M $(CFLAGS) $< \
diff --git a/games-puzzle/icebreaker/icebreaker-1.9.5.ebuild b/games-puzzle/icebreaker/icebreaker-1.9.5.ebuild
deleted file mode 100644
index 65d2d3ad3c8e..000000000000
--- a/games-puzzle/icebreaker/icebreaker-1.9.5.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/icebreaker/icebreaker-1.9.5.ebuild,v 1.17 2010/10/19 15:14:32 mr_bones_ Exp $
-
-EAPI=2
-inherit eutils games
-
-DESCRIPTION="Trap and capture penguins on Antarctica"
-HOMEPAGE="http://www.mattdm.org/icebreaker/"
-SRC_URI="http://www.mattdm.org/${PN}/1.9.x/${P}.tgz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND="media-libs/libsdl[video]
- media-libs/sdl-mixer"
-
-PATCHES=( "${FILESDIR}"/${P}-ldflags.patch
- "${FILESDIR}"/${P}-gentoo.patch
- "${FILESDIR}"/${P}-parallell-install.patch )
-
-src_compile() {
- emake \
- OPTIMIZE="${CFLAGS}" \
- prefix=/usr \
- bindir="${GAMES_BINDIR}" \
- datadir="${GAMES_DATADIR}" \
- highscoredir="${GAMES_STATEDIR}" \
- || die "emake failed"
-}
-
-src_install() {
- emake \
- prefix="${D}/usr" \
- bindir="${D}${GAMES_BINDIR}" \
- datadir="${D}${GAMES_DATADIR}" \
- highscoredir="${D}${GAMES_STATEDIR}" install || die
- newicon ${PN}_48.bmp ${PN}.bmp
- make_desktop_entry ${PN} IceBreaker /usr/share/pixmaps/${PN}.bmp
- dodoc ChangeLog README* TODO
- prepgamesdirs
-}