summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-07-07 21:07:23 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-07-07 21:07:23 +0000
commit634dd905533b385fcf741f94d8a28d5d947de8a7 (patch)
tree321f55bca6f2f9b6695b4fbf584e6c3358890d2b /games-puzzle
parentamd64/x86 stable, bug #225851 (diff)
downloadgentoo-2-634dd905533b385fcf741f94d8a28d5d947de8a7.tar.gz
gentoo-2-634dd905533b385fcf741f94d8a28d5d947de8a7.tar.bz2
gentoo-2-634dd905533b385fcf741f94d8a28d5d947de8a7.zip
old
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/tint/files/0.03a-warnings.patch31
-rw-r--r--games-puzzle/tint/tint-0.03a.ebuild42
2 files changed, 0 insertions, 73 deletions
diff --git a/games-puzzle/tint/files/0.03a-warnings.patch b/games-puzzle/tint/files/0.03a-warnings.patch
deleted file mode 100644
index 5dc1cfa7aa39..000000000000
--- a/games-puzzle/tint/files/0.03a-warnings.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- tint.c.orig 2004-09-24 19:28:16.000000000 -0700
-+++ tint.c 2004-09-24 19:28:27.000000000 -0700
-@@ -651,7 +651,7 @@
- shapecount[engine.curshape]++;
- break;
- /* shape moved down one line */
-- case 1:
-+ case 1:;
- }
- }
- }
---- engine.c.orig 2004-09-24 19:26:04.000000000 -0700
-+++ engine.c 2004-09-24 19:28:01.000000000 -0700
-@@ -27,6 +27,8 @@
- * OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- */
-
-+#include <stdlib.h>
-+#include <string.h>
- #include "typedefs.h"
- #include "utils.h"
- #include "io.h"
-@@ -94,7 +96,7 @@
- case 5:
- real_rotate (shape,FALSE);
- break;
-- case 3: /* This one is not rotated at all */
-+ case 3:; /* This one is not rotated at all */
- }
- }
-
diff --git a/games-puzzle/tint/tint-0.03a.ebuild b/games-puzzle/tint/tint-0.03a.ebuild
deleted file mode 100644
index 36a72181cfa4..000000000000
--- a/games-puzzle/tint/tint-0.03a.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/tint/tint-0.03a.ebuild,v 1.9 2006/08/15 15:00:11 tcort Exp $
-
-inherit eutils games
-
-MY_P=${P/-/_}
-DESCRIPTION="Tint Is Not Tetris, a ncurses based clone of the original Tetris(tm) game"
-HOMEPAGE="http://oasis.frogfoot.net/code/tint/"
-SRC_URI="http://oasis.frogfoot.net/code/tint/download/${PV}/${MY_P}.tar.gz"
-
-LICENSE="as-is"
-SLOT="0"
-KEYWORDS="amd64 ppc ppc64 x86 ~x86-fbsd"
-IUSE=""
-
-DEPEND=">=sys-libs/ncurses-5.4-r1"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}/${PV}-warnings.patch"
- sed -i '/STRIP/d' Makefile || die "sed failed"
-}
-
-src_compile() {
- emake \
- CFLAGS="${CFLAGS}" \
- LDFLAGS="${LDFLAGS}" \
- localstatedir="${GAMES_STATEDIR}" \
- || die "emake failed"
-}
-
-src_install() {
- dogamesbin tint || die "dogamesbin failed"
- doman tint.6
- dodoc CREDITS NOTES
- insopts -m 0664
- insinto "${GAMES_STATEDIR}"
- doins tint.scores || die "doins failed"
- prepgamesdirs
-}