summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-02-08 18:27:21 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-02-08 18:27:21 +0000
commitd54246a2644764edbf329b3e6c4845019a346a3c (patch)
tree2c3c3fdec279b2850118ae216a0489be397f2492 /games-puzzle
parentFixed unquoted variables, bug #258164, thank Markus Meier for report. (diff)
downloadgentoo-2-d54246a2644764edbf329b3e6c4845019a346a3c.tar.gz
gentoo-2-d54246a2644764edbf329b3e6c4845019a346a3c.tar.bz2
gentoo-2-d54246a2644764edbf329b3e6c4845019a346a3c.zip
Fix --as-needed bug #247418
(Portage version: 2.1.6.4/cvs/Linux 2.6.26-gentoo-r3 i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/bastet/ChangeLog8
-rw-r--r--games-puzzle/bastet/bastet-0.41.ebuild13
-rw-r--r--games-puzzle/bastet/files/bastet-0.41-as-needed.patch19
3 files changed, 31 insertions, 9 deletions
diff --git a/games-puzzle/bastet/ChangeLog b/games-puzzle/bastet/ChangeLog
index f8b91bfb3041..895587b1a50c 100644
--- a/games-puzzle/bastet/ChangeLog
+++ b/games-puzzle/bastet/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/bastet
-# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/bastet/ChangeLog,v 1.8 2006/10/19 15:20:40 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/bastet/ChangeLog,v 1.9 2009/02/08 18:27:16 tupone Exp $
+
+ 08 Feb 2009; Tupone Alfredo <tupone@gentoo.org>
+ +files/bastet-0.41-as-needed.patch, bastet-0.41.ebuild:
+ Fix --as-needed bug #247418 by flameeyes@gentoo.org
19 Oct 2006; Tristan Heaven <nyhm@gentoo.org> bastet-0.41.ebuild:
Use LDFLAGS and install the man page
diff --git a/games-puzzle/bastet/bastet-0.41.ebuild b/games-puzzle/bastet/bastet-0.41.ebuild
index 0f14be079fa9..4cc0b1500223 100644
--- a/games-puzzle/bastet/bastet-0.41.ebuild
+++ b/games-puzzle/bastet/bastet-0.41.ebuild
@@ -1,8 +1,9 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/bastet/bastet-0.41.ebuild,v 1.8 2006/10/19 15:20:40 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/bastet/bastet-0.41.ebuild,v 1.9 2009/02/08 18:27:16 tupone Exp $
-inherit toolchain-funcs games
+EAPI=2
+inherit toolchain-funcs eutils games
DESCRIPTION="a simple, evil, ncurses-based Tetris(R) clone"
HOMEPAGE="http://fph.altervista.org/prog/bastet.shtml"
@@ -15,17 +16,15 @@ IUSE=""
DEPEND=">=sys-libs/ncurses-5"
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e '/^include/s/^/-/' \
-e "/^CC/s/gcc/$(tc-getCC)/" \
-e "/^DATA_PREFIX/s:=.*:=${GAMES_STATEDIR}/:" \
-e '/^CFLAGS/s/=/+=/' \
- -e '/^LDFLAGS/s/=/+=/' \
Makefile \
|| die "sed failed"
+ epatch "${FILESDIR}"/${P}-as-needed.patch
sed -i \
-e 's/ch;/ch = 0;/' \
diff --git a/games-puzzle/bastet/files/bastet-0.41-as-needed.patch b/games-puzzle/bastet/files/bastet-0.41-as-needed.patch
new file mode 100644
index 000000000000..efb1efc01809
--- /dev/null
+++ b/games-puzzle/bastet/files/bastet-0.41-as-needed.patch
@@ -0,0 +1,19 @@
+--- Makefile.old 2009-02-08 19:19:20.000000000 +0100
++++ Makefile 2009-02-08 19:19:48.000000000 +0100
+@@ -12,14 +12,14 @@
+
+ CC=i686-pc-linux-gnu-gcc
+ CFLAGS+=-Wall -DHIGHSCORE_FILE=\"$(DATA_PREFIX)$(HISCORE)\"
+-LDFLAGS=-lncurses
++LDLIBS+=-lncurses
+ SOURCES=main.c game.c highscore.c bast.c
+ EXNAME=bastet
+
+ all: $(EXNAME)
+
+ $(EXNAME) : $(SOURCES:.c=.o)
+- $(CC) $(LDFLAGS) -o $(EXNAME) $(SOURCES:.c=.o)
++ $(CC) $(LDFLAGS) -o $(EXNAME) $(SOURCES:.c=.o) $(LDLIBS)
+
+ %.d: %.c
+ set -e; $(CC) -MM $(CFLAGS) $< \