summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2011-08-31 15:43:17 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2011-08-31 15:43:17 +0000
commitf446f3e2e73f0d113b89fd0078ea2333d30e0a49 (patch)
treebf3683febd71b661e3991e10d14f193e1cb4512c /games-puzzle
parentInitial import of mod_auth_token; ebuild by Pavel Stratil (proxied maintainer... (diff)
downloadgentoo-2-f446f3e2e73f0d113b89fd0078ea2333d30e0a49.tar.gz
gentoo-2-f446f3e2e73f0d113b89fd0078ea2333d30e0a49.tar.bz2
gentoo-2-f446f3e2e73f0d113b89fd0078ea2333d30e0a49.zip
version bump
(Portage version: 2.1.10.11/cvs/Linux i686)
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/ltris/ChangeLog8
-rw-r--r--games-puzzle/ltris/files/ltris-1.0.17-gentoo.patch51
-rw-r--r--games-puzzle/ltris/ltris-1.0.17.ebuild40
3 files changed, 98 insertions, 1 deletions
diff --git a/games-puzzle/ltris/ChangeLog b/games-puzzle/ltris/ChangeLog
index b16700145946..3ca22fe7d03e 100644
--- a/games-puzzle/ltris/ChangeLog
+++ b/games-puzzle/ltris/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-puzzle/ltris
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ChangeLog,v 1.43 2011/06/24 18:47:19 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ChangeLog,v 1.44 2011/08/31 15:43:17 mr_bones_ Exp $
+
+*ltris-1.0.17 (31 Aug 2011)
+
+ 31 Aug 2011; Michael Sterrett <mr_bones_@gentoo.org> +ltris-1.0.17.ebuild,
+ +files/ltris-1.0.17-gentoo.patch:
+ version bump
24 Jun 2011; Brent Baude <ranger@gentoo.org> ltris-1.0.16.ebuild:
Marking ltris-1.0.16 ppc for bug 362221
diff --git a/games-puzzle/ltris/files/ltris-1.0.17-gentoo.patch b/games-puzzle/ltris/files/ltris-1.0.17-gentoo.patch
new file mode 100644
index 000000000000..82acee7d33bc
--- /dev/null
+++ b/games-puzzle/ltris/files/ltris-1.0.17-gentoo.patch
@@ -0,0 +1,51 @@
+diff -ru ltris-1.0.15.orig/Makefile.am ltris-1.0.15/Makefile.am
+--- ltris-1.0.15.orig/Makefile.am 2010-09-20 13:26:05.000000000 -0400
++++ ltris-1.0.15/Makefile.am 2010-09-21 02:01:52.680858712 -0400
+@@ -1,21 +1,9 @@
+-SUBDIRS = intl m4 po src icons
++SUBDIRS = intl m4 po src
+
+ EXTRA_DIST = config.rpath AUTHORS COPYING ChangeLog INSTALL \
+ README TODO touchall ABOUT-NLS po/tr.po_full po/pt.po_full \
+-po/nonascii.pl ltris32.gif ltris48.gif ltris.desktop.in
+-
+-desktopdir = $(datadir)/applications
+-desktop_DATA = ltris.desktop
+-icondir = $(datadir)/icons
+-icon_DATA = ltris48.gif
++po/nonascii.pl
+
+ AUTOMAKE_OPTIONS = foreign
+
+-# We can't use static desktop file because of icon location. Is this
+-# the right way to handle it? At least it works... as long as $datadir
+-# does not contain plus signs. :-)
+-ltris.desktop:
+- @sed -e "s+Icon=+Icon=$(datadir)/icons/ltris48.gif+" \
+- < ltris.desktop.in > ltris.desktop
+-
+ ACLOCAL_AMFLAGS = -I m4
+diff -ru ltris-1.0.15.orig/configure.in ltris-1.0.15/configure.in
+--- ltris-1.0.15.orig/configure.in 2010-09-20 13:23:17.000000000 -0400
++++ ltris-1.0.15/configure.in 2010-09-21 02:02:22.418843746 -0400
+@@ -55,7 +55,7 @@
+ AC_SUBST(buf_flag)
+
+ dnl set localedir
+-localedir=$datadir/locale
++localedir=/usr/share/locale
+ locdir_flag="-DLOCALEDIR=\\\"$localedir\\\""
+
+ dnl installation path
+diff -ru ltris-1.0.15.orig/po/Makefile.in.in ltris-1.0.15/po/Makefile.in.in
+--- ltris-1.0.15.orig/po/Makefile.in.in 2005-10-04 14:41:03.000000000 -0400
++++ ltris-1.0.15/po/Makefile.in.in 2010-09-21 02:02:40.464207966 -0400
+@@ -23,7 +23,7 @@
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = /usr/share/locale
+ gettextsrcdir = $(datadir)/gettext/po
+
+ INSTALL = @INSTALL@
diff --git a/games-puzzle/ltris/ltris-1.0.17.ebuild b/games-puzzle/ltris/ltris-1.0.17.ebuild
new file mode 100644
index 000000000000..f7b53920b16b
--- /dev/null
+++ b/games-puzzle/ltris/ltris-1.0.17.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/ltris/ltris-1.0.17.ebuild,v 1.1 2011/08/31 15:43:17 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="very polished Tetris clone"
+HOMEPAGE="http://lgames.sourceforge.net/"
+SRC_URI="mirror://sourceforge/lgames/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="nls"
+
+RDEPEND="media-libs/libsdl[video]
+ media-libs/sdl-mixer
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ nls? ( sys-devel/gettext )"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ AT_M4DIR=m4 eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable nls)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO
+ newicon icons/ltris48.xpm ${PN}.xpm
+ make_desktop_entry ltris LTris
+ prepgamesdirs
+}