summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-07-31 05:32:11 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-07-31 05:32:11 +0000
commit264fa9ba8f4c73e32bb3f868f81ba284fe1b4d4b (patch)
tree352362972f2ecde067ef2f6877f0c109cb7af33c /games-roguelike/scourge
parentStable on x86. (diff)
downloadgentoo-2-264fa9ba8f4c73e32bb3f868f81ba284fe1b4d4b.tar.gz
gentoo-2-264fa9ba8f4c73e32bb3f868f81ba284fe1b4d4b.tar.bz2
gentoo-2-264fa9ba8f4c73e32bb3f868f81ba284fe1b4d4b.zip
version bump; fix bug #100192
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-roguelike/scourge')
-rw-r--r--games-roguelike/scourge/ChangeLog8
-rw-r--r--games-roguelike/scourge/files/0.10.1-datadir.patch14
-rw-r--r--games-roguelike/scourge/files/digest-scourge-0.10.11
-rw-r--r--games-roguelike/scourge/scourge-0.10.1.ebuild47
4 files changed, 69 insertions, 1 deletions
diff --git a/games-roguelike/scourge/ChangeLog b/games-roguelike/scourge/ChangeLog
index ae826eef0570..71f5da0b3083 100644
--- a/games-roguelike/scourge/ChangeLog
+++ b/games-roguelike/scourge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-roguelike/scourge
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.11 2005/06/23 00:20:40 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.12 2005/07/31 05:32:11 mr_bones_ Exp $
+
+*scourge-0.10.1 (31 Jul 2005)
+
+ 31 Jul 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/0.10.1-datadir.patch, +scourge-0.10.1.ebuild:
+ version bump; fix bug #100192
23 Jun 2005; Michael Sterrett <mr_bones_@gentoo.org>
+files/0.10-64bit.patch, scourge-0.10.ebuild:
diff --git a/games-roguelike/scourge/files/0.10.1-datadir.patch b/games-roguelike/scourge/files/0.10.1-datadir.patch
new file mode 100644
index 000000000000..ca300011bcff
--- /dev/null
+++ b/games-roguelike/scourge/files/0.10.1-datadir.patch
@@ -0,0 +1,14 @@
+--- src/main.cpp.orig 2005-06-09 01:13:49.000000000 -0400
++++ src/main.cpp 2005-07-30 22:44:03.000000000 -0400
+@@ -82,7 +82,11 @@
+ rootDir = (char*)malloc( 300 * sizeof( char ) );
+ strcpy( rootDir, "data" );
+ #else
++#ifdef ENABLE_BINRELOC
+ rootDir = (char*)BR_DATADIR( "/data" );
++#else
++ rootDir = DATA_DIR;
++#endif
+ #endif
+ cerr << "rootDir=" << rootDir << endl;
+
diff --git a/games-roguelike/scourge/files/digest-scourge-0.10.1 b/games-roguelike/scourge/files/digest-scourge-0.10.1
new file mode 100644
index 000000000000..899458e3bdec
--- /dev/null
+++ b/games-roguelike/scourge/files/digest-scourge-0.10.1
@@ -0,0 +1 @@
+MD5 d19ef1ce0d8cfc852c3561c3375d0504 scourge-0.10.1.tar.gz 23268675
diff --git a/games-roguelike/scourge/scourge-0.10.1.ebuild b/games-roguelike/scourge/scourge-0.10.1.ebuild
new file mode 100644
index 000000000000..8301f036b5c0
--- /dev/null
+++ b/games-roguelike/scourge/scourge-0.10.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.10.1.ebuild,v 1.1 2005/07/31 05:32:11 mr_bones_ Exp $
+
+inherit flag-o-matic eutils games
+
+DESCRIPTION="A rogue-like adventure game to eliminate pests"
+HOMEPAGE="http://scourge.sf.net"
+SRC_URI="mirror://sourceforge/scourge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="virtual/x11
+ virtual/glu
+ virtual/opengl
+ >=media-libs/freetype-2
+ >=media-libs/libsdl-1.2
+ media-libs/sdl-net
+ media-libs/sdl-mixer"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ find "${S}/data" -type f -exec chmod a-x \{\} \;
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-datadir.patch"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-binreloc \
+ --with-data-dir="${GAMES_DATADIR}/${PN}/data" \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/scourge || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}"
+ cp -r data/ "${D}${GAMES_DATADIR}/${PN}" || die "cp failed"
+ dodoc AUTHORS README || die "dodoc failed"
+ prepgamesdirs
+}