summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2006-06-01 21:24:45 +0000
committerAlfredo Tupone <tupone@gentoo.org>2006-06-01 21:24:45 +0000
commitd0b2062f1203c352631d82c21f85d625fcac8fa1 (patch)
treecb25a92118fb60e368c2e2802075c928e4a1dd51 /games-roguelike/scourge
parentFixed Makefile to work properly with --as-needed. Closes bug #135152. Remov... (diff)
downloadgentoo-2-d0b2062f1203c352631d82c21f85d625fcac8fa1.tar.gz
gentoo-2-d0b2062f1203c352631d82c21f85d625fcac8fa1.tar.bz2
gentoo-2-d0b2062f1203c352631d82c21f85d625fcac8fa1.zip
Version bump, bug #126279
(Portage version: 2.1_rc3-r1)
Diffstat (limited to 'games-roguelike/scourge')
-rw-r--r--games-roguelike/scourge/ChangeLog8
-rw-r--r--games-roguelike/scourge/files/digest-scourge-0.133
-rw-r--r--games-roguelike/scourge/files/scourge-0.13-gcc41.patch85
-rw-r--r--games-roguelike/scourge/scourge-0.13.ebuild53
4 files changed, 148 insertions, 1 deletions
diff --git a/games-roguelike/scourge/ChangeLog b/games-roguelike/scourge/ChangeLog
index ba0dc8c8f257..c391c940d506 100644
--- a/games-roguelike/scourge/ChangeLog
+++ b/games-roguelike/scourge/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-roguelike/scourge
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.17 2006/05/21 21:07:05 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/ChangeLog,v 1.18 2006/06/01 21:24:45 tupone Exp $
+
+*scourge-0.13 (01 Jun 2006)
+
+ 01 Jun 2006; <Tupone@gentoo.org> +files/scourge-0.13-gcc41.patch,
+ +scourge-0.13.ebuild:
+ Version bump, bug #126279 by Cristiano Chiucchiolo
21 May 2006; <Tupone@gentoo.org> +files/scourge-0.12-gcc41.patch,
scourge-0.12.ebuild:
diff --git a/games-roguelike/scourge/files/digest-scourge-0.13 b/games-roguelike/scourge/files/digest-scourge-0.13
new file mode 100644
index 000000000000..1ec13de46006
--- /dev/null
+++ b/games-roguelike/scourge/files/digest-scourge-0.13
@@ -0,0 +1,3 @@
+MD5 6df6b493186f22eb6f315e8893c355b7 scourge-0.13.tar.gz 46504845
+RMD160 c8d3c32ba109a62273d64bf0884a1ca65583e4f6 scourge-0.13.tar.gz 46504845
+SHA256 b0d69b2d606712d00b2c34f7920beff73123b6635937230e0e10697d79edab92 scourge-0.13.tar.gz 46504845
diff --git a/games-roguelike/scourge/files/scourge-0.13-gcc41.patch b/games-roguelike/scourge/files/scourge-0.13-gcc41.patch
new file mode 100644
index 000000000000..ac536cb97181
--- /dev/null
+++ b/games-roguelike/scourge/files/scourge-0.13-gcc41.patch
@@ -0,0 +1,85 @@
+--- src/minimap.h.old 2006-06-01 22:56:42.000000000 +0200
++++ src/minimap.h 2006-06-01 22:56:54.000000000 +0200
+@@ -59,8 +59,8 @@
+ bool directMode;
+
+ public:
+- MiniMap::MiniMap();
+- MiniMap::~MiniMap();
++ MiniMap();
++ ~MiniMap();
+ MiniMap( Scourge *scourge, bool directMode = false );
+
+ void reset();
+--- src/preferences.h.old 2006-06-01 22:56:04.000000000 +0200
++++ src/preferences.h 2006-06-01 22:56:20.000000000 +0200
+@@ -113,10 +113,10 @@
+ TEST
+ };
+
+- Preferences::Preferences() {
++ Preferences() {
+ stencilBufInitialized = false;
+ }
+- virtual Preferences::~Preferences() {}
++ virtual ~Preferences() {}
+
+ // engine variables
+ virtual bool getFullscreen() = 0;
+--- src/userconfiguration.h.old 2006-06-01 22:57:08.000000000 +0200
++++ src/userconfiguration.h 2006-06-01 22:57:20.000000000 +0200
+@@ -100,8 +100,8 @@
+
+ public:
+
+- UserConfiguration::UserConfiguration();
+- UserConfiguration::~UserConfiguration();
++ UserConfiguration();
++ ~UserConfiguration();
+
+ const char * getEngineActionDescription(int i);
+ const char * getEngineActionKeyName(int i);
+--- src/render/glcaveshape.h.old 2006-06-01 23:04:35.000000000 +0200
++++ src/render/glcaveshape.h 2006-06-01 23:04:48.000000000 +0200
+@@ -94,7 +94,7 @@
+
+ static char *names[];
+
+- static GLCaveShape *GLCaveShape::shapeList[];
++ static GLCaveShape *shapeList[];
+
+ static std::vector<CVector3*> points;
+ static std::vector<std::vector<CaveFace*>*> polys;
+--- src/render/map.h.old 2006-06-01 23:03:49.000000000 +0200
++++ src/render/map.h 2006-06-01 23:04:19.000000000 +0200
+@@ -368,10 +368,10 @@
+ Shape *removePosition(Sint16 x, Sint16 y, Sint16 z);
+ Shape *removeLocation(Sint16 x, Sint16 y, Sint16 z);
+
+- void Map::setItem(Sint16 x, Sint16 y, Sint16 z, RenderedItem *item);
++ void setItem(Sint16 x, Sint16 y, Sint16 z, RenderedItem *item);
+ RenderedItem *removeItem(Sint16 x, Sint16 y, Sint16 z);
+
+- void Map::setCreature(Sint16 x, Sint16 y, Sint16 z, RenderedCreature *creature);
++ void setCreature(Sint16 x, Sint16 y, Sint16 z, RenderedCreature *creature);
+ RenderedCreature *removeCreature(Sint16 x, Sint16 y, Sint16 z);
+
+ /**
+@@ -426,7 +426,7 @@
+ // like shapefits, but returns the blocking location or, NULL if there's nothing there
+ Location *getBlockingLocation(Shape *shape, int x, int y, int z);
+
+- Location *Map::getDropLocation(Shape *shape, int x, int y, int z);
++ Location *getDropLocation(Shape *shape, int x, int y, int z);
+
+ inline void updateLightMap() { lightMapChanged = resortShapes = true; }
+
+@@ -455,7 +455,7 @@
+ DrawLater *later=NULL);
+
+ bool isDoor(int x, int y);
+- bool Map::isDoor(Shape *shape);
++ bool isDoor(Shape *shape);
+
+ // ====================================================================
+ // Locked doors/chests code
diff --git a/games-roguelike/scourge/scourge-0.13.ebuild b/games-roguelike/scourge/scourge-0.13.ebuild
new file mode 100644
index 000000000000..7b8bdfbc49cc
--- /dev/null
+++ b/games-roguelike/scourge/scourge-0.13.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-roguelike/scourge/scourge-0.13.ebuild,v 1.1 2006/06/01 21:24:45 tupone Exp $
+
+inherit eutils games
+
+DESCRIPTION="A rogue-like adventure game to eliminate pests"
+HOMEPAGE="http://scourge.sf.net"
+SRC_URI="mirror://sourceforge/scourge/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="|| (
+ (
+ x11-libs/libXmu
+ x11-libs/libXi
+ )
+ virtual/x11
+ )
+ sys-libs/zlib
+ virtual/glu
+ virtual/opengl
+ >=media-libs/freetype-2
+ >=media-libs/libsdl-1.2
+ media-libs/sdl-net
+ media-libs/sdl-mixer"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ find data -type f -exec chmod a-x \{\} \;
+ epatch "${FILESDIR}/${P}"-gcc41.patch
+}
+
+src_compile() {
+ egamesconf \
+ --with-data-dir="${GAMES_DATADIR}/${PN}/data" \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/scourge || die "dogamesbin failed"
+ newicon assets/scourge.png scourge.png
+ insinto "${GAMES_DATADIR}/${PN}"
+ doins -r data/ || die "doins failed"
+ dodoc AUTHORS README
+ make_desktop_entry scourge Scourge
+ prepgamesdirs
+}