summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-09-11 02:40:34 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-09-11 02:40:34 +0000
commit460cf8bca65c582b608cde7d795be4826790e46e (patch)
tree094a26168a300b3eb22d3cb18196fadbb6357ac9 /games-rpg/adonthell
parentMore as-needed fixes, thanks to Kacper Kowalik closing bug #284518 (diff)
downloadgentoo-2-460cf8bca65c582b608cde7d795be4826790e46e.tar.gz
gentoo-2-460cf8bca65c582b608cde7d795be4826790e46e.tar.bz2
gentoo-2-460cf8bca65c582b608cde7d795be4826790e46e.zip
version bump (bug #226191)
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-rpg/adonthell')
-rw-r--r--games-rpg/adonthell/ChangeLog8
-rw-r--r--games-rpg/adonthell/adonthell-0.3.5.ebuild55
-rw-r--r--games-rpg/adonthell/files/adonthell-0.3.5-configure.in.patch92
3 files changed, 154 insertions, 1 deletions
diff --git a/games-rpg/adonthell/ChangeLog b/games-rpg/adonthell/ChangeLog
index 2ca97833c67e..8e8cd0e2d043 100644
--- a/games-rpg/adonthell/ChangeLog
+++ b/games-rpg/adonthell/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-rpg/adonthell
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.16 2009/07/26 22:03:30 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/ChangeLog,v 1.17 2009/09/11 02:40:30 mr_bones_ Exp $
+
+*adonthell-0.3.5 (11 Sep 2009)
+
+ 11 Sep 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +adonthell-0.3.5.ebuild, +files/adonthell-0.3.5-configure.in.patch:
+ version bump (bug #226191)
26 Jul 2009; Ryan Hill <dirtyepic@gentoo.org> adonthell-0.3.4a-r1.ebuild,
+files/adonthell-0.3.4a-glibc-2.10.patch:
diff --git a/games-rpg/adonthell/adonthell-0.3.5.ebuild b/games-rpg/adonthell/adonthell-0.3.5.ebuild
new file mode 100644
index 000000000000..bbe667c9a037
--- /dev/null
+++ b/games-rpg/adonthell/adonthell-0.3.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/adonthell/adonthell-0.3.5.ebuild,v 1.1 2009/09/11 02:40:30 mr_bones_ Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+DESCRIPTION="roleplaying game engine"
+HOMEPAGE="http://adonthell.linuxgames.com/"
+SRC_URI="http://savannah.nongnu.org/download/${PN}/${PN}-src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc nls"
+
+RDEPEND="media-libs/sdl-ttf
+ media-libs/sdl-mixer[vorbis]
+ media-libs/libsdl[X,video,audio]
+ sys-libs/zlib
+ media-libs/freetype
+ media-libs/libogg
+ media-libs/libvorbis
+ dev-lang/python
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}
+ dev-lang/swig
+ doc? (
+ media-gfx/graphviz
+ app-doc/doxygen
+ )
+ nls? ( sys-devel/gettext )"
+
+S=${WORKDIR}/${PN}-${PV/a/}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-configure.in.patch
+ rm -f ac{local,include}.m4
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-py-debug \
+ $(use_enable nls) \
+ $(use_enable doc)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ keepdir "${GAMES_DATADIR}"/${PN}/games
+ dodoc AUTHORS ChangeLog FULLSCREEN.howto NEWBIE NEWS README
+ prepgamesdirs
+}
diff --git a/games-rpg/adonthell/files/adonthell-0.3.5-configure.in.patch b/games-rpg/adonthell/files/adonthell-0.3.5-configure.in.patch
new file mode 100644
index 000000000000..903bd9a5f67d
--- /dev/null
+++ b/games-rpg/adonthell/files/adonthell-0.3.5-configure.in.patch
@@ -0,0 +1,92 @@
+--- configure.in
++++ configure.in
+@@ -13,7 +13,7 @@
+ AM_INIT_AUTOMAKE([])
+ AM_CONFIG_HEADER(config.h)
+
+-CFLAGS="-g -Wall -fno-exceptions"
++CXXFLAGS="$CXXFLAGS -Wall -fno-exceptions"
+ CPPFLAGS=""
+ DEFS=""
+
+@@ -163,10 +163,8 @@
+
+ dnl Extract the version using Python, check against 2.2+
+
+- changequote(<<, >>)
+- PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version[0]) * 10 + int(sys.version[2]))'`
+- PY_VERSION=`$PYPACKAGE -c 'import sys ; print sys.version[0:3]'`
+- changequote([, ])
++ PYTHON_VERSION=`$PYPACKAGE -c 'import sys ; print (int(sys.version@<:@0@:>@) * 10 + int(sys.version@<:@2@:>@))'`
++ PY_VERSION=`$PYPACKAGE -c 'import sys ; print sys.version@<:@0:3@:>@'`
+
+ if test $PYTHON_VERSION -lt 22; then
+ echo "Sorry, you need to have Python 2.2+ installed - update your version!"
+@@ -176,9 +174,7 @@
+ dnl Find the Python.h header file
+
+ AC_MSG_CHECKING(for Python header files)
+- changequote(<<, >>)
+- PYINCLUDE=`$PYPACKAGE -c 'import sys ; print "%s/include/python%s" % (sys.prefix, sys.version[:3])'`
+- changequote([, ])
++ PYINCLUDE=`$PYPACKAGE -c 'import sys ; print "%s/include/python%s" % (sys.prefix, sys.version@<:@:3@:>@)'`
+
+ if test -r "$PYINCLUDE/Python.h"; then
+ PY_CFLAGS="-I$PYINCLUDE"
+@@ -191,10 +187,8 @@
+ dnl Find the Python library
+ AC_MSG_CHECKING(for Python library)
+ PYLIB=""
+- changequote(<<, >>)
+ PYPREFIX=`$PYPACKAGE -c 'import sys; print sys.prefix'`
+- PYLIBVER=`$PYPACKAGE -c 'import sys; print sys.version[:3]'`
+- changequote([, ])
++ PYLIBVER=`$PYPACKAGE -c 'import sys; print sys.version@<:@:3@:>@'`
+
+ dnl look for a framework build of python first
+ fw=`echo "$PYPREFIX" | sed 's/.*\(Python\.framework\).*/\1/;'`
+@@ -233,19 +227,9 @@
+ fi
+ dnl Get the libraries that python depends on
+
+- AC_PATH_PROG(haveldd, ldd)
+ AC_MSG_CHECKING(for Python's dependencies)
+
+- if test x$haveldd != x ; then
+- changequote(<<, >>)
+- py_deps=`ldd $PYPACKAGE | sed 's/\( *.*lib\([^\/]*\)\.so.*=.*$\)/-l\2/p; d' | grep -v 'stdc++'`
+- for py_lib in $py_deps ; do
+- if test "$py_lib" != "-lm" && test "$py_lib" != "-lc" ; then
+- PY_DEPS="$PY_DEPS $py_lib"
+- fi
+- done
+- changequote([, ])
+- fi
++ PY_DEPS="$PY_DEPS `python-config --libs` -lutil"
+
+ case $target in
+ *-sun-solaris*)
+@@ -293,11 +277,9 @@
+ if test "$P_SWIG" != "no" ; then
+ $P_SWIG -version &> swig.ver
+
+- changequote(<<, >>)
+- swig_major_ver=`more swig.ver | sed 's/.* \([0-9]*\)\.[0-9]*\.[0-9]*.*/\1/p; d'`
+- swig_minor_ver=`more swig.ver | sed 's/.* [0-9]*\.\([0-9]*\)\.[0-9]*.*/\1/p; d'`
+- swig_micro_ver=`more swig.ver | sed 's/.* [0-9]*\.[0-9]*\.\([0-9]*\).*/\1/p; d'`
+- changequote([, ])
++ swig_major_ver=`more swig.ver | sed 's/.* \(@<:@0-9@:>@*\)\.@<:@0-9@:>@*\.@<:@0-9@:>@*.*/\1/p; d'`
++ swig_minor_ver=`more swig.ver | sed 's/.* @<:@0-9@:>@*\.\(@<:@0-9@:>@*\)\.@<:@0-9@:>@*.*/\1/p; d'`
++ swig_micro_ver=`more swig.ver | sed 's/.* @<:@0-9@:>@*\.@<:@0-9@:>@*\.\(@<:@0-9@:>@*\).*/\1/p; d'`
+
+ rm -f swig.ver
+
+@@ -387,7 +369,7 @@
+ dnl Generate our compiler arguements
+ dnl ********************************
+
+-CXXFLAGS="$CFLAGS $DEFS $INCLUDES"
++CXXFLAGS="$CXXFLAGS $DEFS $INCLUDES"
+
+ AC_SUBST(CXX)
+ AC_SUBST(CXXFLAGS)