summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2006-08-16 17:29:06 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2006-08-16 17:29:06 +0000
commitd00ab5ce56768f49423a65ae27bfe6aa70e7efb0 (patch)
tree28cead703c227137a84d61a78cf5677949adb521 /games-rpg/daimonin-client
parentStable on ppc64 (diff)
downloadgentoo-2-d00ab5ce56768f49423a65ae27bfe6aa70e7efb0.tar.gz
gentoo-2-d00ab5ce56768f49423a65ae27bfe6aa70e7efb0.tar.bz2
gentoo-2-d00ab5ce56768f49423a65ae27bfe6aa70e7efb0.zip
version bump (bug #132367)
(Portage version: 2.1.1_pre5-r1)
Diffstat (limited to 'games-rpg/daimonin-client')
-rw-r--r--games-rpg/daimonin-client/ChangeLog10
-rw-r--r--games-rpg/daimonin-client/daimonin-client-0.96.7_beta3.ebuild58
-rw-r--r--games-rpg/daimonin-client/files/0.96.7_beta3-gentoo-paths.patch102
-rw-r--r--games-rpg/daimonin-client/files/daimonin-client-0.96.7_beta3-64bits.patch31
-rw-r--r--games-rpg/daimonin-client/files/digest-daimonin-client-0.96.7_beta33
5 files changed, 203 insertions, 1 deletions
diff --git a/games-rpg/daimonin-client/ChangeLog b/games-rpg/daimonin-client/ChangeLog
index 21268d43add2..ea0ce17ff11c 100644
--- a/games-rpg/daimonin-client/ChangeLog
+++ b/games-rpg/daimonin-client/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for games-rpg/daimonin-client
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.15 2006/03/31 21:26:58 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/ChangeLog,v 1.16 2006/08/16 17:29:06 mr_bones_ Exp $
+
+*daimonin-client-0.96.7_beta3 (16 Aug 2006)
+
+ 16 Aug 2006; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/daimonin-client-0.96.7_beta3-64bits.patch,
+ +files/0.96.7_beta3-gentoo-paths.patch,
+ +daimonin-client-0.96.7_beta3.ebuild:
+ version bump (bug #132367)
31 Mar 2006; <Tupone@gentoo.org> daimonin-client-0.95b-r2.ebuild,
daimonin-client-0.96.6_beta3.ebuild:
diff --git a/games-rpg/daimonin-client/daimonin-client-0.96.7_beta3.ebuild b/games-rpg/daimonin-client/daimonin-client-0.96.7_beta3.ebuild
new file mode 100644
index 000000000000..619146fd0f65
--- /dev/null
+++ b/games-rpg/daimonin-client/daimonin-client-0.96.7_beta3.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/daimonin-client/daimonin-client-0.96.7_beta3.ebuild,v 1.1 2006/08/16 17:29:06 mr_bones_ Exp $
+
+inherit eutils flag-o-matic games
+
+MY_PV=${PV/_beta*}
+MY_PV=${MY_PV//.}
+DESCRIPTION="MMORPG with 2D isometric tiles grafik, true color and alpha blending effects"
+HOMEPAGE="http://daimonin.sourceforge.net/"
+SRC_URI="mirror://sourceforge/daimonin/daimonin_client-BETA3-${MY_PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl
+ media-libs/sdl-mixer
+ media-libs/sdl-image"
+
+S=${WORKDIR}/daimonin/client
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PV}-gentoo-paths.patch" \
+ "${FILESDIR}/${P}"-64bits.patch
+ chmod a+x make/linux/configure
+}
+
+src_compile() {
+ append-flags \
+ -DGENTOO_DATADIR="'\"${GAMES_DATADIR}/${PN}\"'" \
+ -DGENTOO_STATEDIR="'\"${GAMES_STATEDIR}/${PN}\"'"
+ # Bug #91950 - compiler optimization is bad for the game on amd64
+ if use amd64; then
+ append-flags -O0
+ fi
+
+ cd make/linux
+ egamesconf || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ dogamesbin src/daimonin || die "dogamesbin failed"
+ dodir "${GAMES_DATADIR}/${PN}" "${GAMES_STATEDIR}/${PN}"
+ cp -r bitmaps icons media sfx "${D}/${GAMES_DATADIR}/${PN}/" \
+ || die "cp failed"
+ cp -r cache gfx_user srv_files "${D}/${GAMES_STATEDIR}/${PN}/" \
+ || die "cp failed"
+ insinto "${GAMES_STATEDIR}/${PN}"
+ doins *.{dat,p0} || die "doins failed"
+ prepgamesdirs
+ find "${D}/${GAMES_STATEDIR}/${PN}/" -type d -print0 | xargs -0 \
+ chmod g+w
+}
diff --git a/games-rpg/daimonin-client/files/0.96.7_beta3-gentoo-paths.patch b/games-rpg/daimonin-client/files/0.96.7_beta3-gentoo-paths.patch
new file mode 100644
index 000000000000..94022939b3a9
--- /dev/null
+++ b/games-rpg/daimonin-client/files/0.96.7_beta3-gentoo-paths.patch
@@ -0,0 +1,102 @@
+diff -urN client/src/include/config.h client-new/src/include/config.h
+--- client/src/include/config.h 2004-05-13 19:14:52.000000000 +0100
++++ client-new/src/include/config.h 2004-06-13 13:23:55.408837640 +0100
+@@ -26,11 +26,11 @@
+ #define VERSION_CS 991016
+ #define VERSION_SC 991016
+
+-#define KEYBIND_FILE "./keys.dat"
+-#define OPTION_FILE "./options.dat"
+-#define ARCHDEF_FILE "./archdef.dat"
++#define KEYBIND_FILE GENTOO_STATEDIR "/keys.dat"
++#define OPTION_FILE GENTOO_STATEDIR "/options.dat"
++#define ARCHDEF_FILE GENTOO_STATEDIR "/archdef.dat"
+
+-#define LOG_FILE "./client.log"
++#define LOG_FILE GENTOO_STATEDIR "/client.log"
+
+ #define CLIENT_ICON_NAME "icon.png"
+
+diff -urN client/src/include/main.h client-new/src/include/main.h
+--- client/src/include/main.h 2004-05-13 19:14:52.000000000 +0100
++++ client-new/src/include/main.h 2004-06-13 13:33:36.773456784 +0100
+@@ -103,16 +103,16 @@
+
+ extern int bmaptype_table_size;
+
+-#define FILE_DAIMONIN_P0 "./daimonin.p0"
+-#define FILE_BMAPS_P0 "./bmaps.p0"
+-#define FILE_BMAPS_TMP "./srv_files/bmaps.tmp"
+-#define FILE_ANIMS_TMP "./srv_files/anims.tmp"
+-
+-#define FILE_CLIENT_SPELLS "./srv_files/client_spells"
+-#define FILE_CLIENT_SKILLS "./srv_files/client_skills"
+-#define FILE_CLIENT_SETTINGS "./srv_files/client_settings"
+-#define FILE_CLIENT_BMAPS "./srv_files/client_bmap"
+-#define FILE_CLIENT_ANIMS "./srv_files/client_anims"
++#define FILE_DAIMONIN_P0 GENTOO_STATEDIR "/daimonin.p0"
++#define FILE_BMAPS_P0 GENTOO_STATEDIR "/bmaps.p0"
++#define FILE_BMAPS_TMP GENTOO_STATEDIR "/srv_files/bmaps.tmp"
++#define FILE_ANIMS_TMP GENTOO_STATEDIR "/srv_files/anims.tmp"
++
++#define FILE_CLIENT_SPELLS GENTOO_STATEDIR "/srv_files/client_spells"
++#define FILE_CLIENT_SKILLS GENTOO_STATEDIR "/srv_files/client_skills"
++#define FILE_CLIENT_SETTINGS GENTOO_STATEDIR "/srv_files/client_settings"
++#define FILE_CLIENT_BMAPS GENTOO_STATEDIR "/srv_files/client_bmap"
++#define FILE_CLIENT_ANIMS GENTOO_STATEDIR "/srv_files/client_anims"
+
+ enum {
+ SRV_CLIENT_SKILLS,
+diff -urN client/src/wrapper.c client-new/src/wrapper.c
+--- client/src/wrapper.c 2004-05-13 19:14:52.000000000 +0100
++++ client-new/src/wrapper.c 2004-06-13 13:45:34.944278224 +0100
+@@ -84,35 +84,35 @@
+ char * GetBitmapDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./bitmaps/");
++ return(GENTOO_DATADIR "/bitmaps/");
+ #endif
+ }
+
+ char * GetIconDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./icons/");
++ return(GENTOO_DATADIR "/icons/");
+ #endif
+ }
+
+ char * GetSfxDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./sfx/");
++ return(GENTOO_DATADIR "/sfx/");
+ #endif
+ }
+
+ char * GetCacheDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./cache/");
++ return(GENTOO_STATEDIR "/cache/");
+ #endif
+ }
+
+ char * GetGfxUserDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./gfx_user/");
++ return(GENTOO_STATEDIR "/gfx_user/");
+ #endif
+ }
+
+@@ -120,7 +120,7 @@
+ char * GetMediaDirectory(void)
+ {
+ #if defined( __WIN_32) || defined(__LINUX)
+- return("./media/");
++ return(GENTOO_DATADIR "/media/");
+ #endif
+ }
+
diff --git a/games-rpg/daimonin-client/files/daimonin-client-0.96.7_beta3-64bits.patch b/games-rpg/daimonin-client/files/daimonin-client-0.96.7_beta3-64bits.patch
new file mode 100644
index 000000000000..aa097abbb0a9
--- /dev/null
+++ b/games-rpg/daimonin-client/files/daimonin-client-0.96.7_beta3-64bits.patch
@@ -0,0 +1,31 @@
+--- ../../src/wrapper.c.orig Thu Dec 18 22:43:08 2003
++++ ../../src/wrapper.c Wed Feb 16 10:09:17 2005
+@@ -44,13 +44,15 @@
+ }
+ if(!logstream) /* secure: we have no open stream*/
+ flag = FALSE;
+- va_start(ap, format);
+ if(flag)
+ {
++ va_start(ap, format);
+ vfprintf(stdout, format, ap);
++ va_end(ap);
++ va_start(ap, format);
+ vfprintf(logstream, format, ap);
++ va_end(ap);
+ }
+- va_end(ap);
+ fflush(logstream);
+
+ #endif
+--- ../../src/uncompr.c.orig Sun Nov 30 22:59:30 2003
++++ ../../src/uncompr.c Wed Feb 16 22:11:32 2005
+@@ -39,7 +39,7 @@
+
+ stream.next_out = dest;
+ stream.avail_out = (uInt)*destLen;
+- if ((uLong)stream.avail_out != *destLen) return Z_BUF_ERROR;
++ if ((uLong)stream.avail_out != (uInt)*destLen) return Z_BUF_ERROR;
+
+ stream.zalloc = (alloc_func)0;
+ stream.zfree = (free_func)0;
diff --git a/games-rpg/daimonin-client/files/digest-daimonin-client-0.96.7_beta3 b/games-rpg/daimonin-client/files/digest-daimonin-client-0.96.7_beta3
new file mode 100644
index 000000000000..ec030cc6ba5c
--- /dev/null
+++ b/games-rpg/daimonin-client/files/digest-daimonin-client-0.96.7_beta3
@@ -0,0 +1,3 @@
+MD5 d3998c0bcea05a57a1c937a3349880ec daimonin_client-BETA3-0967.tgz 15276026
+RMD160 628a070c38f0b2c10728d2295a01955d82eba84b daimonin_client-BETA3-0967.tgz 15276026
+SHA256 d02586e7a619ccccb15d1cef467cc46570847f4779815d91817972d36e237e3b daimonin_client-BETA3-0967.tgz 15276026