summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2012-04-14 19:21:00 +0000
committerAlfredo Tupone <tupone@gentoo.org>2012-04-14 19:21:00 +0000
commit039576782ca1a76e692a7313768dbc396dd82ce8 (patch)
treec6268e9e6b70ba76cf4922ea8684501730469942 /games-rpg/mana/mana-0.6.0.ebuild
parentAdd ~amd64-linux keyword. (diff)
downloadgentoo-2-039576782ca1a76e692a7313768dbc396dd82ce8.tar.gz
gentoo-2-039576782ca1a76e692a7313768dbc396dd82ce8.tar.bz2
gentoo-2-039576782ca1a76e692a7313768dbc396dd82ce8.zip
Honor LINGUAS. Bug #408771
(Portage version: 2.1.10.56/cvs/Linux i686)
Diffstat (limited to 'games-rpg/mana/mana-0.6.0.ebuild')
-rw-r--r--games-rpg/mana/mana-0.6.0.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/games-rpg/mana/mana-0.6.0.ebuild b/games-rpg/mana/mana-0.6.0.ebuild
index f9c73498c552..17e57ee73c71 100644
--- a/games-rpg/mana/mana-0.6.0.ebuild
+++ b/games-rpg/mana/mana-0.6.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-rpg/mana/mana-0.6.0.ebuild,v 1.1 2012/02/17 06:26:14 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-rpg/mana/mana-0.6.0.ebuild,v 1.2 2012/04/14 19:21:00 tupone Exp $
EAPI=2
inherit eutils cmake-utils games
@@ -45,6 +45,12 @@ src_prepare() {
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
CMakeLists.txt \
|| die "sed failed"
+
+ if [[ ${LINGUAS+set} ]]; then
+ for lang in $(grep -v ^# po/LINGUAS); do
+ has $lang $LINGUAS || sed -i "s:^${lang}:#${lang}:" po/LINGUAS
+ done
+ fi
}
src_configure() {