summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2011-02-21 14:17:21 +0000
committerAlfredo Tupone <tupone@gentoo.org>2011-02-21 14:17:21 +0000
commitb46fa99fc06cb36f6e8d62c04117bc0bcaa92629 (patch)
tree6f8a50b8f4df48977517c6e8aef4ce63aa26176b /games-server/crossfire-server
parentaalib, sdl and vaapi require X too (diff)
downloadgentoo-2-b46fa99fc06cb36f6e8d62c04117bc0bcaa92629.tar.gz
gentoo-2-b46fa99fc06cb36f6e8d62c04117bc0bcaa92629.tar.bz2
gentoo-2-b46fa99fc06cb36f6e8d62c04117bc0bcaa92629.zip
Fix build with media-libs/libpng-1.5 Bug #355123
(Portage version: 2.1.9.40/cvs/Linux i686)
Diffstat (limited to 'games-server/crossfire-server')
-rw-r--r--games-server/crossfire-server/ChangeLog9
-rw-r--r--games-server/crossfire-server/crossfire-server-1.11.0.ebuild8
-rw-r--r--games-server/crossfire-server/files/crossfire-server-1.11.0-libpng15.patch11
3 files changed, 23 insertions, 5 deletions
diff --git a/games-server/crossfire-server/ChangeLog b/games-server/crossfire-server/ChangeLog
index 7bbc2c289ca8..5f4bccb7be92 100644
--- a/games-server/crossfire-server/ChangeLog
+++ b/games-server/crossfire-server/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-server/crossfire-server
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/ChangeLog,v 1.17 2010/03/24 14:15:39 ranger Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/ChangeLog,v 1.18 2011/02/21 14:17:21 tupone Exp $
+
+ 21 Feb 2011; Tupone Alfredo <tupone@gentoo.org>
+ crossfire-server-1.11.0.ebuild,
+ +files/crossfire-server-1.11.0-libpng15.patch:
+ Fix build with media-libs/libpng-1.5 Bug #355123 by Lars Wendler
24 Mar 2010; Brent Baude <ranger@gentoo.org>
crossfire-server-1.11.0.ebuild:
diff --git a/games-server/crossfire-server/crossfire-server-1.11.0.ebuild b/games-server/crossfire-server/crossfire-server-1.11.0.ebuild
index 2ca15aaf91c2..de2510025462 100644
--- a/games-server/crossfire-server/crossfire-server-1.11.0.ebuild
+++ b/games-server/crossfire-server/crossfire-server-1.11.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/crossfire-server-1.11.0.ebuild,v 1.5 2010/03/24 14:15:39 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/crossfire-server/crossfire-server-1.11.0.ebuild,v 1.6 2011/02/21 14:17:21 tupone Exp $
EAPI=2
-inherit autotools games
+inherit eutils autotools games
MY_P="${P/-server/}"
DESCRIPTION="server for the crossfire clients"
@@ -20,10 +20,12 @@ DEPEND="
X? (
x11-libs/libXaw
media-libs/libpng )"
+RDEPEND="${DEPEND}"
S=${WORKDIR}/${MY_P}
src_prepare() {
+ epatch "${FILESDIR}"/${P}-libpng15.patch
sed -i \
-e 's/make /$(MAKE) /' \
$(find . -name Makefile.am) \
diff --git a/games-server/crossfire-server/files/crossfire-server-1.11.0-libpng15.patch b/games-server/crossfire-server/files/crossfire-server-1.11.0-libpng15.patch
new file mode 100644
index 000000000000..93841e518db5
--- /dev/null
+++ b/games-server/crossfire-server/files/crossfire-server-1.11.0-libpng15.patch
@@ -0,0 +1,11 @@
+--- crossedit/png.c.old 2011-02-21 14:50:43.000000000 +0100
++++ crossedit/png.c 2011-02-21 14:51:20.000000000 +0100
+@@ -269,7 +269,7 @@
+ png_destroy_read_struct (&png_ptr, &info_ptr, NULL);
+ return PNGX_OUTOFMEM;
+ }
+- if (setjmp (png_ptr->jmpbuf)) {
++ if (setjmp(png_jmpbuf(png_ptr))) {
+ png_destroy_read_struct (&png_ptr, &info_ptr, &end_info);
+ return PNGX_DATA;
+ }