summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-11-13 02:53:50 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-11-13 02:53:50 +0000
commitd25a85cc2eca07f7827c26320fda05f69d167a95 (patch)
treef7313213e09f5541ee4f22afaa5d815bc6fa7c0d /games-server/cyphesis/cyphesis-0.6.0.ebuild
parentversion bump (diff)
downloadgentoo-2-d25a85cc2eca07f7827c26320fda05f69d167a95.tar.gz
gentoo-2-d25a85cc2eca07f7827c26320fda05f69d167a95.tar.bz2
gentoo-2-d25a85cc2eca07f7827c26320fda05f69d167a95.zip
version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'games-server/cyphesis/cyphesis-0.6.0.ebuild')
-rw-r--r--games-server/cyphesis/cyphesis-0.6.0.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/games-server/cyphesis/cyphesis-0.6.0.ebuild b/games-server/cyphesis/cyphesis-0.6.0.ebuild
new file mode 100644
index 000000000000..3c5eb4b29386
--- /dev/null
+++ b/games-server/cyphesis/cyphesis-0.6.0.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/cyphesis/cyphesis-0.6.0.ebuild,v 1.1 2012/11/13 02:53:50 mr_bones_ Exp $
+
+EAPI=2
+PYTHON_DEPEND=2
+inherit autotools python eutils games
+
+DESCRIPTION="WorldForge server running small games"
+HOMEPAGE="http://worldforge.org/dev/eng/servers/cyphesis"
+SRC_URI="mirror://sourceforge/worldforge/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="test"
+
+RDEPEND=">=media-libs/skstream-0.3.9
+ >=dev-games/wfmath-1.0.1
+ >=dev-games/mercator-0.3.1
+ dev-libs/libgcrypt
+ dev-libs/libsigc++:2
+ sys-libs/ncurses
+ sys-libs/readline
+ =media-libs/atlas-c++-0.6*
+ >=media-libs/varconf-0.6.4
+ dev-db/postgresql-base"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2
+ virtual/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+ games_pkg_setup
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-gentoo.patch \
+ "${FILESDIR}"/${P}-makefile.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --localstatedir=/var
+}
+
+src_install() {
+ emake DESTDIR="${D}" confbackupdir="/usr/share/doc/${PF}/conf" \
+ install || die
+ dodoc AUTHORS ChangeLog FIXME NEWS README THANKS TODO
+ prepgamesdirs
+}