summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-16 18:30:09 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-16 18:30:09 +0000
commitd54d61466b17357b0aab87c07e3f80816f1d7007 (patch)
tree3dedfdddc6b95e2bc4e1e05ab7f59ab1fcb2118c /games-server/halflife-adminmod
parentmanifest (diff)
downloadgentoo-2-d54d61466b17357b0aab87c07e3f80816f1d7007.tar.gz
gentoo-2-d54d61466b17357b0aab87c07e3f80816f1d7007.tar.bz2
gentoo-2-d54d61466b17357b0aab87c07e3f80816f1d7007.zip
ver bump #46306
Diffstat (limited to 'games-server/halflife-adminmod')
-rw-r--r--games-server/halflife-adminmod/ChangeLog7
-rw-r--r--games-server/halflife-adminmod/files/2.50.59-adminmod.cfg20
-rw-r--r--games-server/halflife-adminmod/files/digest-halflife-adminmod-2.50.591
-rw-r--r--games-server/halflife-adminmod/halflife-adminmod-2.50.59.ebuild43
4 files changed, 70 insertions, 1 deletions
diff --git a/games-server/halflife-adminmod/ChangeLog b/games-server/halflife-adminmod/ChangeLog
index 81f185bedcfa..17020355f53c 100644
--- a/games-server/halflife-adminmod/ChangeLog
+++ b/games-server/halflife-adminmod/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-server/halflife-adminmod
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-adminmod/ChangeLog,v 1.3 2003/11/08 07:18:30 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-adminmod/ChangeLog,v 1.4 2004/04/16 18:30:09 vapier Exp $
+
+*halflife-adminmod-2.50.59 (16 Apr 2004)
+
+ 16 Apr 2004; Mike Frysinger <vapier@gentoo.org> :
+ Version bumpage #46306 by Daniel Fullmer.
*halflife-adminmod-2.50.58 (08 Nov 2003)
diff --git a/games-server/halflife-adminmod/files/2.50.59-adminmod.cfg b/games-server/halflife-adminmod/files/2.50.59-adminmod.cfg
new file mode 100644
index 000000000000..83be51a21823
--- /dev/null
+++ b/games-server/halflife-adminmod/files/2.50.59-adminmod.cfg
@@ -0,0 +1,20 @@
+--- config/adminmod.cfg.orig 2003-08-12 10:47:26.000000000 -0400
++++ config/adminmod.cfg 2003-08-12 10:51:55.000000000 -0400
+@@ -17 +17 @@
+-admin_connect_msg "Welcome to the Real World..."
++admin_connect_msg "Welcome to the Real World w/Gentoo Linux..."
+@@ -62 +62 @@
+-admin_plugin_file "addons/adminmod/config/plugin.ini"
++admin_plugin_file "plugin.ini"
+@@ -70 +70 @@
+-admin_reject_msg "You do not have access to this command."
++admin_reject_msg "Larry the Cow says you do not have access to this command."
+@@ -79 +79 @@
+-admin_repeat_msg "This server is using Admin Mod"
++admin_repeat_msg "Running Admin Mod on Gentoo Linux"
+@@ -90 +90 @@
+-admin_vault_file "addons/adminmod/config/vault.ini"
++admin_vault_file "vault.ini"
+@@ -222 +222 @@
+-users_file "addons/adminmod/config/users.ini"
++users_file "users.ini"
diff --git a/games-server/halflife-adminmod/files/digest-halflife-adminmod-2.50.59 b/games-server/halflife-adminmod/files/digest-halflife-adminmod-2.50.59
new file mode 100644
index 000000000000..5192369d0d6d
--- /dev/null
+++ b/games-server/halflife-adminmod/files/digest-halflife-adminmod-2.50.59
@@ -0,0 +1 @@
+MD5 1ede3ec0873770c43c6150658bff1f03 halflife-admin-2.50.59.tar.gz 1559354
diff --git a/games-server/halflife-adminmod/halflife-adminmod-2.50.59.ebuild b/games-server/halflife-adminmod/halflife-adminmod-2.50.59.ebuild
new file mode 100644
index 000000000000..4ace2ae2c23f
--- /dev/null
+++ b/games-server/halflife-adminmod/halflife-adminmod-2.50.59.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-server/halflife-adminmod/halflife-adminmod-2.50.59.ebuild,v 1.1 2004/04/16 18:30:09 vapier Exp $
+
+inherit games eutils
+
+MY_P=${P/mod/}
+DESCRIPTION="give people admin access (and a looooooot more)"
+HOMEPAGE="http://www.adminmod.org/"
+SRC_URI="mirror://sourceforge/halflifeadmin/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-* x86"
+
+RDEPEND="games-server/halflife-metamod"
+PDEPEND="games-server/halflife-modsetup"
+
+S=${WORKDIR}/Adminmod
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ # fix default values
+ sed -i "s:addons:../addons:" config/{metamod,plugin}.ini
+ sed -i "/^[^/]/s:^://:" config/Samples/{ips,users}.ini
+ sed -i "/^[^/h]/s:^://:" config/Samples/models.ini
+ epatch ${FILESDIR}/${PV}-adminmod.cfg
+}
+
+src_install() {
+ local dir=${GAMES_PREFIX_OPT}/halflife/addons/adminmod
+
+ dodoc HISTORY NEWS README docs/*
+ dohtml -r docs/html/*
+ rm -rf HISTORY LICENSE NEWS README docs dlls/metamod_i386.so
+
+ dodir ${dir}
+ cp -rf ${S}/* ${FILESDIR}/modsetup ${D}/${dir}/
+ dosym /usr/share/doc/${PF} ${dir}/docs
+
+ prepgamesdirs
+}