summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2012-05-04 23:13:04 +0000
committerMichael Weber <xmw@gentoo.org>2012-05-04 23:13:04 +0000
commitec1ddf948abbee8143f3b04c0edaf4f9a73d7e6c (patch)
treebf6653749b37cdca9421c86c34f986601f3eb4c1 /games-simulation/crrcsim
parentwhitespace (diff)
downloadgentoo-2-ec1ddf948abbee8143f3b04c0edaf4f9a73d7e6c.tar.gz
gentoo-2-ec1ddf948abbee8143f3b04c0edaf4f9a73d7e6c.tar.bz2
gentoo-2-ec1ddf948abbee8143f3b04c0edaf4f9a73d7e6c.zip
Version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation/crrcsim')
-rw-r--r--games-simulation/crrcsim/ChangeLog7
-rw-r--r--games-simulation/crrcsim/crrcsim-0.9.12.ebuild44
2 files changed, 50 insertions, 1 deletions
diff --git a/games-simulation/crrcsim/ChangeLog b/games-simulation/crrcsim/ChangeLog
index b9fd0bf43235..898a6e9341c0 100644
--- a/games-simulation/crrcsim/ChangeLog
+++ b/games-simulation/crrcsim/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for games-simulation/crrcsim
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/ChangeLog,v 1.4 2012/04/23 17:36:59 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/ChangeLog,v 1.5 2012/05/04 23:13:04 xmw Exp $
+
+*crrcsim-0.9.12 (04 May 2012)
+
+ 04 May 2012; Michael Weber <xmw@gentoo.org> +crrcsim-0.9.12.ebuild:
+ Version bump
23 Apr 2012; Michał Górny <mgorny@gentoo.org> crrcsim-0.9.11.ebuild:
Use mirror:// in SRC_URI.
diff --git a/games-simulation/crrcsim/crrcsim-0.9.12.ebuild b/games-simulation/crrcsim/crrcsim-0.9.12.ebuild
new file mode 100644
index 000000000000..72f894608522
--- /dev/null
+++ b/games-simulation/crrcsim/crrcsim-0.9.12.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/crrcsim/crrcsim-0.9.12.ebuild,v 1.1 2012/05/04 23:13:04 xmw Exp $
+
+EAPI=3
+
+inherit autotools eutils games
+
+DESCRIPTION="model-airplane flight simulation program"
+HOMEPAGE="http://sourceforge.net/projects/crrcsim/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="portaudio"
+
+RDEPEND="sci-mathematics/cgal
+ media-libs/plib
+ media-libs/libsdl[X,audio,joystick,opengl,video]
+ portaudio? ( media-libs/portaudio )"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-buildsystem.patch
+ if built_with_use --missing false sci-mathematics/cgal gmp ; then
+ epatch "${FILESDIR}"/${PN}-cgal_gmp.patch
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ econf --docdir="${EPREFIX}/usr/share/doc/${PF}" \
+ $(use_with portaudio)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+
+ dodoc AUTHORS HISTORY NEWS README || die
+
+ prepgamesdirs
+}