summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-07-25 11:39:45 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-07-25 11:39:45 +0000
commite3113b75d942050cc3568c8c46416493f0acfae0 (patch)
treed19a3012485e8bbf38e536767e078db59709d257 /games-simulation/fgrun/fgrun-0.4.8.ebuild
parentclean-up; make init script work with baselayout 2; add some comments to die c... (diff)
downloadgentoo-2-e3113b75d942050cc3568c8c46416493f0acfae0.tar.gz
gentoo-2-e3113b75d942050cc3568c8c46416493f0acfae0.tar.bz2
gentoo-2-e3113b75d942050cc3568c8c46416493f0acfae0.zip
inherit multilib
(Portage version: 2.1.3_rc9)
Diffstat (limited to 'games-simulation/fgrun/fgrun-0.4.8.ebuild')
-rw-r--r--games-simulation/fgrun/fgrun-0.4.8.ebuild12
1 files changed, 7 insertions, 5 deletions
diff --git a/games-simulation/fgrun/fgrun-0.4.8.ebuild b/games-simulation/fgrun/fgrun-0.4.8.ebuild
index 28f324eb62a6..96f6011d6da6 100644
--- a/games-simulation/fgrun/fgrun-0.4.8.ebuild
+++ b/games-simulation/fgrun/fgrun-0.4.8.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-0.4.8.ebuild,v 1.2 2007/07/25 09:27:29 opfer Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/fgrun/fgrun-0.4.8.ebuild,v 1.3 2007/07/25 11:39:45 nyhm Exp $
-inherit autotools eutils games
+inherit autotools eutils multilib games
-DESCRIPTION="A graphical frontend to run FlightGear Flight Simulator."
+DESCRIPTION="A graphical frontend for the FlightGear Flight Simulator"
HOMEPAGE="http://sourceforge.net/projects/fgrun"
SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
@@ -27,13 +27,15 @@ src_unpack() {
}
src_compile() {
- egamesconf --with-plib-libraries=/usr/$(get_libdir) --with-plib-includes=/usr/include || die "egamesconf failed"
+ egamesconf \
+ --with-plib-libraries=/usr/$(get_libdir) \
+ --with-plib-includes=/usr/include \
+ || die
emake || die "emake failed"
}
src_install() {
emake DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS NEWS
-
prepgamesdirs
}