summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2009-03-06 11:05:00 +0000
committerAlfredo Tupone <tupone@gentoo.org>2009-03-06 11:05:00 +0000
commit38d5062a963d5cf6401988e7c8e18044cddf33ff (patch)
treed446c26421b1a6e17f537809119a3053de73aab0 /games-simulation/flightgear
parentdrop old configure options (diff)
downloadgentoo-2-38d5062a963d5cf6401988e7c8e18044cddf33ff.tar.gz
gentoo-2-38d5062a963d5cf6401988e7c8e18044cddf33ff.tar.bz2
gentoo-2-38d5062a963d5cf6401988e7c8e18044cddf33ff.zip
Version bump to 1.9.1 Bug #252200
(Portage version: 2.1.6.7/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation/flightgear')
-rw-r--r--games-simulation/flightgear/ChangeLog9
-rw-r--r--games-simulation/flightgear/files/flightgear-1.9.1-parallel.patch11
-rw-r--r--games-simulation/flightgear/files/flightgear-1.9.1-sdl.patch11
-rw-r--r--games-simulation/flightgear/flightgear-1.9.1.ebuild49
4 files changed, 79 insertions, 1 deletions
diff --git a/games-simulation/flightgear/ChangeLog b/games-simulation/flightgear/ChangeLog
index 94c3b69699f7..68dbe97c415f 100644
--- a/games-simulation/flightgear/ChangeLog
+++ b/games-simulation/flightgear/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-simulation/flightgear
# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.36 2009/02/24 17:14:18 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/ChangeLog,v 1.37 2009/03/06 11:04:59 tupone Exp $
+
+*flightgear-1.9.1 (06 Mar 2009)
+
+ 06 Mar 2009; Alfredo Tupone <tupone@gentoo.org>
+ +files/flightgear-1.9.1-parallel.patch, +files/flightgear-1.9.1-sdl.patch,
+ +flightgear-1.9.1.ebuild:
+ Version bump to 1.9.1 Bug #252200 by Hal Engel
24 Feb 2009; Joseph Jezak <josejx@gentoo.org> flightgear-1.0.0.ebuild:
Marked ppc stable for bug #217505.
diff --git a/games-simulation/flightgear/files/flightgear-1.9.1-parallel.patch b/games-simulation/flightgear/files/flightgear-1.9.1-parallel.patch
new file mode 100644
index 000000000000..61147475ed4a
--- /dev/null
+++ b/games-simulation/flightgear/files/flightgear-1.9.1-parallel.patch
@@ -0,0 +1,11 @@
+--- src/Main/Makefile.am.old 2009-03-05 16:57:02.000000000 +0100
++++ src/Main/Makefile.am 2009-03-05 16:57:26.000000000 +0100
+@@ -61,7 +61,7 @@
+ fgfs_SOURCES = bootstrap.cxx
+
+ fgfs_LDADD = \
+- $(top_builddir)/src/Main/libMain.a \
++ libMain.a \
+ $(top_builddir)/src/Aircraft/libAircraft.a \
+ $(top_builddir)/src/ATCDCL/libATCDCL.a \
+ $(top_builddir)/src/Cockpit/libCockpit.a \
diff --git a/games-simulation/flightgear/files/flightgear-1.9.1-sdl.patch b/games-simulation/flightgear/files/flightgear-1.9.1-sdl.patch
new file mode 100644
index 000000000000..835d0f4c0006
--- /dev/null
+++ b/games-simulation/flightgear/files/flightgear-1.9.1-sdl.patch
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2008-09-08 12:57:35.000000000 -0400
++++ configure.ac 2008-09-08 12:58:50.000000000 -0400
+@@ -268,6 +268,8 @@
+ AC_SEARCH_LIBS(glutGetModifiers, [ glut freeglut ])
+ if test "x$enable_sdl" = "xyes"; then
+ AC_SEARCH_LIBS(SDL_Init, SDL)
++ CFLAGS="$CFLAGS `sdl-config --cflags`"
++ CXXFLAGS="$CXXFLAGS `sdl-config --cflags`"
+ fi
+ ;;
+
diff --git a/games-simulation/flightgear/flightgear-1.9.1.ebuild b/games-simulation/flightgear/flightgear-1.9.1.ebuild
new file mode 100644
index 000000000000..382a0f0013a1
--- /dev/null
+++ b/games-simulation/flightgear/flightgear-1.9.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/flightgear/flightgear-1.9.1.ebuild,v 1.1 2009/03/06 11:04:59 tupone Exp $
+
+EAPI=2
+inherit autotools eutils games
+
+MY_PN=FlightGear
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="Open Source Flight Simulator"
+HOMEPAGE="http://www.flightgear.org/"
+SRC_URI="mirror://flightgear/Source/${MY_P}.tar.gz
+ mirror://flightgear/Shared/${MY_PN}-data-1.9.0.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="sdl"
+
+RDEPEND="virtual/glut
+ ~dev-games/simgear-1.9.1
+ dev-games/openscenegraph
+ x11-libs/libXmu"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-sdl.patch \
+ "${FILESDIR}"/${P}-parallel.patch
+ eautoreconf
+}
+
+src_configure() {
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable sdl) \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ insinto "${GAMES_DATADIR}"/${MY_PN}
+ doins -r ../data/* || die "doins failed"
+ newicon ../data/Aircraft/A6M2/thumbnail.jpg ${PN}.jpg
+ make_desktop_entry fgfs FlightGear /usr/share/pixmaps/${PN}.jpg
+ dodoc AUTHORS ChangeLog NEWS README Thanks
+ prepgamesdirs
+}