summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2006-11-17 12:51:52 +0000
committerTristan Heaven <nyhm@gentoo.org>2006-11-17 12:51:52 +0000
commit4a477dbb9eb04b6d9f93541bfe5ccd8001a39f12 (patch)
tree40519c1fbd5a69ed780a89a3043f921c741eb9e2 /games-simulation
parentStable on sparc (diff)
downloadgentoo-2-4a477dbb9eb04b6d9f93541bfe5ccd8001a39f12.tar.gz
gentoo-2-4a477dbb9eb04b6d9f93541bfe5ccd8001a39f12.tar.bz2
gentoo-2-4a477dbb9eb04b6d9f93541bfe5ccd8001a39f12.zip
Fix install location
(Portage version: 2.1.2_rc1-r7)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/kfreeflight/ChangeLog6
-rw-r--r--games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild20
2 files changed, 16 insertions, 10 deletions
diff --git a/games-simulation/kfreeflight/ChangeLog b/games-simulation/kfreeflight/ChangeLog
index 19dd866136f5..28a9a4e74590 100644
--- a/games-simulation/kfreeflight/ChangeLog
+++ b/games-simulation/kfreeflight/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/kfreeflight
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/kfreeflight/ChangeLog,v 1.3 2006/10/31 23:11:41 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/kfreeflight/ChangeLog,v 1.4 2006/11/17 12:51:52 nyhm Exp $
+
+ 17 Nov 2006; Tristan Heaven <nyhm@gentoo.org>
+ kfreeflight-0.2.1_rc1.ebuild:
+ Fix install location
31 Oct 2006; <tupone@gentoo.org> kfreeflight-0.2.1_rc1.ebuild:
Added ~amd64 keyword. Bug #153461 by Zaba Zabov
diff --git a/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild b/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild
index 5960b2e4f4ce..f798cde52144 100644
--- a/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild
+++ b/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild,v 1.3 2006/10/31 23:11:41 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/kfreeflight/kfreeflight-0.2.1_rc1.ebuild,v 1.4 2006/11/17 12:51:52 nyhm Exp $
-inherit eutils kde games
+inherit eutils kde-functions games
MY_P=${P//_/}
@@ -13,7 +13,7 @@ SRC_URI="mirror://sourceforge/kfreeflight/${MY_P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="arts"
RDEPEND="games-simulation/flightgear"
@@ -22,18 +22,20 @@ S=${WORKDIR}/${PN}-${PV%_*}
need-kde 3.5.2
src_compile() {
- local myconf
- kde_src_compile myconf
- egamesconf $myconf || die "egamesconf failed"
+ egamesconf \
+ --datadir=/usr/share \
+ $(use_with arts) \
+ || die
emake || die "emake failed"
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
dodoc AUTHORS NEWS TODO
- rm -rf ${D}/usr/share/applnk
- make_desktop_entry ${PN}
+ rm -rf "${D}"/usr/share/applnk
+ newicon src/hi64-app-kfreeflight.png ${PN}.png
+ make_desktop_entry ${PN} KFreeFlight
prepgamesdirs
}