summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2012-09-03 19:30:21 +0000
committerJulian Ospald <hasufell@gentoo.org>2012-09-03 19:30:21 +0000
commit4e55f0e69aecd25b62cf28f2f25877f2888dcc93 (patch)
tree77f91db3f52247617d50cb2e3e6a54b9e7a06488 /games-simulation
parentrespect cflags wrt #430080 (diff)
downloadgentoo-2-4e55f0e69aecd25b62cf28f2f25877f2888dcc93.tar.gz
gentoo-2-4e55f0e69aecd25b62cf28f2f25877f2888dcc93.tar.bz2
gentoo-2-4e55f0e69aecd25b62cf28f2f25877f2888dcc93.zip
respect flags wrt #427788
(Portage version: 2.1.11.9/cvs/Linux x86_64)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/cannonsmash/ChangeLog6
-rw-r--r--games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild4
-rw-r--r--games-simulation/cannonsmash/files/cannonsmash-0.6.6-flags.patch21
-rw-r--r--games-simulation/cannonsmash/files/cannonsmash-0.6.6-ldflags.patch11
4 files changed, 28 insertions, 14 deletions
diff --git a/games-simulation/cannonsmash/ChangeLog b/games-simulation/cannonsmash/ChangeLog
index d15374ccef30..d56ef3b7b77f 100644
--- a/games-simulation/cannonsmash/ChangeLog
+++ b/games-simulation/cannonsmash/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-simulation/cannonsmash
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.21 2012/05/02 21:16:56 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/ChangeLog,v 1.22 2012/09/03 19:30:21 hasufell Exp $
+
+ 03 Sep 2012; Julian Ospald <hasufell@gentoo.org> cannonsmash-0.6.6.ebuild,
+ +files/cannonsmash-0.6.6-flags.patch, -files/cannonsmash-0.6.6-ldflags.patch:
+ respect flags wrt #427788
02 May 2012; Jeff Horelick <jdhore@gentoo.org> cannonsmash-0.6.6.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
index 63ad0757779c..0191a3785488 100644
--- a/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
+++ b/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.17 2012/05/02 21:16:56 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/cannonsmash/cannonsmash-0.6.6.ebuild,v 1.18 2012/09/03 19:30:21 hasufell Exp $
EAPI=2
inherit eutils games
@@ -38,7 +38,7 @@ src_prepare() {
"${FILESDIR}"/${P}-x-inc.patch \
"${FILESDIR}"/${P}-sizeof-cast.patch \
"${FILESDIR}"/${P}-gcc41.patch \
- "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-flags.patch
if use vorbis ; then
sed -i \
-e "s:${MY_OGG}:${GAMES_DATADIR}/csmash/${MY_OGG}:" ttinc.h \
diff --git a/games-simulation/cannonsmash/files/cannonsmash-0.6.6-flags.patch b/games-simulation/cannonsmash/files/cannonsmash-0.6.6-flags.patch
new file mode 100644
index 000000000000..85612b929c59
--- /dev/null
+++ b/games-simulation/cannonsmash/files/cannonsmash-0.6.6-flags.patch
@@ -0,0 +1,21 @@
+--- configure.old 2010-10-18 15:05:02.000000000 +0200
++++ configure 2010-10-18 15:05:31.000000000 +0200
+@@ -5516,12 +5516,12 @@
+
+
+ if test "x$x_includes" != "x"; then
+- CFLAGS="-I $x_includes"
+-else
+- CFLAGS=""
+-fi
+-LDFLAGS="-L/usr/local/lib -L$x_libraries -L$libdir"
+-CXXFLAGS="$CFLAGS -Wall"
++ CFLAGS="${CFLAGS} -I $x_includes"
++else
++ CFLAGS="${CFLAGS}"
++fi
++LDFLAGS="${LDFLAGS} -L/usr/local/lib -L$x_libraries -L$libdir"
++CXXFLAGS="${CXXFLAGS} -Wall"
+
+
+ echo "$as_me:$LINENO: checking for main in -lXmu" >&5
diff --git a/games-simulation/cannonsmash/files/cannonsmash-0.6.6-ldflags.patch b/games-simulation/cannonsmash/files/cannonsmash-0.6.6-ldflags.patch
deleted file mode 100644
index ad6168a463ed..000000000000
--- a/games-simulation/cannonsmash/files/cannonsmash-0.6.6-ldflags.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- configure.old 2010-10-18 15:05:02.000000000 +0200
-+++ configure 2010-10-18 15:05:31.000000000 +0200
-@@ -5520,7 +5520,7 @@
- else
- CFLAGS=""
- fi
--LDFLAGS="-L/usr/local/lib -L$x_libraries -L$libdir"
-+LDFLAGS="${LDFLAGS} -L/usr/local/lib -L$x_libraries -L$libdir"
- CXXFLAGS="$CFLAGS -Wall"
-
-