summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Holm <dholm@gentoo.org>2004-12-28 10:06:14 +0000
committerDavid Holm <dholm@gentoo.org>2004-12-28 10:06:14 +0000
commita359ebdf9a4386346ddee200a768bfc1d0877258 (patch)
treeebd930900081f1d45d40ab56f207009e1a9abbd5 /games-simulation
parentAdded ~ppc64 to KEYWORDS (Manifest recommit) (diff)
downloadgentoo-2-a359ebdf9a4386346ddee200a768bfc1d0877258.tar.gz
gentoo-2-a359ebdf9a4386346ddee200a768bfc1d0877258.tar.bz2
gentoo-2-a359ebdf9a4386346ddee200a768bfc1d0877258.zip
Play midi through alsa if timidity is disabled (Bug #64863)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/ChangeLog5
-rw-r--r--games-simulation/openttd/openttd-0.3.5.ebuild10
2 files changed, 11 insertions, 4 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index 05b6e7179b98..9c0bf993d07e 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.8 2004/12/25 11:15:23 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.9 2004/12/28 10:06:14 dholm Exp $
+
+ 28 Dec 2004; David Holm <dholm@gentoo.org> openttd-0.3.5.ebuild:
+ Play midi through alsa if timidity is disabled (Bug #64863)
*openttd-0.3.5 (25 Dec 2004)
diff --git a/games-simulation/openttd/openttd-0.3.5.ebuild b/games-simulation/openttd/openttd-0.3.5.ebuild
index ed276e89e14c..25abf5b4c1f6 100644
--- a/games-simulation/openttd/openttd-0.3.5.ebuild
+++ b/games-simulation/openttd/openttd-0.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.3.5.ebuild,v 1.1 2004/12/25 11:15:23 dholm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.3.5.ebuild,v 1.2 2004/12/28 10:06:14 dholm Exp $
inherit games
@@ -11,20 +11,24 @@ SRC_URI="mirror://sourceforge/openttd/${P}-source.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86 ~ppc ~amd64"
-IUSE="debug png zlib timidity"
+IUSE="debug png zlib timidity alsa"
DEPEND="virtual/libc
media-libs/libsdl
png? ( media-libs/libpng )
zlib? ( sys-libs/zlib )"
RDEPEND="${DEPEND}
- timidity? ( media-sound/timidity++ )"
+ timidity? ( media-sound/timidity++ )
+ !timidity? ( alsa? ( media-sound/pmidi ) )"
src_compile() {
local myopts="MANUAL_CONFIG=1 UNIX=1 WITH_SDL=1 WITH_NETWORK=1 INSTALL=1 RELEASE=${PV} USE_HOMEDIR=1 PERSONAL_DIR=.openttd PREFIX=/usr DATA_DIR=share/games/${PN}"
use debug && myopts="${myopts} DEBUG=1"
use png && myopts="${myopts} WITH_PNG=1"
use zlib && myopts="${myopts} WITH_ZLIB=1"
+ if ! use timidity; then
+ use alsa && myopts="${myopts} MIDI=/usr/bin/pmidi"
+ fi
emake -j1 ${myopts} || die "emake failed"
}