summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2009-12-09 17:03:30 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2009-12-09 17:03:30 +0000
commitacb2a9b71d5aa76ca3ebb6755572c9d01658cc23 (patch)
tree4d13229170127e72be02cce7fd56cb5ae5406bcb /games-simulation
parentMarking gst-python-0.10.16 ppc64 for bug 290343 (diff)
downloadgentoo-2-acb2a9b71d5aa76ca3ebb6755572c9d01658cc23.tar.gz
gentoo-2-acb2a9b71d5aa76ca3ebb6755572c9d01658cc23.tar.bz2
gentoo-2-acb2a9b71d5aa76ca3ebb6755572c9d01658cc23.zip
version bump
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'games-simulation')
-rw-r--r--games-simulation/openttd/ChangeLog8
-rw-r--r--games-simulation/openttd/openttd-0.7.4.ebuild119
2 files changed, 126 insertions, 1 deletions
diff --git a/games-simulation/openttd/ChangeLog b/games-simulation/openttd/ChangeLog
index 431677041b7c..0c0cf082d9eb 100644
--- a/games-simulation/openttd/ChangeLog
+++ b/games-simulation/openttd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-simulation/openttd
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.79 2009/11/09 21:30:45 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/ChangeLog,v 1.80 2009/12/09 17:03:30 mr_bones_ Exp $
+
+*openttd-0.7.4 (09 Dec 2009)
+
+ 09 Dec 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +openttd-0.7.4.ebuild:
+ version bump
09 Nov 2009; Joseph Jezak <josejx@gentoo.org> openttd-0.7.3.ebuild:
Marked ppc/ppc64 stable for bug #291910.
diff --git a/games-simulation/openttd/openttd-0.7.4.ebuild b/games-simulation/openttd/openttd-0.7.4.ebuild
new file mode 100644
index 000000000000..31b0e3e85fd3
--- /dev/null
+++ b/games-simulation/openttd/openttd-0.7.4.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-simulation/openttd/openttd-0.7.4.ebuild,v 1.1 2009/12/09 17:03:30 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="OpenTTD is a clone of Transport Tycoon Deluxe"
+HOMEPAGE="http://www.openttd.org/"
+SRC_URI="http://binaries.openttd.org/releases/${PV}/${P}-source.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="alsa debug dedicated iconv icu +png +truetype zlib"
+RESTRICT="test"
+
+DEPEND="
+ !dedicated? (
+ media-libs/libsdl[audio,X,video]
+ icu? ( dev-libs/icu )
+ truetype? (
+ media-libs/fontconfig
+ media-libs/freetype:2
+ sys-libs/zlib
+ )
+ )
+ iconv? ( virtual/libiconv )
+ png? ( media-libs/libpng )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}
+ !dedicated? (
+ alsa? ( media-sound/alsa-utils )
+ )"
+
+src_configure() {
+ local myopts
+
+ use debug && myopts="${myopts} --enable-debug=3"
+
+ if use dedicated ; then
+ myopts="${myopts} --enable-dedicated"
+ else
+ use alsa && myopts="${myopts} --with-midi=/usr/bin/aplaymidi"
+ myopts="${myopts}
+ $(use_with truetype freetype)
+ $(use_with icu)
+ --with-sdl"
+ fi
+ if use png || { use !dedicated && use truetype; } || use zlib ; then
+ myopts="${myopts} --with-zlib"
+ else
+ myopts="${myopts} --without-zlib"
+ fi
+
+ # there is an allegro interface available as well as sdl, but
+ # the configure for it looks broken so the sdl interface is
+ # always built instead.
+ myopts="${myopts} --without-allegro"
+
+ # configure is a hand-written bash-script, so econf will not work
+ ./configure \
+ --disable-strip \
+ --prefix-dir=/ \
+ --binary-dir="${GAMES_BINDIR}" \
+ --data-dir="${GAMES_DATADIR}/${PN}" \
+ --install-dir="${D}" \
+ --icon-dir=/usr/share/pixmaps \
+ --menu-dir=/usr/share/applications \
+ --icon-theme-dir=/usr/share/icons/hicolor \
+ --man-dir=/usr/share/man/man6 \
+ --doc-dir=/usr/share/doc/${PF} \
+ --menu-group="Game;Simulation;" \
+ ${myopts} \
+ $(use_with iconv) \
+ $(use_with png) \
+ || die "configure failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use dedicated ; then
+ newinitd "${FILESDIR}"/${PN}.initd ${PN}
+ rm -rf "${D}"/usr/share/{applications,icons,pixmaps}
+ fi
+ rm -f "${D}"/usr/share/doc/${PF}/COPYING
+ prepalldocs
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+
+ elog
+ elog "In order to play, you must copy the following 6 files from "
+ elog "a version of TTD to ${GAMES_DATADIR}/${PN}/data/."
+ elog
+ elog "From the WINDOWS version you need: "
+ elog " sample.cat trg1r.grf trgcr.grf trghr.grf trgir.grf trgtr.grf"
+ elog "OR from the DOS version you need: "
+ elog " SAMPLE.CAT TRG1.GRF TRGC.GRF TRGH.GRF TRGI.GRF TRGT.GRF"
+ elog
+ elog "File names are case sensitive so make sure they are "
+ elog "correct for whichever version you have."
+ elog
+
+ if use dedicated ; then
+ ewarn "Warning: The init script will kill all running openttd"
+ ewarn "processes when run, including any running client sessions!"
+ else
+ if use alsa ; then
+ elog "You have emerged with 'aplaymidi' for playing MIDI."
+ elog "You have to set the environment variable ALSA_OUTPUT_PORTS."
+ elog "Available ports can be listed by using 'aplaymidi -l'."
+ else
+ elog "alsa not in USE so music will not be played during the game."
+ fi
+ fi
+}