summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-06-29 03:00:12 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-06-29 03:00:12 +0000
commit20c00f3d15a27d654a7b0ef659c4f8134b3f0768 (patch)
tree1d575ecb0665b1a55307aaf77dd3f27eaec1477d /games-sports/bygfoot/bygfoot-2.2.0.ebuild
parentdev-dotnet/ikvm: switching from ecj to javac (bug #183526) (diff)
downloadgentoo-2-20c00f3d15a27d654a7b0ef659c4f8134b3f0768.tar.gz
gentoo-2-20c00f3d15a27d654a7b0ef659c4f8134b3f0768.tar.bz2
gentoo-2-20c00f3d15a27d654a7b0ef659c4f8134b3f0768.zip
Version bump
(Portage version: 2.1.3_rc5)
Diffstat (limited to 'games-sports/bygfoot/bygfoot-2.2.0.ebuild')
-rw-r--r--games-sports/bygfoot/bygfoot-2.2.0.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/games-sports/bygfoot/bygfoot-2.2.0.ebuild b/games-sports/bygfoot/bygfoot-2.2.0.ebuild
new file mode 100644
index 000000000000..686fa63e0bdd
--- /dev/null
+++ b/games-sports/bygfoot/bygfoot-2.2.0.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/bygfoot/bygfoot-2.2.0.ebuild,v 1.1 2007/06/29 03:00:12 nyhm Exp $
+
+inherit eutils games
+
+MY_P=${P}-source
+DESCRIPTION="GTK+2 Soccer Management Game"
+HOMEPAGE="http://bygfoot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:$(gnulocaledir):/usr/share/locale:' \
+ -e '/PACKAGE_LOCALE_DIR/s:\$(prefix)/\$(DATADIRNAME):/usr/share:' \
+ po/Makefile.in.in src/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-gstreamer \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO UPDATE
+ newicon support_files/pixmaps/bygfoot_icon.png ${PN}.png
+ make_desktop_entry ${PN} Bygfoot
+ prepgamesdirs
+}