summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-05-29 21:59:42 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-05-29 21:59:42 +0000
commit498602da979d24d02516cde14dada19e6c417860 (patch)
treecb74706244bcf774f98ca119a9d5872bf11302cf /games-sports
parentBug 223973 (diff)
downloadgentoo-2-498602da979d24d02516cde14dada19e6c417860.tar.gz
gentoo-2-498602da979d24d02516cde14dada19e6c417860.tar.bz2
gentoo-2-498602da979d24d02516cde14dada19e6c417860.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-sports')
-rw-r--r--games-sports/bygfoot/ChangeLog10
-rw-r--r--games-sports/bygfoot/bygfoot-2.2.1.ebuild49
2 files changed, 57 insertions, 2 deletions
diff --git a/games-sports/bygfoot/ChangeLog b/games-sports/bygfoot/ChangeLog
index 6dbbcc561088..6c5fa3f1ce7e 100644
--- a/games-sports/bygfoot/ChangeLog
+++ b/games-sports/bygfoot/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-sports/bygfoot
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-sports/bygfoot/ChangeLog,v 1.17 2007/06/29 03:00:12 nyhm Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/bygfoot/ChangeLog,v 1.18 2008/05/29 21:59:42 mr_bones_ Exp $
+
+*bygfoot-2.2.1 (29 May 2008)
+
+ 29 May 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +bygfoot-2.2.1.ebuild:
+ version bump
*bygfoot-2.2.0 (29 Jun 2007)
diff --git a/games-sports/bygfoot/bygfoot-2.2.1.ebuild b/games-sports/bygfoot/bygfoot-2.2.1.ebuild
new file mode 100644
index 000000000000..f40c6fe2471c
--- /dev/null
+++ b/games-sports/bygfoot/bygfoot-2.2.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-sports/bygfoot/bygfoot-2.2.1.ebuild,v 1.1 2008/05/29 21:59:42 mr_bones_ Exp $
+
+inherit eutils games
+
+MY_P=${P}-source
+DESCRIPTION="GTK+2 Soccer Management Game"
+HOMEPAGE="http://bygfoot.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND=">=x11-libs/gtk+-2
+ virtual/libintl"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+S=${WORKDIR}/${MY_P}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e 's:$(gnulocaledir):/usr/share/locale:' \
+ -e '/PACKAGE_LOCALE_DIR/s:\$(prefix)/\$(DATADIRNAME):/usr/share:' \
+ po/Makefile.in.in src/Makefile.in \
+ || die "sed failed"
+}
+
+src_compile() {
+ egamesconf \
+ --disable-dependency-tracking \
+ --disable-gstreamer \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog README TODO UPDATE
+ newicon support_files/pixmaps/bygfoot_icon.png ${PN}.png
+ make_desktop_entry ${PN} Bygfoot
+ prepgamesdirs
+}