summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-09-28 15:15:58 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-09-28 15:15:58 +0000
commitbe9c34b9c29300606a650e39010f19cafbb4a720 (patch)
treebcdcf4952ebd6f8cd7a4b1a6ffc709a88c3ff2a5 /games-strategy/coldwar-demo
parentNew pango (diff)
downloadgentoo-2-be9c34b9c29300606a650e39010f19cafbb4a720.tar.gz
gentoo-2-be9c34b9c29300606a650e39010f19cafbb4a720.tar.bz2
gentoo-2-be9c34b9c29300606a650e39010f19cafbb4a720.zip
Revision bump to remove fetch restriction. Updated ebuild by Paul Bredbury <brebs@sent.com>. Closing bug #142016.
(Portage version: 2.1.2_pre1-r4)
Diffstat (limited to 'games-strategy/coldwar-demo')
-rw-r--r--games-strategy/coldwar-demo/ChangeLog9
-rw-r--r--games-strategy/coldwar-demo/coldwar-demo-1-r1.ebuild73
-rw-r--r--games-strategy/coldwar-demo/files/digest-coldwar-demo-1-r13
3 files changed, 84 insertions, 1 deletions
diff --git a/games-strategy/coldwar-demo/ChangeLog b/games-strategy/coldwar-demo/ChangeLog
index e19e832f3dab..21e25e9acfd5 100644
--- a/games-strategy/coldwar-demo/ChangeLog
+++ b/games-strategy/coldwar-demo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for games-strategy/coldwar-demo
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar-demo/ChangeLog,v 1.3 2006/05/22 18:12:42 wolf31o2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar-demo/ChangeLog,v 1.4 2006/09/28 15:15:58 wolf31o2 Exp $
+
+*coldwar-demo-1-r1 (28 Sep 2006)
+
+ 28 Sep 2006; Chris Gianelloni <wolf31o2@gentoo.org>
+ -coldwar-demo-1.ebuild, +coldwar-demo-1-r1.ebuild:
+ Revision bump to remove fetch restriction. Updated ebuild by Paul Bredbury
+ <brebs@sent.com>. Closing bug #142016.
22 May 2006; Chris Gianelloni <wolf31o2@gentoo.org> coldwar-demo-1.ebuild:
Demo->(Demo) for bug #133836.
diff --git a/games-strategy/coldwar-demo/coldwar-demo-1-r1.ebuild b/games-strategy/coldwar-demo/coldwar-demo-1-r1.ebuild
new file mode 100644
index 000000000000..43a9b725abe9
--- /dev/null
+++ b/games-strategy/coldwar-demo/coldwar-demo-1-r1.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/coldwar-demo/coldwar-demo-1-r1.ebuild,v 1.1 2006/09/28 15:15:58 wolf31o2 Exp $
+
+inherit eutils games
+
+MY_PN=${PN%-demo}
+
+DESCRIPTION="Third-person sneaker like Splinter Cell"
+HOMEPAGE="http://linuxgamepublishing.com/info.php?id=coldwar"
+SRC_URI="http://demofiles.linuxgamepublishing.com/coldwar/coldwar-demo.run"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+RESTRICT="strip"
+
+RDEPEND="virtual/opengl
+ x86? (
+ media-libs/libogg
+ media-libs/openal
+ media-libs/libvorbis
+ media-libs/smpeg
+ dev-libs/glib
+ x11-libs/libX11
+ x11-libs/libXext )
+ amd64? (
+ app-emulation/emul-linux-x86-sdl
+ app-emulation/emul-linux-x86-xlibs
+ app-emulation/emul-linux-x86-medialibs )"
+DEPEND=""
+
+S=${WORKDIR}
+dir=${GAMES_PREFIX_OPT}/${PN}
+
+QA_TEXTRELS="${dir:1}/lib/libSDL-1.2.so.0.7.2
+ ${dir:1}/lib/libSDL-1.2.so.0"
+
+src_unpack() {
+ unpack_makeself
+ unpack ./data/data.tar.gz
+
+ mv bin/Linux/x86/${MY_PN}_demo .
+ mv bin/Linux/x86/bin/meng bin
+
+ rm -r bin/{Linux,*BSD} lgp_* setup.* data/data.tar.gz
+}
+
+src_install() {
+ insinto "${dir}"
+ doins -r * || die "doins -r * failed"
+ rm "${D}/${dir}"/{${MY_PN}_demo,bin/{launcher,meng}}
+
+ exeinto "${dir}"
+ doexe ${MY_PN}_demo || die "doexe ${MY_PN}_demo failed"
+ exeinto "${dir}/bin"
+ doexe bin/{launcher,meng} || die "doexe bin failed"
+
+ games_make_wrapper ${PN} ./${MY_PN}_demo "${dir}" "${dir}"
+ newicon icon.xpm ${PN}.xpm || die "newicon failed"
+ make_desktop_entry ${PN} "Cold War (Demo)" ${PN}.xpm
+
+ prepgamesdirs
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ elog "The instruction manual is available as:"
+ elog " http://demofiles.linuxgamepublishing.com/coldwar/manual.pdf"
+ echo
+ einfo "To play the game, run: ${PN}"
+}
diff --git a/games-strategy/coldwar-demo/files/digest-coldwar-demo-1-r1 b/games-strategy/coldwar-demo/files/digest-coldwar-demo-1-r1
new file mode 100644
index 000000000000..5f2160f2c668
--- /dev/null
+++ b/games-strategy/coldwar-demo/files/digest-coldwar-demo-1-r1
@@ -0,0 +1,3 @@
+MD5 e46ca7b1dac2bd53b75c455080b81e07 coldwar-demo.run 354684447
+RMD160 e43e7c7b30d53599a2a309c9a9bf6f7b8994262f coldwar-demo.run 354684447
+SHA256 769ca25da2f095e85e594ee09343ea20bf353e75f3bce362b937c2fae04c52aa coldwar-demo.run 354684447