summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2007-01-16 16:21:18 +0000
committerAlfredo Tupone <tupone@gentoo.org>2007-01-16 16:21:18 +0000
commit15a88b014dc6e653da631af35dcf41cced12f7b7 (patch)
treec449f962f3d13422171093781c5515f861469a0b /games-strategy/dark-oberon/files
parentInclude look&feel settings in the .jar file again, this time unpack them from... (diff)
downloadgentoo-2-15a88b014dc6e653da631af35dcf41cced12f7b7.tar.gz
gentoo-2-15a88b014dc6e653da631af35dcf41cced12f7b7.tar.bz2
gentoo-2-15a88b014dc6e653da631af35dcf41cced12f7b7.zip
New ebuild. Bug #96781
(Portage version: 2.1.1-r2)
Diffstat (limited to 'games-strategy/dark-oberon/files')
-rw-r--r--games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-gcc41.patch111
-rw-r--r--games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-gentoo.patch43
-rw-r--r--games-strategy/dark-oberon/files/digest-dark-oberon-1.0.2_rc13
3 files changed, 157 insertions, 0 deletions
diff --git a/games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-gcc41.patch b/games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-gcc41.patch
new file mode 100644
index 000000000000..a579debe71f4
--- /dev/null
+++ b/games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-gcc41.patch
@@ -0,0 +1,111 @@
+--- src/donet.h.old 2007-01-16 13:53:05.000000000 +0100
++++ src/donet.h 2007-01-16 13:53:20.000000000 +0100
+@@ -489,7 +489,7 @@
+ /** Exception throwed when there was an error with resolving hostname. */
+ class ResolveException {};
+
+- TNET_RESOLVER::TNET_RESOLVER ();
++ TNET_RESOLVER ();
+
+ static std::string GetHostName ();
+
+--- src/dofight.h.old 2007-01-16 13:53:31.000000000 +0100
++++ src/dofight.h 2007-01-16 13:53:43.000000000 +0100
+@@ -230,7 +230,7 @@
+ void SetProtection(const float new_value)
+ {if (new_value > 1.0f) protection = 1.0f; else if (new_value < 0) protection = 0; else protection = new_value;};
+
+- TDEFENSE::TDEFENSE()
++ TDEFENSE()
+ { armour = 0; protection = 0; }
+
+ private:
+--- src/doraces.h.old 2007-01-16 13:53:50.000000000 +0100
++++ src/doraces.h 2007-01-16 13:54:02.000000000 +0100
+@@ -755,7 +755,7 @@
+ //!<Sets if unit can walk on source or building can be built on source when is empty.
+ void SetHideable(bool hide) {hideable = hide;};
+ //!<Tests whether position is available for this kind of the building.
+- bool TSOURCE_ITEM::IsPositionAvailable(int pos_x, int pos_y);
++ bool IsPositionAvailable(int pos_x, int pos_y);
+
+ //! Specifies on which terrains it is able to build the item.
+ TINTERVAL<TTERRAIN_ID> buildable[DAT_SEGMENTS_COUNT];
+--- src/dodraw.h.old 2007-01-16 13:54:12.000000000 +0100
++++ src/dodraw.h 2007-01-16 13:54:25.000000000 +0100
+@@ -140,7 +140,7 @@
+ void SetProjection(TPROJECTION_TYPE projection);
+ void Update();
+
+- TPROJECTION::TPROJECTION() { SetProjection(PRO_MENU); };
++ TPROJECTION() { SetProjection(PRO_MENU); };
+ };
+
+
+--- src/dounits.h.old 2007-01-16 13:54:41.000000000 +0100
++++ src/dounits.h 2007-01-16 13:55:05.000000000 +0100
+@@ -1094,7 +1094,7 @@
+
+ TSOURCE_UNIT * FindNewSource(TPOSITION_3D position);
+ //bool FindNewSource(TPOSITION_3D position);
+- TSOURCE_UNIT * TWORKER_UNIT::IsSourceOnPosition(int pos_x, int pos_y);
++ TSOURCE_UNIT * IsSourceOnPosition(int pos_x, int pos_y);
+
+ //! Constructor.
+ TWORKER_UNIT(int uplayer, int ux, int uy, int uz, int udirection, TFORCE_ITEM *mi, int new_unit_id, bool global_unit)
+--- src/dowalk.h.old 2007-01-16 13:55:13.000000000 +0100
++++ src/dowalk.h 2007-01-16 13:55:39.000000000 +0100
+@@ -270,7 +270,7 @@
+ bool TestLastPathPosition(void); //!< Tests if a_stem is last step.
+ TPOSITION_3D GetGoalPosition(); //!<Get goal of the path.
+ TPATH_LIST* CreateCopy(int shift_x, int shift_y, int shift_z); //!<The path list create copy of the itself with shift.
+- double TPATH_LIST::CountTime(TFORCE_UNIT *unit); //!<Counts the time, which unit spends on the exact way.
++ double CountTime(TFORCE_UNIT *unit); //!<Counts the time, which unit spends on the exact way.
+ void DecreaseSteps(int st_count) { steps -= st_count;}; //! Decreases variable steps, used when building is build, unit cant go to the goal, but just near the newly built building.
+ void IncreaseASteps(); //!< Increases actuall step
+ void DecreaseASteps(); //!< Decrease actuall step
+@@ -297,10 +297,10 @@
+ //! Coordinates in the map, each step of the path is storaged in this array.
+ TPOSITION_3D path_pos[WLK_NODES_NUM];
+
+- TPATH_NODE::TPATH_NODE(TPATH_NODE *first, TPOSITION_3D adding); //!< Adding constructor.
+- TPATH_NODE::TPATH_NODE(TPOSITION_3D goal); //!< Constructor.
++ TPATH_NODE(TPATH_NODE *first, TPOSITION_3D adding); //!< Adding constructor.
++ TPATH_NODE(TPOSITION_3D goal); //!< Constructor.
+ private:
+- TPATH_NODE::TPATH_NODE(TPATH_NODE &origin, int sx, int sy, int sz); //!< Constructor creates copy with shift.
++ TPATH_NODE(TPATH_NODE &origin, int sx, int sy, int sz); //!< Constructor creates copy with shift.
+ friend TPATH_LIST* TPATH_LIST::CreateCopy(int, int, int);
+ };
+
+--- src/doconfig.h.old 2007-01-16 13:55:48.000000000 +0100
++++ src/doconfig.h 2007-01-16 13:56:01.000000000 +0100
+@@ -211,7 +211,7 @@
+ GLubyte pr_warfog_color[4]; //!< Precomputed warfog color and alfa-channel. [-128..127]
+ double pr_expected_frame_duration; //!< Precomputed expected frame duration from max_frame_rate. [seconds]
+
+- TCONFIG::TCONFIG();
++ TCONFIG();
+ };
+
+
+--- src/doengine.h.old 2007-01-16 13:56:08.000000000 +0100
++++ src/doengine.h 2007-01-16 13:56:25.000000000 +0100
+@@ -212,7 +212,7 @@
+ std::string GetRacIdName (std::string name);
+ std::string GetRacName (std::string id_name);
+
+- std::string TMAP_INFO_LIST::GetMapName (std::string id_name);
++ std::string GetMapName (std::string id_name);
+
+ TMAP_INFO_LIST (void) { map_list = NULL; rac_list = NULL;};
+ ~TMAP_INFO_LIST (void) { ClearMapList(); ClearRacList();};
+@@ -276,7 +276,7 @@
+ order_panel = NULL;
+ }
+
+- TPANEL_INFO::TPANEL_INFO() { Clear(); }
++ TPANEL_INFO() { Clear(); }
+ };
+
+ extern TPANEL_INFO panel_info;
diff --git a/games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-gentoo.patch b/games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-gentoo.patch
new file mode 100644
index 000000000000..7570442d2029
--- /dev/null
+++ b/games-strategy/dark-oberon/files/dark-oberon-1.0.2_rc1-gentoo.patch
@@ -0,0 +1,43 @@
+--- src/doconfig.h.old 2007-01-16 16:17:17.000000000 +0100
++++ src/doconfig.h 2007-01-16 16:17:58.000000000 +0100
+@@ -40,7 +40,7 @@
+
+ /** Filename of the configuration file.
+ * @sa DATA_DIR */
+-#define CFG_FILE_NAME (user_dir + DATA_DIR "config.cfg").c_str()
++#define CFG_FILE_NAME (user_dir + "config.cfg").c_str()
+
+ /** Default configuration's screen resolution. From this value the
+ * TCONFIG::width and TCONFIG::height are set. */
+--- src/dologs.h.old 2007-01-16 16:17:26.000000000 +0100
++++ src/dologs.h 2007-01-16 16:18:12.000000000 +0100
+@@ -37,7 +37,7 @@
+ * Directory, where log files are created.
+ * @note Macro is only available if #LOG_TO_LOGFILES is specified.
+ */
+-# define LOG_PATH (user_dir + DATA_DIR "logs/").c_str()
++# define LOG_PATH (user_dir + "logs/").c_str()
+ /**
+ * Filename of the error log #err_log.
+ * @note Macro is only available if #LOG_TO_LOGFILES is specified.
+--- src/Makefile.old 2007-01-16 16:50:19.000000000 +0100
++++ src/Makefile 2007-01-16 16:51:39.000000000 +0100
+@@ -1,12 +1,15 @@
+ SOUND ?= 0
+ DEBUG ?= 0
+
+-CPP = g++ $(CPPFLAGS) $(INCLUDES) $(DEFINES)
++CPP = $(CXX) $(CXXFLAGS) $(INCLUDES) $(DEFINES)
+ CPPFLAGS = -g -Wall -O
+-DEFINES = -DDATA_DIR='""' -DUNIX=1 -DSOUND=$(SOUND) -DDEBUG=$(DEBUG)
++DEFINES = -DDATA_DIR='"$(GAMES_DATADIR)/$(PN)/"' -DUNIX=1 -DSOUND=$(SOUND) -DDEBUG=$(DEBUG)
+ INCLUDES = -I/usr/X11R6/include -I/usr/X11R6/include/GL -I../libs
+ LIBPATHS = -L/usr/X11R6/lib -L/usr/lib -L/usr/local/lib -L../libs
+-LIBRARIES = -pthread -lglfw -lGL -lX11 -lGLU
++LIBRARIES = -pthread -lglfw -lGL -lX11 -lGLU -lXxf86vm
++ifneq ($(SOUND),0)
++LIBRARIES += -lfmod
++endif
+ OBJECTS = doalloc.o doberon.o dobuildings.o doconfig.o dodata.o dodraw.o doengine.o doevents.o dofactories.o dofight.o dofile.o dofollower.o doforces.o dohost.o doipc.o dolayout.o doleader.o dologs.o domap.o domapunits.o domouse.o donet.o doplayers.o doraces.o doschemes.o doselection.o dosimpletypes.o dosound.o dosources.o dounits.o dowalk.o doworkers.o glfont.o glgui.o tga.o utils.o
+ TARGETS = ../dark-oberon
+
diff --git a/games-strategy/dark-oberon/files/digest-dark-oberon-1.0.2_rc1 b/games-strategy/dark-oberon/files/digest-dark-oberon-1.0.2_rc1
new file mode 100644
index 000000000000..2f4f77821b00
--- /dev/null
+++ b/games-strategy/dark-oberon/files/digest-dark-oberon-1.0.2_rc1
@@ -0,0 +1,3 @@
+MD5 62e5f4593b282b630a06675127afc840 dark-oberon-1.0.2-RC1.tar.gz 28487655
+RMD160 078de205c884ff1255b9600c9a763d526fed066d dark-oberon-1.0.2-RC1.tar.gz 28487655
+SHA256 d867bac1f75c844a005d1f873059090d25f9f266730fcd7d0d261a5b84a420b1 dark-oberon-1.0.2-RC1.tar.gz 28487655