summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-08-31 05:18:07 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-08-31 05:18:07 +0000
commitda46f74983fe5a0ac82ac1ae72e41a0c47d8abe2 (patch)
treebd4bd7f3e8045dd98aac0c7de259a123a4157b70 /games-strategy/galaxyhack
parentold (diff)
downloadgentoo-2-da46f74983fe5a0ac82ac1ae72e41a0c47d8abe2.tar.gz
gentoo-2-da46f74983fe5a0ac82ac1ae72e41a0c47d8abe2.tar.bz2
gentoo-2-da46f74983fe5a0ac82ac1ae72e41a0c47d8abe2.zip
patch to build with gcc4.3 submitted by Bert Karwatzki via bug #232069
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-strategy/galaxyhack')
-rw-r--r--games-strategy/galaxyhack/ChangeLog8
-rw-r--r--games-strategy/galaxyhack/files/galaxyhack-1.74-gcc43.patch12
-rw-r--r--games-strategy/galaxyhack/galaxyhack-1.74.ebuild7
3 files changed, 22 insertions, 5 deletions
diff --git a/games-strategy/galaxyhack/ChangeLog b/games-strategy/galaxyhack/ChangeLog
index 439e403b9c1b..8511e69cd70f 100644
--- a/games-strategy/galaxyhack/ChangeLog
+++ b/games-strategy/galaxyhack/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/galaxyhack
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/galaxyhack/ChangeLog,v 1.5 2007/11/10 00:47:17 tupone Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/galaxyhack/ChangeLog,v 1.6 2008/08/31 05:18:06 mr_bones_ Exp $
+
+ 31 Aug 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/galaxyhack-1.74-gcc43.patch, galaxyhack-1.74.ebuild:
+ patch to build with gcc4.3 submitted by Bert Karwatzki via bug #232069
*galaxyhack-1.74 (10 Nov 2007)
diff --git a/games-strategy/galaxyhack/files/galaxyhack-1.74-gcc43.patch b/games-strategy/galaxyhack/files/galaxyhack-1.74-gcc43.patch
new file mode 100644
index 000000000000..eeb64d12e587
--- /dev/null
+++ b/games-strategy/galaxyhack/files/galaxyhack-1.74-gcc43.patch
@@ -0,0 +1,12 @@
+diff -aur src.old/JSDL.cpp src/JSDL.cpp
+--- src.old/JSDL.cpp 2008-07-17 18:31:38.000000000 +0200
++++ src/JSDL.cpp 2008-07-17 19:19:39.000000000 +0200
+@@ -20,7 +20,7 @@
+ #include <cstdlib>
+ #include <fstream>
+ #include <stdexcept>
+-
++#include <cstring>
+ using std::runtime_error;
+ using std::memcpy;
+
diff --git a/games-strategy/galaxyhack/galaxyhack-1.74.ebuild b/games-strategy/galaxyhack/galaxyhack-1.74.ebuild
index 22281dc5fb35..77c3c7462c84 100644
--- a/games-strategy/galaxyhack/galaxyhack-1.74.ebuild
+++ b/games-strategy/galaxyhack/galaxyhack-1.74.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/galaxyhack/galaxyhack-1.74.ebuild,v 1.1 2007/11/10 00:47:17 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/galaxyhack/galaxyhack-1.74.ebuild,v 1.2 2008/08/31 05:18:06 mr_bones_ Exp $
inherit eutils games
@@ -27,7 +27,8 @@ src_unpack() {
edos2unix Makefile
epatch \
"${FILESDIR}"/${P}-destdirs.patch \
- "${FILESDIR}"/${P}-boost.patch
+ "${FILESDIR}"/${P}-boost.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
sed -i "s:@GAMES_DATADIR@:${GAMES_DATADIR}:" \
Main.cpp \
|| die "sed Main.cpp failed"