summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Gianelloni <wolf31o2@gentoo.org>2006-06-06 21:22:09 +0000
committerChris Gianelloni <wolf31o2@gentoo.org>2006-06-06 21:22:09 +0000
commit2c9c571d182d32777089dd967b913b90a35a0a81 (patch)
tree66060653fd60ecce435fcff79a9929f2188c041f /games-strategy/gwp/gwp-0.4.0.ebuild
parentStable on x86. (diff)
downloadgentoo-2-2c9c571d182d32777089dd967b913b90a35a0a81.tar.gz
gentoo-2-2c9c571d182d32777089dd967b913b90a35a0a81.tar.bz2
gentoo-2-2c9c571d182d32777089dd967b913b90a35a0a81.zip
Initial import. Original ebuild by James Jones <jcjones@ufl.edu> and edited by me. Updated ebuild provided by Tom Wesley <tom@tomaw.org> and edited by me. Closing bug #56533.
(Portage version: 2.1_rc3-r2)
Diffstat (limited to 'games-strategy/gwp/gwp-0.4.0.ebuild')
-rw-r--r--games-strategy/gwp/gwp-0.4.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/games-strategy/gwp/gwp-0.4.0.ebuild b/games-strategy/gwp/gwp-0.4.0.ebuild
new file mode 100644
index 000000000000..17a79f937a75
--- /dev/null
+++ b/games-strategy/gwp/gwp-0.4.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/gwp/gwp-0.4.0.ebuild,v 1.1 2006/06/06 21:22:09 wolf31o2 Exp $
+
+inherit eutils games
+
+DESCRIPTION="GNOME client for the classic PBEM strategy game VGA Planets 3"
+HOMEPAGE="http://gwp.lunix.com.ar"
+SRC_URI="http://gwp.lunix.com.ar/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="python opengl"
+
+DEPEND="
+ =x11-libs/gtk+-2*
+ =gnome-base/libgnomeui-2*
+ =gnome-base/libglade-2*
+ app-text/scrollkeeper
+ dev-libs/libpcre
+ opengl? ( =dev-python/pygtk-2*
+ =x11-libs/gtkglext-1* )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${P}-gcc41.patch"
+}
+
+src_compile() {
+ egamesconf \
+ $(use_enable opengl gtkglext) \
+ $(use_enable python) \
+ || die "Error: econf failed!"
+ emake || die "Error: emake failed!"
+}
+
+src_install () {
+ make DESTDIR=${D} localstatedir=${D}/var/games/gwp install || die "Error: install failed"
+ dodoc AUTHORS COPYING ChangeLog README TODO
+ doicon ${PN}.png
+ make_desktop_entry gwp "Gnome WarPad"
+ prepgamesdirs
+}