summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-04-16 05:18:43 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-04-16 05:18:43 +0000
commit56f32b6187660ca8942cc300fef0765070dfcbb0 (patch)
tree9df4946a99086a10ab8a0d6d5d024a179defa0cc /games-strategy/naev/naev-0.5.3.ebuild
parentInitial commit. (diff)
downloadgentoo-2-56f32b6187660ca8942cc300fef0765070dfcbb0.tar.gz
gentoo-2-56f32b6187660ca8942cc300fef0765070dfcbb0.tar.bz2
gentoo-2-56f32b6187660ca8942cc300fef0765070dfcbb0.zip
Version bump.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'games-strategy/naev/naev-0.5.3.ebuild')
-rw-r--r--games-strategy/naev/naev-0.5.3.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/games-strategy/naev/naev-0.5.3.ebuild b/games-strategy/naev/naev-0.5.3.ebuild
new file mode 100644
index 000000000000..243650a5b0f0
--- /dev/null
+++ b/games-strategy/naev/naev-0.5.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/naev/naev-0.5.3.ebuild,v 1.1 2012/04/16 05:18:43 ssuominen Exp $
+
+EAPI=2
+inherit gnome2-utils games
+
+DESCRIPTION="A 2D space trading and combat game, in a similar vein to Escape Velocity"
+HOMEPAGE="http://code.google.com/p/naev/"
+SRC_URI="mirror://sourceforge/naev/${P}.tar.bz2
+ mirror://sourceforge/naev/ndata-${PV}"
+
+LICENSE="GPL-2 GPL-3 public-domain CCPL-Attribution-3.0 CCPL-Attribution-ShareAlike-3.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug +mixer +openal"
+
+RDEPEND="media-libs/libsdl[X,audio,video]
+ dev-libs/libxml2
+ >=media-libs/freetype-2
+ >=media-libs/libvorbis-1.2.1
+ >=media-libs/libpng-1.2:0
+ media-libs/sdl-image[png]
+ virtual/glu
+ virtual/opengl
+ mixer? ( media-libs/sdl-mixer )
+ openal? ( media-libs/openal )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_unpack() {
+ unpack ${P}.tar.bz2
+}
+
+src_configure() {
+ egamesconf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-dependency-tracking \
+ $(use_enable debug) \
+ $(use_with openal) \
+ $(use_with mixer sdlmixer)
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ appicondir=/usr/share/pixmaps \
+ Graphicsdir=/usr/share/applications \
+ install || die
+
+ insinto "${GAMES_DATADIR}"/${PN}
+ newins "${DISTDIR}"/ndata-${PV} ndata || die
+
+ local res
+ for res in 16 32 64 128; do
+ insinto /usr/share/icons/hicolor/${res}x${res}/apps
+ newins extras/logos/logo${res}.png naev.png || die
+ done
+
+ rm -f "${D}"/usr/share/doc/${PF}/LICENSE
+ prepalldocs
+
+ prepgamesdirs
+}
+
+pkg_preinst() {
+ games_pkg_preinst
+ gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ games_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}