summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2007-04-04 20:28:56 +0000
committerTristan Heaven <nyhm@gentoo.org>2007-04-04 20:28:56 +0000
commit14efc5b4ccbc414a31fe27531f5acb7c145be6b8 (patch)
tree59261fbae60b390db8d0edf7843c5e65c9e0ef47 /games-strategy/outerspace
parentadded ~alpha keyword (diff)
downloadgentoo-2-14efc5b4ccbc414a31fe27531f5acb7c145be6b8.tar.gz
gentoo-2-14efc5b4ccbc414a31fe27531f5acb7c145be6b8.tar.bz2
gentoo-2-14efc5b4ccbc414a31fe27531f5acb7c145be6b8.zip
use games_get_libdir
(Portage version: 2.1.2.3)
Diffstat (limited to 'games-strategy/outerspace')
-rw-r--r--games-strategy/outerspace/files/digest-outerspace-0.5.593
-rw-r--r--games-strategy/outerspace/outerspace-0.5.59.ebuild42
-rw-r--r--games-strategy/outerspace/outerspace-0.5.61.ebuild15
3 files changed, 7 insertions, 53 deletions
diff --git a/games-strategy/outerspace/files/digest-outerspace-0.5.59 b/games-strategy/outerspace/files/digest-outerspace-0.5.59
deleted file mode 100644
index 070c3045a253..000000000000
--- a/games-strategy/outerspace/files/digest-outerspace-0.5.59
+++ /dev/null
@@ -1,3 +0,0 @@
-MD5 acc185de2b24bc06f6ac49a87aed0354 OuterSpace-0.5.59.tar.gz 1546027
-RMD160 7a24b19a7c9ecb179276fd64440978634a2d81f4 OuterSpace-0.5.59.tar.gz 1546027
-SHA256 b600d80615c2383958632cda5433be280254dac76228a015a4eb3d987d4ee5ba OuterSpace-0.5.59.tar.gz 1546027
diff --git a/games-strategy/outerspace/outerspace-0.5.59.ebuild b/games-strategy/outerspace/outerspace-0.5.59.ebuild
deleted file mode 100644
index bb003645b143..000000000000
--- a/games-strategy/outerspace/outerspace-0.5.59.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.59.ebuild,v 1.4 2007/01/07 10:41:25 tupone Exp $
-
-inherit eutils games
-
-MY_PN=${PN/outerspace/OuterSpace}
-MY_P=${MY_PN}-$PV
-
-DESCRIPTION="on-line strategy game taking place in the dangerous universe"
-HOMEPAGE="http://www.ospace.net/"
-SRC_URI="mirror://sourceforge/ospace/${MY_P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE=""
-
-DEPEND=">=dev-python/pygame-1.7
- >=dev-lang/python-2.4"
-
-S=${WORKDIR}/${MY_P}
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
- -e "s:@GENTOO_LIBDIR@:${GAMES_LIBDIR}/${PN}:" \
- "${FILESDIR}"/${PN} > ${PN} \
- || die "sed failed"
-}
-
-src_install() {
- insinto "${GAMES_LIBDIR}"/${PN}
- doins -r osc.py lib libsrvr || die "doins of libraries failed"
- insinto "${GAMES_DATADIR}"/${PN}
- doins -r res || die "doins of data failed"
- dogamesbin ${PN} || die "dogamesbin failed"
- newicon res/icon32.png ${PN}.png
- make_desktop_entry ${PN} ${MY_PN}
- prepgamesdirs
-}
diff --git a/games-strategy/outerspace/outerspace-0.5.61.ebuild b/games-strategy/outerspace/outerspace-0.5.61.ebuild
index c8a7f299545f..97705f8657ae 100644
--- a/games-strategy/outerspace/outerspace-0.5.61.ebuild
+++ b/games-strategy/outerspace/outerspace-0.5.61.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.61.ebuild,v 1.1 2007/02/26 23:50:32 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/outerspace/outerspace-0.5.61.ebuild,v 1.2 2007/04/04 20:28:55 nyhm Exp $
inherit eutils games
MY_PN=${PN/outerspace/OuterSpace}
-MY_P=${MY_PN}-$PV
-
+MY_P=${MY_PN}-${PV}
DESCRIPTION="on-line strategy game taking place in the dangerous universe"
HOMEPAGE="http://www.ospace.net/"
SRC_URI="mirror://sourceforge/ospace/${MY_P}.tar.gz"
@@ -16,7 +15,7 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
IUSE=""
-DEPEND=">=dev-python/pygame-1.7
+RDEPEND=">=dev-python/pygame-1.7
>=dev-lang/python-2.4"
S=${WORKDIR}/${MY_P}
@@ -25,16 +24,16 @@ src_unpack() {
unpack ${A}
cd "${S}"
sed -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
- -e "s:@GENTOO_LIBDIR@:${GAMES_LIBDIR}/${PN}:" \
+ -e "s:@GENTOO_LIBDIR@:$(games_get_libdir)/${PN}:" \
"${FILESDIR}"/${PN} > ${PN} \
|| die "sed failed"
}
src_install() {
- insinto "${GAMES_LIBDIR}"/${PN}
- doins -r osc.py lib libsrvr || die "doins of libraries failed"
+ insinto "$(games_get_libdir)"/${PN}
+ doins -r osc.py lib libsrvr || die "doins lib failed"
insinto "${GAMES_DATADIR}"/${PN}
- doins -r res || die "doins of data failed"
+ doins -r res || die "doins data failed"
dogamesbin ${PN} || die "dogamesbin failed"
newicon res/icon32.png ${PN}.png
make_desktop_entry ${PN} ${MY_PN}