summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2005-09-09 04:31:13 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2005-09-09 04:31:13 +0000
commitea341617ebcee7f2f6305202c0c7dfae3518bbde (patch)
tree0b3765dd32588cbf78f923fa0b7e8ef6818508ac /games-strategy/wesnoth
parentMarked ~ppc for bug #105206. (diff)
downloadgentoo-2-ea341617ebcee7f2f6305202c0c7dfae3518bbde.tar.gz
gentoo-2-ea341617ebcee7f2f6305202c0c7dfae3518bbde.tar.bz2
gentoo-2-ea341617ebcee7f2f6305202c0c7dfae3518bbde.zip
version bump
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'games-strategy/wesnoth')
-rw-r--r--games-strategy/wesnoth/ChangeLog8
-rw-r--r--games-strategy/wesnoth/Manifest2
-rw-r--r--games-strategy/wesnoth/files/digest-wesnoth-0.9.71
-rw-r--r--games-strategy/wesnoth/wesnoth-0.9.7.ebuild48
4 files changed, 58 insertions, 1 deletions
diff --git a/games-strategy/wesnoth/ChangeLog b/games-strategy/wesnoth/ChangeLog
index b4b77689e1f1..d18d2b13f29e 100644
--- a/games-strategy/wesnoth/ChangeLog
+++ b/games-strategy/wesnoth/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/wesnoth
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.61 2005/08/29 02:57:25 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/ChangeLog,v 1.62 2005/09/09 04:31:13 mr_bones_ Exp $
+
+*wesnoth-0.9.7 (08 Sep 2005)
+
+ 08 Sep 2005; Michael Sterrett <mr_bones_@gentoo.org>
+ +wesnoth-0.9.7.ebuild:
+ version bump
*wesnoth-0.9.6 (29 Aug 2005)
diff --git a/games-strategy/wesnoth/Manifest b/games-strategy/wesnoth/Manifest
index eebf5aab295c..99e9ad84be69 100644
--- a/games-strategy/wesnoth/Manifest
+++ b/games-strategy/wesnoth/Manifest
@@ -1,8 +1,10 @@
MD5 f17b9b8fa07a38914fe1c03268f51678 metadata.xml 158
+MD5 8db58a8f70a15e32d9e253b21466fb7d wesnoth-0.9.7.ebuild 1304
MD5 f9e43f87ccb899434b58e28b0562bc46 wesnoth-0.9.4.ebuild 1304
MD5 8db58a8f70a15e32d9e253b21466fb7d wesnoth-0.9.6.ebuild 1304
MD5 719ea412b7fca1450af74952035f60bb wesnoth-0.9.5.ebuild 1300
MD5 ce59820c66b2fcf3734de1eebb8e42aa ChangeLog 8351
MD5 ea2efbb3f381d538283b68d4f21120a6 files/digest-wesnoth-0.9.4 67
MD5 ed05bdc0d65c5396b06d15c667e260fc files/digest-wesnoth-0.9.6 67
+MD5 fb1fa5b4b8d2cf8cb254199744d05a69 files/digest-wesnoth-0.9.7 67
MD5 71dbed5b6d7ecb9c9c7750acb349f400 files/digest-wesnoth-0.9.5 67
diff --git a/games-strategy/wesnoth/files/digest-wesnoth-0.9.7 b/games-strategy/wesnoth/files/digest-wesnoth-0.9.7
new file mode 100644
index 000000000000..6a0bf8659ceb
--- /dev/null
+++ b/games-strategy/wesnoth/files/digest-wesnoth-0.9.7
@@ -0,0 +1 @@
+MD5 c2c863c58a3eb7de5fce882d8a1944e1 wesnoth-0.9.7.tar.gz 40965266
diff --git a/games-strategy/wesnoth/wesnoth-0.9.7.ebuild b/games-strategy/wesnoth/wesnoth-0.9.7.ebuild
new file mode 100644
index 000000000000..9a62025bd01e
--- /dev/null
+++ b/games-strategy/wesnoth/wesnoth-0.9.7.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/wesnoth/wesnoth-0.9.7.ebuild,v 1.1 2005/09/09 04:31:13 mr_bones_ Exp $
+
+inherit eutils toolchain-funcs flag-o-matic games
+
+DESCRIPTION="A fantasy turn-based strategy game"
+HOMEPAGE="http://www.wesnoth.org/"
+SRC_URI="mirror://sourceforge/wesnoth/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ppc sparc x86"
+IUSE="editor gnome kde lite nls server tools"
+
+DEPEND=">=media-libs/libsdl-1.2.7
+ >=media-libs/sdl-image-1.2
+ >=media-libs/sdl-mixer-1.2
+ >=media-libs/freetype-2
+ media-libs/sdl-net
+ sys-libs/zlib
+ virtual/x11"
+
+src_compile() {
+ filter-flags -ftracer -fomit-frame-pointer
+ if [[ $(gcc-major-version) -eq 3 ]] ; then
+ filter-flags -fstack-protector
+ fi
+ egamesconf \
+ --disable-dependency-tracking \
+ $(use_enable lite) \
+ $(use_enable server) \
+ $(use_enable server campaign-server) \
+ $(use_enable editor) \
+ $(use_enable tools) \
+ $(use_enable nls) \
+ $(use_with gnome) \
+ $(use_with kde) \
+ || die
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "make install failed"
+ mv "${D}${GAMES_DATADIR}/"{icons,applnk,applications} "${D}/usr/share/"
+ dodoc MANUAL changelog
+ prepgamesdirs
+}