summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2008-03-02 07:58:09 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2008-03-02 07:58:09 +0000
commit0d0b940eb005ab7ca16e59b6f55227fec8fb09b9 (patch)
tree2106458a578a7b755d3a54b95518847cee381fb1 /games-strategy
parentadd pkgconfig dep (bug #206126) (diff)
downloadgentoo-2-0d0b940eb005ab7ca16e59b6f55227fec8fb09b9.tar.gz
gentoo-2-0d0b940eb005ab7ca16e59b6f55227fec8fb09b9.tar.bz2
gentoo-2-0d0b940eb005ab7ca16e59b6f55227fec8fb09b9.zip
version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/boswars/ChangeLog8
-rw-r--r--games-strategy/boswars/boswars-2.5.ebuild55
-rw-r--r--games-strategy/boswars/files/boswars-2.5-gentoo.patch29
3 files changed, 91 insertions, 1 deletions
diff --git a/games-strategy/boswars/ChangeLog b/games-strategy/boswars/ChangeLog
index b4ba20a97445..d0fe33be3353 100644
--- a/games-strategy/boswars/ChangeLog
+++ b/games-strategy/boswars/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/boswars
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.6 2008/02/29 19:50:18 carlo Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.7 2008/03/02 07:58:08 mr_bones_ Exp $
+
+*boswars-2.5 (02 Mar 2008)
+
+ 02 Mar 2008; Michael Sterrett <mr_bones_@gentoo.org>
+ +files/boswars-2.5-gentoo.patch, +boswars-2.5.ebuild:
+ version bump
29 Feb 2008; Carsten Lohrke <carlo@gentoo.org> boswars-2.4.1.ebuild:
Remove icon extension from desktop entry to match Icon Theme Specification.
diff --git a/games-strategy/boswars/boswars-2.5.ebuild b/games-strategy/boswars/boswars-2.5.ebuild
new file mode 100644
index 000000000000..7c89d58d4c9c
--- /dev/null
+++ b/games-strategy/boswars/boswars-2.5.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/boswars-2.5.ebuild,v 1.1 2008/03/02 07:58:08 mr_bones_ Exp $
+
+inherit eutils games
+
+DESCRIPTION="Futuristic real-time strategy game"
+HOMEPAGE="http://www.boswars.org/"
+SRC_URI="http://www.boswars.org/dist/releases/${P}-src.tar.gz
+ mirror://gentoo/bos.png"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-lang/lua
+ media-libs/libsdl
+ media-libs/libpng
+ media-libs/libvorbis
+ media-libs/libtheora
+ media-libs/libogg
+ virtual/opengl
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ dev-util/scons"
+
+S=${WORKDIR}/${P}-src
+
+src_unpack() {
+ unpack ${A/bos.png}
+ cd "${S}"
+ rm -f doc/{README-SDL.txt,guichan-copyright.txt}
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ sed -i \
+ -e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
+ engine/include/stratagus.h \
+ || die "sed failed"
+}
+
+src_compile() {
+ scons || die "scons failed"
+}
+
+src_install() {
+ dogamesbin ${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns graphics intro languages maps scripts sounds units \
+ || die "doins failed"
+ doicon "${DISTDIR}"/bos.png
+ make_desktop_entry ${PN} "Bos Wars" bos
+ dodoc CHANGELOG COPYRIGHT.txt README.txt
+ dohtml -r doc/*
+ prepgamesdirs
+}
diff --git a/games-strategy/boswars/files/boswars-2.5-gentoo.patch b/games-strategy/boswars/files/boswars-2.5-gentoo.patch
new file mode 100644
index 000000000000..1c7f35da0760
--- /dev/null
+++ b/games-strategy/boswars/files/boswars-2.5-gentoo.patch
@@ -0,0 +1,29 @@
+--- engine/include/stratagus.h.old 2007-08-04 21:54:17.000000000 +0200
++++ engine/include/stratagus.h 2007-08-04 21:55:20.000000000 +0200
+@@ -188,7 +188,7 @@
+ extern char NameLine[];
+
+ #ifndef STRATAGUS_LIB_PATH
+-#define STRATAGUS_LIB_PATH "." /// Where to find the data files
++#define STRATAGUS_LIB_PATH "@GENTOO_DATADIR@" /// Where to find the data files
+ #endif
+
+ #ifndef STRATAGUS_HOME_PATH
+--- SConstruct.orig 2007-08-10 20:00:53.000000000 -0400
++++ SConstruct 2007-08-10 20:11:07.000000000 -0400
+@@ -183,14 +183,8 @@
+ return 0
+
+ lualibfound = 0
+- if conf.CheckFunc('luaopen_base'):
++ if conf.CheckLibWithHeader('lua', 'lualib.h', 'c'):
+ return 1
+- if conf.CheckLibWithHeader('lualib', 'lualib.h', 'c'):
+- lualibfound = 1
+- elif conf.CheckLibWithHeader('lualib50', 'lualib.h', 'c'):
+- lualibfound = 1
+- elif conf.CheckLibWithHeader('lualib5.0', 'lualib.h', 'c'):
+- lualibfound = 1
+ # the lua library should be after lualib
+ env["LIBS"].remove(found)
+ env.Append(LIBS = found)