summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTristan Heaven <nyhm@gentoo.org>2009-06-21 00:59:07 +0000
committerTristan Heaven <nyhm@gentoo.org>2009-06-21 00:59:07 +0000
commit4628f5d8a9785de1eaedd26aeb7cc4b4c199de9e (patch)
tree856bdd0db8b32809e8994c6d2919f18df9cbc5ed /games-strategy
parentVersion bump. Documentation seems to be no longer available. (diff)
downloadgentoo-2-4628f5d8a9785de1eaedd26aeb7cc4b4c199de9e.tar.gz
gentoo-2-4628f5d8a9785de1eaedd26aeb7cc4b4c199de9e.tar.bz2
gentoo-2-4628f5d8a9785de1eaedd26aeb7cc4b4c199de9e.zip
Fix building with gcc-4.4, bug #273532
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/boswars/ChangeLog8
-rw-r--r--games-strategy/boswars/boswars-2.5.ebuild7
-rw-r--r--games-strategy/boswars/files/boswars-2.5-gcc44.patch20
3 files changed, 30 insertions, 5 deletions
diff --git a/games-strategy/boswars/ChangeLog b/games-strategy/boswars/ChangeLog
index 0d0f67ccbed6..e4ff18226e70 100644
--- a/games-strategy/boswars/ChangeLog
+++ b/games-strategy/boswars/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-strategy/boswars
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.8 2008/05/01 00:21:34 nyhm Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/ChangeLog,v 1.9 2009/06/21 00:59:07 nyhm Exp $
+
+ 21 Jun 2009; Tristan Heaven <nyhm@gentoo.org> boswars-2.5.ebuild,
+ +files/boswars-2.5-gcc44.patch:
+ Fix building with gcc-4.4, bug #273532
01 May 2008; Tristan Heaven <nyhm@gentoo.org>
+files/boswars-2.5-gcc43.patch, boswars-2.5.ebuild:
diff --git a/games-strategy/boswars/boswars-2.5.ebuild b/games-strategy/boswars/boswars-2.5.ebuild
index 35625404f464..c8bb709616c1 100644
--- a/games-strategy/boswars/boswars-2.5.ebuild
+++ b/games-strategy/boswars/boswars-2.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2008 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/boswars-2.5.ebuild,v 1.2 2008/05/01 00:21:34 nyhm Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/boswars/boswars-2.5.ebuild,v 1.3 2009/06/21 00:59:07 nyhm Exp $
inherit eutils games
@@ -33,7 +33,8 @@ src_unpack() {
rm -f doc/{README-SDL.txt,guichan-copyright.txt}
epatch \
"${FILESDIR}"/${P}-gentoo.patch \
- "${FILESDIR}"/${P}-gcc43.patch
+ "${FILESDIR}"/${P}-gcc43.patch \
+ "${FILESDIR}"/${P}-gcc44.patch
sed -i \
-e "s:@GENTOO_DATADIR@:${GAMES_DATADIR}/${PN}:" \
engine/include/stratagus.h \
diff --git a/games-strategy/boswars/files/boswars-2.5-gcc44.patch b/games-strategy/boswars/files/boswars-2.5-gcc44.patch
new file mode 100644
index 000000000000..7d4516883713
--- /dev/null
+++ b/games-strategy/boswars/files/boswars-2.5-gcc44.patch
@@ -0,0 +1,20 @@
+--- engine/pathfinder/astar.cpp
++++ engine/pathfinder/astar.cpp
+@@ -33,6 +33,7 @@
+ -- Includes
+ ----------------------------------------------------------------------------*/
+
++#include <cstdio>
+ #include "stratagus.h"
+ #include "pathfinder.h"
+
+--- engine/stratagus/translate.cpp
++++ engine/stratagus/translate.cpp
+@@ -36,6 +36,7 @@
+
+ #include <map>
+ #include <string>
++#include <cstdio>
+
+ #include "translate.h"
+ #include "iolib.h"